Foxit Reader NOT subject to recent exploits to Adobe vulnerability

Recently we received a number of inquiries regarding the latest Adobe vulnerability; people are concerned whether Foxit Reader is vulnerable to same kind of exploit. We have gathered enough technical information about that vulnerability and confirmed that Foxit Reader is NOT subject to same kind of exploits.

The Adobe vulnerability is caused by some buffer overflow issue within their JBIG2 decoder. Foxit uses our own JBIG2 decoder and it handles those malicious JBIG2 stream gracefully (empty image will be displayed instead of crashing).

More information regarding Adobe vulnerability can be found at or

If you should have any concern over security of PDF and Foxit Reader, feel free to contact us in any way.

Thanks for your attention.