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Security updates available in Foxit PDF Reader 2024.1 and Foxit PDF Editor 2024.1



Release date: March 5, 2024

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 2024.1 and Foxit PDF Editor 2024.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	2023.3.0.23028 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	2023.3.0.23028 and all previous 2023.x versions, 13.0.1.21693 and all previous 13.x versions, 12.1.4.15400 and all previous 12.x versions, 11.2.8.53842 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	(For Version 2023.1 and higher) In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed a potential issue where the application could be exposed to Arbitrary Code Execution vulnerability when executing certain JavaScripts, which attackers could exploit to induce users to execute commands with malicious parameters. The application has optimized the prompt message to enable users to view the complete parameters before executing commands. (CVE-2024-25858)


	
	Kaushik Pal, Cyber Threat Intelligence at CYFIRMA



	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when parsing certain PDF files or handling certain Doc, Annotation, Signature, or AcroForm objects, which attackers could exploit to execute remote code or disclose information. This occurs due to the use of the wild pointer, memory, or object that has been deleted or freed without proper validation. (ZDI-CAN-22499, ZDI-CAN-22576, ZDI-CAN-22592, ZDI-CAN-22593, ZDI-CAN-22632, ZDI-CAN-22633, ZDI-CAN-22634, ZDI-CAN-22636, ZDI-CAN-22637, ZDI-CAN-22638, ZDI-CAN-22639, ZDI-CAN-22640, ZDI-CAN-22641, ZDI-CAN-22642, ZDI-CAN-22704, ZDI-CAN-22705, ZDI-CAN-22706, ZDI-CAN-22707, ZDI-CAN-22709, ZDI-CAN-22720, ZDI-CAN-22721, ZDI-CAN-22733, ZDI-CAN-22742, ZDI-CAN-22745, ZDI-CAN-22799, ZDI-CAN-22800, ZDI-CAN-22807, ZDI-CAN-22808, ZDI-CAN-22811, ZDI-CAN-22821, ZDI-CAN-22797, ZDI-CAN-22877, ZDI-CAN-22798, ZDI-CAN-22947, ZDI-CAN-23002, ZDI-CAN-23013)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Jacky So
	Jinxin from Qihoo 360



	

Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write vulnerability and crash when handing certain U3D files, Doc objects, or 3D objects in AcroForms, which attackers could exploit to execute remote code or disclose information. This occurs as the application encounters an infinite loop when traversing objects in a circular reference, reads or writes data beyond the boundaries of an allocated object/buffer, or converts and uses the pointer that is discrepant with the object type. (ZDI-CAN-22501, ZDI-CAN-22910, ZDI-CAN-22911, ZDI-CAN-22912, ZDI-CAN-22708, ZDI-CAN-22809, ZDI-CAN-22888, ZDI-CAN-23008, ZDI-CAN-23009)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Local Privilege Escalation vulnerability when checking for updates, which attackers could exploit to execute malicious DLL files. This occurs due to the weak permissions on the folder in which the update service is executed.


	
	Alexander Staalgaard of Banshie



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash when playing multimedia in certain PDF files, which attackers could exploit to launch a denial of service. This occurs due to the use of null pointer without proper validation as the application fails to properly handle the situation where the canvas is set as zero in width and length or the “/S” dictionary entry for the rendition object has been modified.


	
	Milan Kyselica



	

Addressed a potential issue where the application could be exposed to Type Confusion vulnerability when handling certain Annotation objects, which attackers could exploit to execute remote code. This occurs as the application improperly handles the annotation object that contains a non-standard “DS” field in the annotation dictionary entry using a type that is incompatible with the intended type. (ZDI-CAN-22818)


	
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 2024.1 and Foxit PDF Reader for Mac 2024.1



Release date: March 5, 2024

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 2024.1 and Foxit PDF Reader for Mac 2024.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	2023.3.0.63083 and all previous 2023.x versions, 13.0.1.61866 and all previous 13.x versions, 12.1.2.55366 and all previous 12.x versions, 11.1.6.0109 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	2023.3.0.63083 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	(For Version 2023.1 and higher) In Foxit PDF Reader for Mac or Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when parsing certain Doc, Annotation, Signature, or AcroForm objects, which attackers could exploit to execute remote code. This occurs due to the use of the wild pointer, memory, or object that has been deleted or freed without proper validation. (ZDI-CAN-22576, ZDI-CAN-22632, ZDI-CAN-22633, ZDI-CAN-22637, ZDI-CAN-22642, ZDI-CAN-22709, ZDI-CAN-22720, ZDI-CAN-22721, ZDI-CAN-22733, ZDI-CAN-22742, ZDI-CAN-22800, ZDI-CAN-22821, ZDI-CAN-22797, ZDI-CAN-22947)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Jacky So
	Jinxin from Qihoo 360



	

Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write vulnerability and crash when handing certain U3D files or Doc objects, which attackers could exploit to execute remote code or disclose information. This occurs as the application reads or writes data beyond the boundaries of an allocated object/buffer, or converts and uses the pointer that is discrepant with the object type. (ZDI-CAN-22911, ZDI-CAN-22912, ZDI-CAN-22809, ZDI-CAN-23008, ZDI-CAN-23009)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash when playing multimedia in certain PDF files, which attackers could exploit to launch a denial of service. This occurs due to the use of null pointer without proper validation as the application fails to properly handle the situation where the canvas is set as zero in width and length or the “/S” dictionary entry for the rendition object has been modified.


	
	Milan Kyselica







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 12.1.4



Release date: January 22, 2024

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 12.1.4, which addresses potential security and stability issues

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	12.1.3.15356 and all previous 12.x versions, 11.2.7.53812 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash when handling certain Doc, Graphic, Signature, Bookmark, or 3D annotation objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer, wild pointer, or object that has been deleted or freed without proper validation. (CVE-2023-51549, CVE-2023-51550, CVE-2023-51552, CVE-2023-51554, CVE-2023-51553, CVE-2023-32616, CVE-2023-41257, CVE-2023-38573, CVE-2023-51555, CVE-2023-51556, CVE-2023-51557, CVE-2023-51558, CVE-2023-51559, CVE-2023-51551, CVE-2023-51562)


	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative
	Kamlapati Choubey of Cisco Talos
	Aleksandar Nikolic and KPC of Cisco Talos



	

Addressed potential issues where the application could be exposed to Arbitrary File Creation vulnerability, which could be exploited by attackers to execute arbitrary code. This occurs as the application directly opens the executable files due to the failure to properly identify the file type that is disallowed to be opened when handling the exportDataObject method of the Doc object. (CVE-2023-40194, CVE-2023-35985)


	
	Kamlapati Choubey of Cisco Talos



	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute arbitrary code. This occurs due to the GDI memory overflow as the application fails to properly handle the user inputs.


	
	Suyue Guo, Wei You from Renmin University of China



	

Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when opening certain PDF files that include the OpenAction method using the relative path with path spoofing techniques, which could be exploited by attackers to deceive users to execute commands to spread malicious code. The application has optimized the Launch File process, including getting the absolute path, restricting the execution of files whose file path exceeds 260 characters, and enlarging the window to display the full path (within 260 characters) of the file to be executed.


	
	Anonymous researcher



	

Addressed a potential issue where the application could be exposed to Type Confusion vulnerability and crash when handling certain Annotation objects, which could be exploited by attackers to execute remote code. This occurs due to the access of illegal memory as the application casts the pointers of different types without inheritance relation and uses them without proper validation. (CVE-2023-51560)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Use-After-Free vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the inconsistency between the exported values and appearance values as the application fails to properly handle the radio button component that is missing the Appearance Dictionary, or due to the use of deleted objects without proper validation. (CVE-2023-42089, CVE-2023-42090, CVE-2023-42091, CVE-2023-42092, CVE-2023-42093, CVE-2023-42094, CVE-2023-42095, CVE-2023-42096, CVE-2023-42097, CVE-2023-42098)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the indirectly obtained objects or empty values returned by certain interfaces when handling the bookmarks or text annotations in certain PDFs.


	
	XP from ZGCLab



	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the saveAs method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-39542)


	
	Kamlapati Choubey of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 11.2.8



Release date: January 22, 2024

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.8, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.7.53812 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash when handling certain Doc, Graphic, Signature, Bookmark, or 3D annotation objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer, wild pointer, or object that has been deleted or freed without proper validation. (CVE-2023-51549, CVE-2023-51550, CVE-2023-51552, CVE-2023-51554, CVE-2023-51553, CVE-2023-32616, CVE-2023-41257, CVE-2023-38573, CVE-2023-51555, CVE-2023-51556, CVE-2023-51557, CVE-2023-51558, CVE-2023-51559, CVE-2023-51551, CVE-2023-51562)


	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative
	Kamlapati Choubey of Cisco Talos
	Aleksandar Nikolic and KPC of Cisco Talos



	

Addressed potential issues where the application could be exposed to Arbitrary File Creation vulnerability, which could be exploited by attackers to execute arbitrary code. This occurs as the application directly opens the executable files due to the failure to properly identify the file type that is disallowed to be opened when handling the exportDataObject method of the Doc object. (CVE-2023-40194, CVE-2023-35985)


	
	Kamlapati Choubey of Cisco Talos



	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute arbitrary code. This occurs due to the GDI memory overflow as the application fails to properly handle the user inputs.


	
	Suyue Guo, Wei You from Renmin University of China



	

Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when opening certain PDF files that include the OpenAction method using the relative path with path spoofing techniques, which could be exploited by attackers to deceive users to execute commands to spread malicious code. The application has optimized the Launch File process, including getting the absolute path, restricting the execution of files whose file path exceeds 260 characters, and enlarging the window to display the full path (within 260 characters) of the file to be executed.


	
	Anonymous researcher



	

Addressed a potential issue where the application could be exposed to Type Confusion vulnerability and crash when handling certain Annotation objects, which could be exploited by attackers to execute remote code. This occurs due to the access of illegal memory as the application casts the pointers of different types without inheritance relation and uses them without proper validation. (CVE-2023-51560)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Use-After-Free vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the inconsistency between the exported values and appearance values as the application fails to properly handle the radio button component that is missing the Appearance Dictionary, or due to the use of deleted objects without proper validation. (CVE-2023-42089, CVE-2023-42090, CVE-2023-42091, CVE-2023-42092, CVE-2023-42093, CVE-2023-42094, CVE-2023-42095, CVE-2023-42096, CVE-2023-42097, CVE-2023-42098)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the indirectly obtained objects or empty values returned by certain interfaces when handling the bookmarks or text annotations in certain PDFs.


	
	XP from ZGCLab



	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the saveAs method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-39542)


	
	Kamlapati Choubey of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].





Security update available in Foxit PDF Editor for Mac 12.1.2



Release date: January 17, 2024

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 12.1.2, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	12.1.1.55342 and all previous 12.x versions, 11.1.5.0913 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 11 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when handling certain Doc, Graphic, Signature, or Bookmark objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer or object that has been deleted or freed without proper validation. (CVE-2023-51554, CVE-2023-51553, CVE-2023-51555, CVE-2023-51559, CVE-2023-51551, CVE-2023-42089, CVE-2023-51550, CVE-2023-51562)

	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative



	
Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the empty values returned by certain interfaces when handling the text annotations in certain PDFs.

	
	XP from ZGCLab







For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PDF Editor for Mac 11.1.6



Release date: January 17, 2024

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.1.6, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.1.5.0913 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the "Help" tab of Foxit PDF Editor for Mac, click on "Check for Updates" and update to the latest version.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when handling certain Doc, Graphic, Signature, or Bookmark objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer or object that has been deleted or freed without proper validation. (CVE-2023-51554, CVE-2023-51553, CVE-2023-51555, CVE-2023-51559, CVE-2023-51551, CVE-2023-42089, CVE-2023-51550, CVE-2023-51562)

	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative



	
Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the empty values returned by certain interfaces when handling the text annotations in certain PDFs.

	
	XP from ZGCLab







For more information, please contact the Foxit Security Response Team at [email protected].
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Security updates available in Foxit PDF Reader 2023.3 and Foxit PDF Editor 2023.3



Release date: November 22, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 2023.3 and Foxit PDF Editor 2023.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	2023.2.0.21408 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	2023.2.0.21408, 2023.1.0.15510, 13.0.0.21632, 12.1.3.15356 and all previous 12.x versions, 11.2.7.53812 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	(For Version 2023.1 and higher) In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash when handling certain Doc, Graphic, Signature, Bookmark, or 3D annotation objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer, wild pointer, or object that has been deleted or freed without proper validation. (CVE-2023-51549, CVE-2023-51550, CVE-2023-51552, CVE-2023-51554, CVE-2023-51553, CVE-2023-32616, CVE-2023-41257, CVE-2023-38573, CVE-2023-51555, CVE-2023-51556, CVE-2023-51557, CVE-2023-51558, CVE-2023-51559, CVE-2023-51551, CVE-2023-51562)


	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative
	Kamlapati Choubey of Cisco Talos
	Aleksandar Nikolic and KPC of Cisco Talos



	

Addressed potential issues where the application could be exposed to Arbitrary File Creation vulnerability, which could be exploited by attackers to execute arbitrary code. This occurs as the application directly opens the executable files due to the failure to properly identify the file type that is disallowed to be opened when handling the exportDataObject method of the Doc object. (CVE-2023-40194, CVE-2023-35985)


	
	Kamlapati Choubey of Cisco Talos



	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute arbitrary code. This occurs due to the GDI memory overflow as the application fails to properly handle the user inputs.


	
	Suyue Guo, Wei You from Renmin University of China



	

Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when opening certain PDF files that include the OpenAction method using the relative path with path spoofing techniques, which could be exploited by attackers to deceive users to execute commands to spread malicious code. The application has optimized the Launch File process, including getting the absolute path, restricting the execution of files whose file path exceeds 260 characters, and enlarging the window to display the full path (within 260 characters) of the file to be executed.


	
	Anonymous researcher



	

Addressed a potential issue where the application could be exposed to Type Confusion vulnerability and crash when handling certain Annotation objects, which could be exploited by attackers to execute remote code. This occurs due to the access of illegal memory as the application casts the pointers of different types without inheritance relation and uses them without proper validation. (CVE-2023-51560)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Out-of-Bounds Read vulnerability, which could be exploited by attackers to disclose information. This occurs as the application fails to properly initialize the allocated pointer when parsing certain PDF files. (CVE-2023-51561)


	
	Mat Powell of Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 2023.3 and Foxit PDF Reader for Mac 2023.3 



Release date: November 22, 2023

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 2023.3 and Foxit PDF Reader for Mac 2023.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	2023.2.0.61611, 2023.1.0.55583, 13.0.0.61829, 12.1.1.55342 and all previous 12.x versions, 11.1.5.0913 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	2023.2.0.61611 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	(For Version 2023.1 and higher) In Foxit PDF Reader for Mac or Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when handling certain Doc, Graphic, Signature, or Bookmark objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer or object that has been deleted or freed without proper validation. (CVE-2023-51554, CVE-2023-51553, CVE-2023-51555, CVE-2023-51559, CVE-2023-51551)


	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 13.0.1



Release date: November 14, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 13.0.1, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	13.0.0.21632, 12.1.3.15356 and all previous 12.x versions, 11.2.7.53812 and all previous 11.x versions, 10.1.12.37872 and earlier 
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-After-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash when handling certain Doc, Graphic, Signature, Bookmark, or 3D annotation objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer, wild pointer, or object that has been deleted or freed without proper validation. (CVE-2023-51549, CVE-2023-51550, CVE-2023-51552, CVE-2023-51554, CVE-2023-51553, CVE-2023-32616, CVE-2023-41257, CVE-2023-38573, CVE-2023-51555, CVE-2023-51556, CVE-2023-51557, CVE-2023-51558, CVE-2023-51559, CVE-2023-51551, CVE-2023-51562)


	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative
	Kamlapati Choubey of Cisco Talos
	Aleksandar Nikolic and KPC of Cisco Talos



	

Addressed potential issues where the application could be exposed to Arbitrary File Creation vulnerability, which could be exploited by attackers to execute arbitrary code. This occurs as the application directly opens the executable files due to the failure to properly identify the file type that is disallowed to be opened when handling the exportDataObject method of the Doc object. (CVE-2023-40194, CVE-2023-35985)


	
	Kamlapati Choubey of Cisco Talos



	

Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute arbitrary code. This occurs due to the GDI memory overflow as the application fails to properly handle the user inputs.


	
	Suyue Guo, Wei You from Renmin University of China



	

Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when opening certain PDF files that include the OpenAction method using the relative path with path spoofing techniques, which could be exploited by attackers to deceive users to execute commands to spread malicious code. The application has optimized the Launch File process, including getting the absolute path, restricting the execution of files whose file path exceeds 260 characters, and enlarging the window to display the full path (within 260 characters) of the file to be executed.


	
	Anonymous researcher



	

Addressed a potential issue where the application could be exposed to Type Confusion vulnerability and crash when handling certain Annotation objects, which could be exploited by attackers to execute remote code. This occurs due to the access of illegal memory as the application casts the pointers of different types without inheritance relation and uses them without proper validation. (CVE-2023-51560)


	
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PDF Editor for Mac 13.0.1



Release date: November 8, 2023

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 13.0.1, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	13.0.0.61829, 12.1.1.55342 and all previous 12.x versions, 11.1.5.0913 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 11 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash when handling certain Doc, Graphic, Signature, or Bookmark objects, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the use of null pointer or object that has been deleted or freed without proper validation. (CVE-2023-51554, CVE-2023-51553, CVE-2023-51555, CVE-2023-51559, CVE-2023-51551)

	
	XP from ZGCLab
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 11.2.7



Release date: September 27, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.7, which addresses potential security and stability issues

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.6.53790 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	

Addressed potential issues where the application could be exposed to Use-after-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the access of null pointer/wild pointer or reference to the object that has been deleted without proper validation when handling certain JavaScripts. (CVE-2023-28744, CVE-2023-38111, CVE-2023-38107, CVE-2023-38109, CVE-2023-38113, CVE-2023-38114, CVE-2023-38112, CVE-2023-38110, CVE-2023-38115, CVE-2023-38117, CVE-2023-27379, CVE-2023-33866, CVE-2023-32664, CVE-2023-33876)


	
	Aleksandar Nikolic of Cisco Talos
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative
	Aleksandar Nikolic and Kamlapati Choubey of Cisco Talos



	

Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information. This is caused by the access violation as the application reads the bytes beyond the range of the stream or uses the color components (defined in the color space dictionary) that are inconsistent with the actual ones for the image object when converting the color space of an image. (CVE-2023-38105, CVE-2023-38106, CVE-2023-38108, CVE-2023-38116)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Arbitrary File Read vulnerability, which could be exploited by attackers to disclose files in the target system. This occurs as the application fails to properly validate the type of attachment when calling the methods (with file attachments specified) to create annotations.


	
	@j00sean



	

Addressed potential issues where the application could be exposed to Arbitrary File Deletion vulnerability, which could be exploited by attackers to delete the private files in the current user context. This occurs as the application fails to validate the file type and deletes the target file improperly without checking its existence in the user system when calling certain JavaScripts to export PDFs.


	
	@j00sean



	

Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability and crash when handling certain PDF files that include signatures. This occurs as the application verifies the signatures concurrently in a multi-threaded environment and overwrites the data multiple times. (CVE-2023-38119)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the access violation as the application fails to handle the abnormal parameters properly when rendering the annotation pop-up notes in certain PDF files. (CVE-2023-38118)


	
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 2023.2 and Foxit PDF Editor 2023.2



Release date: September 12, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 2023.2 and Foxit PDF Editor 2023.2, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.1.3.15356 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	2023.1.0.15510, 12.1.3.15356 and all previous 12.x versions, 11.2.7.53812 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	(For Version 2023.1) In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update”.
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	

Addressed potential issues where the application could be exposed to Use-After-Free vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the inconsistency between the exported values and appearance values as the application fails to properly handle the radio button component that is missing the Appearance Dictionary, or due to the use of deleted objects without proper validation. (CVE-2023-42089, CVE-2023-42090, CVE-2023-42091, CVE-2023-42092, CVE-2023-42093, CVE-2023-42094, CVE-2023-42095, CVE-2023-42096, CVE-2023-42097, CVE-2023-42098)


	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the indirectly obtained objects or empty values returned by certain interfaces when handling the bookmarks or text annotations in certain PDFs.


	
	XP from ZGCLab



	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the saveAs method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-39542)


	
	Kamlapati Choubey of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 13.0



Release date: September 12, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 13.0, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.1.3.15356 and all previous 12.x versions, 11.2.6.53790 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-After-Free vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the inconsistency between the exported values and appearance values as the application fails to properly handle the radio button component that is missing the Appearance Dictionary, or due to the use of deleted objects without proper validation. (CVE-2023-42089, CVE-2023-42090, CVE-2023-42091, CVE-2023-42092, CVE-2023-42093, CVE-2023-42094, CVE-2023-42095, CVE-2023-42096, CVE-2023-42097, CVE-2023-42098)

	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to launch a Denial of Service attack. This occurs as the application fails to properly validate the indirectly obtained objects or empty values returned by certain interfaces when handling the bookmarks or text annotations in certain PDFs.


	
	XP from ZGCLab



	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the saveAs method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-39542)


	
	Kamlapati Choubey of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 12.1.1 and Foxit PDF Reader for Mac 12.1.1



Release date: July 25, 2023

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 12.1.1 and Foxit PDF Reader for Mac 12.1.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	12.1.0.1229 and all previous 12.x versions, 11.1.4.1121 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	12.1.0.1229 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader for Mac or Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 11 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-after-Free or Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the access of null pointer/wild pointer or reference to the object that has been deleted without proper validation when handling certain JavaScripts. (CVE-2023-28744, CVE-2023-38111, CVE-2023-38107, CVE-2023-38109, CVE-2023-38113, CVE-2023-38112, CVE-2023-38110, CVE-2023-38117)

	
	Aleksandar Nikolic of Cisco Talos
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be terminated by force when data overflow was detected in XFA JavaScripts.


	
	Philip Kolvenbach of Fraunhofer Institute for Secure Information Technology (SIT)







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 12.1.3 and Foxit PDF Editor 12.1.3



Release date: July 19, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.1.3 and Foxit PDF Editor 12.1.3, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.1.2.15332 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.1.2.15332 and all previous 12.x versions, 11.2.6.53790 and all previous 11.x versions, 10.1.12.37872 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application could be exposed to Use-after-Free, Out-of-Bounds Read, or Type Confusion vulnerability and crash, which could be exploited by attackers to execute remote code or disclose information. This occurs due to the access of null pointer/wild pointer or reference to the object that has been deleted without proper validation when handling certain JavaScripts. (CVE-2023-28744, CVE-2023-38111, CVE-2023-38107, CVE-2023-38109, CVE-2023-38113, CVE-2023-38114, CVE-2023-38112, CVE-2023-38110, CVE-2023-38115, CVE-2023-38117, CVE-2023-27379, CVE-2023-33866, CVE-2023-32664, CVE-2023-33876)

	
	Aleksandar Nikolic of Cisco Talos
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative
	Aleksandar Nikolic and Kamlapati Choubey of Cisco Talos



	
Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information. This is caused by the access violation as the application reads the bytes beyond the range of the stream or uses the color components (defined in the color space dictionary) that are inconsistent with the actual ones for the image object when converting the color space of an image. (CVE-2023-38105, CVE-2023-38106, CVE-2023-38108, CVE-2023-38116)

	
	Anonymous working with Trend Micro Zero Day Initiative



	
Addressed potential issues where the application could be exposed to Arbitrary File Read vulnerability, which could be exploited by attackers to disclose files in the target system. This occurs as the application fails to properly validate the type of attachment when calling the methods (with file attachments specified) to create annotations.

	
	@j00sean



	
Addressed potential issues where the application could be exposed to Arbitrary File Deletion vulnerability, which could be exploited by attackers to delete the private files in the current user context. This occurs as the application fails to validate the file type and deletes the target file improperly without checking its existence in the user system when calling certain JavaScripts to export PDFs.

	
	@j00sean



	

Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability and crash when handling certain PDF files that include signatures. This occurs as the application verifies the signatures concurrently in a multi-threaded environment and overwrites the data multiple times. (CVE-2023-38119)


	
	Anonymous working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the access violation as the application fails to handle the abnormal parameters properly when rendering the annotation pop-up notes in certain PDF files. (CVE-2023-38118)


	
	Anonymous working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 10.1.12



Release date: Jun 16, 2023

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.12, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.11.37866 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website. 






Vulnerability details

	Brief
	Acknowledgement

	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the exportXFAData method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-27363)


	
	Andrea Micalizzi aka rgod working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability and crash when parsing certain XLS or DOC files. This occurs as the application opens the XLS or DOC file with the default permissions and allows for the execution of macros without proper restrictions or consents from users. (CVE-2023-27364, CVE-2023-27365)


	
	kimiya working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference or Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the access of null pointer or freed memory without proper validation when handling certain JavaScripts. (CVE-2023-27366)


	
	Suyue Guo, Wei You from Renmin University of China
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Local Privilege Escalation vulnerability. This occurs as the original executable file of the registered service with system-level permissions can be hijacked by users with normal permissions when the application is installed in a non-standard directory.


	
	Will Dormann of Vul Labs



	

Addressed a potential issue where the application could be terminated by force when data overflow was detected in XFA JavaScripts.


	
	Philip Kolvenbach of Fraunhofer Institute for Secure Information Technology (SIT)







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 11.2.6



Release date: May 31, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.6, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.5.53785 and all previous 11.x versions, 10.1.11.37866 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the exportXFAData method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-27363)


	
	Andrea Micalizzi aka rgod working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability and crash when parsing certain XLS or DOC files. This occurs as the application opens the XLS or DOC file with the default permissions and allows for the execution of macros without proper restrictions or consents from users. (CVE-2023-27364, CVE-2023-27365)


	
	kimiya working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference or Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the access of null pointer or freed memory without proper validation when handling certain JavaScripts. (CVE-2023-27366)


	
	Suyue Guo, Wei You from Renmin University of China
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Local Privilege Escalation vulnerability. This occurs as the original executable file of the registered service with system-level permissions can be hijacked by users with normal permissions when the application is installed in a non-standard directory.


	
	Will Dormann of Vul Labs



	

Addressed a potential issue where the application could be terminated by force when data overflow was detected in XFA JavaScripts.


	
	Philip Kolvenbach of Fraunhofer Institute for Secure Information Technology (SIT)







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 12.1.2 and Foxit PDF Editor 12.1.2



Release date: April 19, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.1.2 and Foxit PDF Editor 12.1.2, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.1.1.15289 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.1.1.15289 and all previous 12.x versions, 11.2.5.53785 and all previous 11.x versions, 10.1.11.37866 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	

Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability when handling certain JavaScripts. This occurs as the application fails to validate the cPath parameter in the exportXFAData method and is thus forced to write to the Startup folder with an .hta file that can execute arbitrary code after a restart. (CVE-2023-27363)


	
	Andrea Micalizzi aka rgod working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability and crash when parsing certain XLS or DOC files. This occurs as the application opens the XLS or DOC file with the default permissions and allows for the execution of macros without proper restrictions or consents from users. (CVE-2023-27364, CVE-2023-27365)


	
	kimiya working with Trend Micro Zero Day Initiative



	

Addressed potential issues where the application could be exposed to Null Pointer Dereference or Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the access of null pointer or freed memory without proper validation when handling certain JavaScripts. (CVE-2023-27366)


	
	Suyue Guo, Wei You from Renmin University of China
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative



	

Addressed a potential issue where the application could be exposed to Local Privilege Escalation vulnerability. This occurs as the original executable file of the registered service with system-level permissions can be hijacked by users with normal permissions when the application is installed in a non-standard directory.


	
	Will Dormann of Vul Labs



	

Addressed a potential issue where the application could be terminated by force when data overflow was detected in XFA JavaScripts.


	
	Philip Kolvenbach of Fraunhofer Institute for Secure Information Technology (SIT)







For more information, please contact the Foxit Security Response Team at [email protected].





Security updates available in Foxit PhantomPDF 10.1.11



Release date: Mar 16, 2023

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.11, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.10.37854 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write vulnerability and crash when opening certain PDFs that contain JavaScripts with too much text specified in certain controls, which could be exploited by attackers to execute arbitrary code. This occurs due to the access of data outside the bounds as the application fails to validate the length of the input parameter when calling certain API functions from the GDI library.
		Suyue Guo, Wei You from Renmin University of China



	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-43649)
		Anonymous working with Trend
Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2023-27331, CVE-2023-27330, CVE-2023-27329)
		Anonymous working with Trend Micro
Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].





Security updates available in Foxit PDF Editor 11.2.5



Release date: March 08, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.5, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.4.53774 and all previous 11.x versions, 10.1.10.37854 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write vulnerability and crash when opening certain PDFs that contain JavaScripts with too much text specified in certain controls, which could be exploited by attackers to execute arbitrary code. This occurs due to the access of data outside the bounds as the application fails to validate the length of the input parameter when calling certain API functions from the GDI library.
		Suyue Guo, Wei You from Renmin University of China



	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-43649)
		Anonymous working with Trend
Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2023-27331, CVE-2023-27330, CVE-2023-27329)
		Anonymous working with Trend Micro
Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].





Security updates available in Foxit PDF Reader 12.1.1 and Foxit PDF Editor 12.1.1



Release date: February 21, 2023

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.1.1 and Foxit PDF Editor 12.1.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.1.0.15250 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.1.0.15250 and all previous 12.x versions, 11.2.4.53774 and all previous 11.x versions, 10.1.10.37854 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability due to the improper encryption when collecting the user clicks of the banner ads and other potential issues as the web server that stores the advertisement logs and information is outdated (Foxit PDF Reader only).
		Tom van den Enden



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2023-27331, CVE-2023-27330, CVE-2023-27329)
		Anonymous working with Trend Micro 
Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].
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Security updates available in Foxit PhantomPDF 10.1.10



Release date: December 27, 2022

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.10, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.9.37808 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Read Access Violation, Use-after-Free, or Out-of-Bounds Read vulnerability and crash when parsing certain U3D files, which could be exploited by attackers to execute remote code or disclose information. This occurs as the application accesses the array or iterator outside the bounds, or uses the wild pointer or object that has been freed without proper validation. (CVE-2022-43637, CVE-2022-43638, CVE-2022-43639, CVE-2022-43640, CVE-2022-43641)
	
	Milan Kyselica
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the use of null pointer without proper validation when parsing certain PDF files that contain the invalid Page object, or access of the array outside the bounds resulting from the logic error when parsing certain PDF files whose colSpan attribute is set beyond the maximum length allowed.
	
	Park Hyeon (@tree_segment) of TeamH4C
	soiax



	Addressed potential issues where the application could be exposed to Stack Overrun or Stack Exhaustion vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the array access violation when handling certain PDF files containing a field that is formatted as “Percent” with an overly large value, or due to the infinite recursion resulting from the self-referenced object or incorrect hierarchy structure of nodes when handling certain PDF or XFA files.
	
	soiax



	Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability. This occurs as the application fails to validate the file when updating a plugin with the .fzip file.
	
	hujin



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-32774, CVE-2022-38097, CVE-2022-37332, CVE-2022-40129)
	
	Aleksandar Nikolic of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 11.2.4



Release date: December 22, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.4, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.3.53593 and all previous 11.x versions, 10.1.9.37808 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Read Access Violation, Use-after-Free, or Out-of-Bounds Read vulnerability and crash when parsing certain U3D files, which could be exploited by attackers to execute remote code or disclose information. This occurs as the application accesses the array or iterator outside the bounds, or uses the wild pointer or object that has been freed without proper validation. (CVE-2022-43637, CVE-2022-43638, CVE-2022-43639, CVE-2022-43640, CVE-2022-43641)
	
	Milan Kyselica
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the use of null pointer without proper validation when parsing certain PDF files that contain the invalid Page object, or access of the array outside the bounds resulting from the logic error when parsing certain PDF files whose colSpan attribute is set beyond the maximum length allowed.
	
	Park Hyeon (@tree_segment) of TeamH4C
	soiax



	Addressed potential issues where the application could be exposed to Stack Overrun or Stack Exhaustion vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the array access violation when handling certain PDF files containing a field that is formatted as “Percent” with an overly large value, or due to the infinite recursion resulting from the self-referenced object or incorrect hierarchy structure of nodes when handling certain PDF or XFA files.
	
	soiax



	Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability. This occurs as the application fails to validate the file when updating a plugin with the .fzip file.
	
	hujin



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-32774, CVE-2022-38097, CVE-2022-37332, CVE-2022-40129)
	
	Aleksandar Nikolic of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 12.1 and Foxit PDF Editor 12.1



Release date: December 13, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.1 and Foxit PDF Editor 12.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.0.2.12465 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.0.2.12465 and all previous 12.x versions, 11.2.3.53593 and all previous 11.x versions, 10.1.9.37808 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write vulnerability and crash when opening certain PDFs that contain JavaScripts with too much text specified in certain controls, which could be exploited by attackers to execute arbitrary code. This occurs due to the access of data outside the bounds as the application fails to validate the length of the input parameter when calling certain API functions from the GDI library.
		Suyue Guo, Wei You from Renmin University of China



	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-43649)
		Anonymous working with Trend
 Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PDF Editor for Mac 11.1.4 



Release date: November 23, 2022

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.1.4, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.1.3.0920 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PDF Editor for Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash. This occurs as the application uses the null pointer or element in the null array without proper validation when handling certain JavaScripts. 
	
	China Information Technology Innovation Vulnerability Database (CITIVD)



	Addressed potential issues where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain U3D files. This occurs as the application accesses the array outside the bounds. 
	
	Milan Kyselica



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the access of the array outside the bounds resulting from the logic error when parsing certain PDF files whose colSpan attribute is set beyond the maximum length allowed.
	
	Park Hyeon (@tree_segment) of TeamH4C
	soiax



	Addressed potential issues where the application could be exposed to Stack Overrun or Stack Exhaustion vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the array access violation when handling certain PDF files containing a field that is formatted as “Percent” with an overly large value, or due to the infinite recursion resulting from the incorrect hierarchy structure of nodes when handling certain PDF or XFA files.
	
	soiax







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 12.0.2 and Foxit PDF Editor 12.0.2



Release date: November 8, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.0.2 and Foxit PDF Editor 12.0.2, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.0.1.12430 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.0.1.12430, 12.0.0.12394, 11.2.3.53593 and all previous 11.x versions, 10.1.9.37808 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Read Access Violation, Use-after-Free, or Out-of-Bounds Read vulnerability and crash when parsing certain U3D files, which could be exploited by attackers to execute remote code or disclose information. This occurs as the application accesses the array or iterator outside the bounds, or uses the wild pointer or object that has been freed without proper validation. (CVE-2022-43637, CVE-2022-43638, CVE-2022-43639, CVE-2022-43640, CVE-2022-43641)
		Milan Kyselica
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the use of null pointer without proper validation when parsing certain PDF files that contain the invalid Page object, or access of the array outside the bounds resulting from the logic error when parsing certain PDF files whose colSpan attribute is set beyond the maximum length allowed. 
		Park Hyeon (@tree_segment) of TeamH4C
	soiax


	Addressed potential issues where the application could be exposed to Stack Overrun or Stack Exhaustion vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the array access violation when handling certain PDF files containing a field that is formatted as “Percent” with an overly large value, or due to the infinite recursion resulting from the self-referenced object or incorrect hierarchy structure of nodes when handling certain PDF or XFA files.
		soiax


	Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability. This occurs as the application fails to validate the file when updating a plugin with the .fzip file.
		hujin



	Addressed potential issues where the application could be exposed to Use-after-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the use of object or pointer that has been freed when executing certain JavaScripts in PDF files. (CVE-2022-32774, CVE-2022-38097, CVE-2022-37332, CVE-2022-40129) 
		Aleksandar Nikolic of Cisco Talos







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 12.0.2 and Foxit PDF Reader for Mac 12.0.2 



Release date: November 1, 2022

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 12.0.2 and Foxit PDF Reader for Mac 12.0.2, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	12.0.1.0720, 12.0.0.0601, 11.1.3.0920 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	12.0.1.0720 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader for Mac or Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 11 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash. This occurs as the application uses the null pointer or element in the null array without proper validation when handling certain JavaScripts.
	
	China Information Technology Innovation Vulnerability Database (CITIVD)



	Addressed potential issues where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain U3D files. This occurs as the application accesses the array outside the bounds. 
	
	Milan Kyselica



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the access of the array outside the bounds resulting from the logic error when parsing certain PDF files whose colSpan attribute is set beyond the maximum length allowed. 
	
	Park Hyeon (@tree_segment) of TeamH4C
	soiax



	Addressed potential issues where the application could be exposed to Stack Overrun or Stack Exhaustion vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the array access violation when handling certain PDF files containing a field that is formatted as “Percent” with an overly large value, or due to the infinite recursion resulting from the incorrect hierarchy structure of nodes when handling certain PDF or XFA files.
	
	soiax







For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PDF Editor for Mac 11.1.3 



Release date: September 22, 2022

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.1.3, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.1.2.0420 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PDF Editor for Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Uninitialized Variable vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to disclose information. This occurs as the application uses V8 JavaScript Engine in the outdated version that is prone to vulnerabilities. 
	
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 10.1.9



Release date: August 30, 2022

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.9, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.8.37795 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Type Confusion, Use-After-Free, or Uninitialized Variable vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application uses V8 JavaScript Engine in the outdated version that is prone to vulnerabilities. (CVE-2022-37376, CVE-2022-37377, CVE-2022-37378) 
	
	Seungju Oh (@real_as3617) , DoHyun Lee (@l33d0hyun) of Zerocution working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University
	René Freingruber, SEC Consult Vulnerability Lab



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the access of null pointer, handle, or array without proper validation. (CVE-2022-26979, CVE-2022-27944, CVE-2022-27359)
	
	Suyue Guo, Wei You from Renmin University of China



	Addressed potential issues where the application could be exposed to Use-After-Free Information Disclosure or Memory Corruption Remote Code Execution vulnerability and crash. This occurs due to the access of illegal address as the application fails to update the pointer after the container is expanded during the iteration when handling the AFSpecial_KeystrokeEx method. (CVE-2022-37379, CVE-2022-37381)
	
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application does not set the pointer as null after it has been released and releases the pointer again during the subsequent destruction when handling certain PDF files, or fails to handle the abnormal parameters during the process to create database API by calling the functions from Windows system when handling ADBC objects, or transforms objects by force without judging the data type when handling Doc objects. (CVE-2022-37380, CVE-2022-37383, CVE-2022-37388)
	
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative
	soiax working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs due to the access or use of wild pointer or released object without proper validation when handling certain JavaScripts, Doc objects, or AcroForms. (CVE-2022-37382, CVE-2022-37384, CVE-2022-37385, CVE-2022-37389, CVE-2022-37386, CVE-2022-37390, CVE-2022-37387, CVE-2022-37391)
	
	Anonymous working with Trend Micro Zero Day Initiative
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative




	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when parsing the data stream in certain PDF files. This occurs due to the access violation caused by the incorrectly allocated memory as an overflow exists during the memory calculation. (CNVD-C-2022-280049)
	
	China National Vulnerability Database



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information. This occurs as the application fails to properly validate the allocation boundaries for objects when handling certain JavaScripts. (CVE-2022-34873, CVE-2022-34875, CVE-2022-34874)
	
	KMFL working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative




	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs as the application uses the null pointer without proper validation after the Page object has been deleted when opening certain PDF files in the Full Screen mode.
	
	Milan Kyselica







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor 11.2.3



Release date: August 26, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Editor 11.2.3, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor
	11.2.2.53575 and all previous 11.x versions, 10.1.8.37795 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Editor, click on “Help” > “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Type Confusion, Use-After-Free, or Uninitialized Variable vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application uses V8 JavaScript Engine in the outdated version that is prone to vulnerabilities. (CVE-2022-37376, CVE-2022-37377, CVE-2022-37378)
		Seungju Oh (@real_as3617) , DoHyun Lee (@l33d0hyun) of Zerocution working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University
	René Freingruber, SEC Consult Vulnerability Lab



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the access of null pointer, handle, or array without proper validation. (CVE-2022-26979, CVE-2022-27944, CVE-2022-27359)
		Suyue Guo, Wei You from Renmin University of China


	Addressed potential issues where the application could be exposed to Use-After-Free Information Disclosure or Memory Corruption Remote Code Execution vulnerability and crash. This occurs due to the access of illegal address as the application fails to update the pointer after the container is expanded during the iteration when handling the AFSpecial_KeystrokeEx method. (CVE-2022-37379, CVE-2022-37381)
		Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application does not set the pointer as null after it has been released and releases the pointer again during the subsequent destruction when handling certain PDF files, or fails to handle the abnormal parameters during the process to create database API by calling the functions from Windows system when handling ADBC objects, or transforms objects by force without judging the data type when handling Doc objects. (CVE-2022-37380, CVE-2022-37383, CVE-2022-37388)
		Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative
	soiax working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs due to the access or use of wild pointer or released object without proper validation when handling certain JavaScripts, Doc objects, or AcroForms. (CVE-2022-37382, CVE-2022-37384, CVE-2022-37385, CVE-2022-37389, CVE-2022-37386, CVE-2022-37390, CVE-2022-37387, CVE-2022-37391)
		Anonymous working with Trend Micro Zero Day Initiative
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when parsing the data stream in certain PDF files. This occurs due to the access violation caused by the incorrectly allocated memory as an overflow exists during the memory calculation. (CNVD-C-2022-280049)
		China National Vulnerability Database


	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information. This occurs as the application fails to properly validate the allocation boundaries for objects when handling certain JavaScripts. (CVE-2022-34873, CVE-2022-34875, CVE-2022-34874)
		KMFL working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative


	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs as the application uses the null pointer without proper validation after the Page object has been deleted when opening certain PDF files in the Full Screen mode.
		Milan Kyselica






For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit Reader for Linux 2.4.5

 

Release date: August 2, 2022

Platform: Linux

Summary

Foxit has released Foxit Reader for Linux 2.4.5, which address
potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader for Linux
	2.4.4.0910 and earlier
	Linux





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader for Linux, click on “Check for Updates Now” and
update to the latest version.

	Click here to
download the updated version of Foxit Reader for Linux from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability. This occurs as the application executes the destructor under png_safe_execute. (CVE-2019-7317)
		Lian Gao and Heng Yin from University of California, Riverside






For more information, please contact the Foxit Security Response
Team at [email protected].





Security updates available in Foxit PDF Reader 12.0.1 and Foxit PDF Editor 12.0.1



Release date: July 29, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.0.1 and Foxit PDF Editor 12.0.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	12.0.0.12394 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	12.0.0.12394, 11.2.2.53575 and all previous 11.x versions, 10.1.8.37795 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Type Confusion, Use-After-Free, or Uninitialized Variable vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application uses V8 JavaScript Engine in the outdated version that is prone to vulnerabilities. (CVE-2022-37376, CVE-2022-37377, CVE-2022-37378)
		Seungju Oh (@real_as3617) , DoHyun Lee (@l33d0hyun) of Zerocution working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) working with Trend Micro Zero Day Initiative
	 DoHyun Lee(@l33d0hyun) of DNSLab, Korea University working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University
	René Freingruber, SEC Consult Vulnerability Lab



	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash, which could be exploited by attackers to cause a denial of service. This occurs due to the access of null pointer, handle, or array without proper validation. (CVE-2022-26979, CVE-2022-27944, CVE-2022-27359) 
		Suyue Guo, Wei You from Renmin University of China


	Addressed potential issues where the application could be exposed to Use-After-Free Information Disclosure or Memory Corruption Remote Code Execution vulnerability and crash. This occurs due to the access of illegal address as the application fails to update the pointer after the container is expanded during the iteration when handling the AFSpecial_KeystrokeEx method. (CVE-2022-37379, CVE-2022-37381)
		Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs as the application does not set the pointer as null after it has been released and releases the pointer again during the subsequent destruction when handling certain PDF files, or fails to handle the abnormal parameters during the process to create database API by calling the functions from Windows system when handling ADBC objects, or transforms objects by force without judging the data type when handling Doc objects. (CVE-2022-37380, CVE-2022-37383, CVE-2022-37388) 
		Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative
	soiax working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs due to the access or use of wild pointer or released object without proper validation when handling certain JavaScripts, Doc objects, or AcroForms. (CVE-2022-37382, CVE-2022-37384, CVE-2022-37385, CVE-2022-37389, CVE-2022-37386, CVE-2022-37390, CVE-2022-37387, CVE-2022-37391)
		Anonymous working with Trend Micro Zero Day Initiative
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc
	Krishnakant Patil and Ashfaq Ansari - HackSys Inc working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when parsing the data stream in certain PDF files. This occurs due to the access violation caused by the incorrectly allocated memory as an overflow exists during the memory calculation. (CNVD-C-2022-280049)
		China National Vulnerability Database






For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 12.0.1 and Foxit PDF Reader for Mac 12.0.1 



Release date: July 29, 2022

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 12.0.1 and Foxit PDF Reader for Mac 12.0.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	12.0.0.0601, 11.1.2.0420 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	12.0.0.0601, 11.1.2.0420 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader for Mac or Foxit PDF Editor for Mac, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 11 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Uninitialized Variable vulnerability and crash when handling certain JavaScripts, which could be exploited by attackers to disclose information. This occurs as the application uses V8 JavaScript Engine in the outdated version that is prone to vulnerabilities. 
	
	DoHyun Lee(@l33d0hyun) of DNSLab, Korea University







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 12.0 and Foxit PDF Editor 12.0



Release date: June 28, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 12.0 and Foxit PDF Editor 12.0, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	11.2.2.53575 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	11.2.2.53575 and all previous 11.x versions, 10.1.8.37795 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to disclose information. This occurs as the application fails to properly validate the allocation boundaries for objects when handling certain JavaScripts. (CVE-2022-34873, CVE-2022-34875, CVE-2022-34874)
	
	KMFL working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs as the application uses the null pointer without proper validation after the Page object has been deleted when opening certain PDF files in the Full Screen mode. 
	
	Milan Kyselica







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 10.1.8



Release date: June 21, 2022

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.8, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.7.37777 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Null Pointer Dereference Denial of Service vulnerability and crash. This is caused by the parsing error when executing JavaScripts in certain PDF files. (CNVD-C-2021-205525) 
	
	Xu Peng from UCAS and Ying Lingyun from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash. This occurs due to the use of null pointer without proper validation as the application fails to get the CF dictionary when handling certain encrypted PDFs with abnormal encryption dictionary.
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Incremental Saving Attack and Shadow Attack and deliver incorrect signature information when handling certain signed PDF files. This is caused by the parsing error as the parsing engine fails to use the cross-reference information correctly when parsing certain compressed objects. (CVE-2022-25641) 
	
	Raphael Sütterlin, Vladislav Mladenov, Christian Mainka, Simon Rohlmann, and Jörg Schwenk of the Ruhr-Universität Bochum, Chair for Network and Data Security



	Addressed potential issues where the application could be exposed to Type Confusion vulnerability and crash when executing certain JavaScripts. This occurs due to the improper compiling for an Unsigned32 result in the V8 JavaScript Engine. (CVE-2022-30557)
	
	DoHyun Lee(@l33d0hyun)



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure or Use-After-Free Remote Code Execution vulnerability and crash when handling certain Acroforms, Doc objects, or Annotation objects. This occurs as the application uses the pointer/variable/object or accesses the memory that has been freed without proper validation. (CVE-2022-28670, CVE-2022-28669, CVE-2022-28671, CVE-2022-28672, CVE-2022-28673, CVE-2022-28675, CVE-2022-28676, CVE-2022-28674, CVE-2022-28678, CVE-2022-28680, CVE-2022-28679)
	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative




	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash. This occurs due to the use of object that has been freed as the application fails to update the copy of the pointer after a page is deleted when executing the deletePages method. (CVE-2022-28677, CVE-2022-28681, CVE-2022-28683)
	
	Anonymous working with Trend Micro Zero Day Initiative
	KMFL working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs as the application fails to properly validate the allocation boundaries for objects when handling certain JavaScripts. (CVE-2022-28682)
	
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 11.2.2 and Foxit PDF Editor 11.2.2



Release date: May 9, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 11.2.2 and Foxit PDF Editor 11.2.2, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	11.2.1.53537 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	11.2.1.53537 and all previous 11.x versions, 10.1.7.37777 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Null Pointer Dereference Denial of Service vulnerability and crash. This is caused by the parsing error when executing JavaScripts in certain PDF files. (CNVD-C-2021-205525)
	
	Xu Peng from UCAS and Ying Lingyun from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash. This occurs due to the use of null pointer without proper validation as the application fails to get the CF dictionary when handling certain encrypted PDFs with abnormal encryption dictionary. 
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Incremental Saving Attack and Shadow Attack and deliver incorrect signature information when handling certain signed PDF files. This is caused by the parsing error as the parsing engine fails to use the cross-reference information correctly when parsing certain compressed objects. (CVE-2022-25641)
	
	Raphael Sütterlin, Vladislav Mladenov, Christian Mainka, Simon Rohlmann, and Jörg Schwenk of the Ruhr-Universität Bochum, Chair for Network and Data Security



	Addressed potential issues where the application could be exposed to Type Confusion vulnerability and crash when executing certain JavaScripts. This occurs due to the improper compiling for an Unsigned32 result in the V8 JavaScript Engine. (CVE-2022-30557) 
	
	DoHyun Lee(@l33d0hyun)



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure or Use-After-Free Remote Code Execution vulnerability and crash when handling certain Acroforms, Doc objects, or Annotation objects. This occurs as the application uses the pointer/variable/object or accesses the memory that has been freed without proper validation. (CVE-2022-28670, CVE-2022-28669, CVE-2022-28671, CVE-2022-28672, CVE-2022-28673, CVE-2022-28675, CVE-2022-28676, CVE-2022-28674, CVE-2022-28678, CVE-2022-28680, CVE-2022-28679) 
	
	Anonymous working with Trend Micro Zero Day Initiative
	Mat Powell of Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash. This occurs due to the use of object that has been freed as the application fails to update the copy of the pointer after a page is deleted when executing the deletePages method. (CVE-2022-28677, CVE-2022-28681, CVE-2022-28683) 
	
	Anonymous working with Trend Micro Zero Day Initiative
	KMFL working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs as the application fails to properly validate the allocation boundaries for objects when handling certain JavaScripts. (CVE-2022-28682)
	
	Suyue Guo and Wei You from Renmin University of China working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 10.1.7



Release date: March 3, 2022

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.7, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.6.37749 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Stack-Based Buffer Overflow vulnerability and crash. This occurs due to the use of abnormal data without proper validation when handling an XFA file that contains improper attribute values in the node of a widget. (CVE-2022-24954) 
	
	DoHyun Lee(@l33d0hyun) and JaeHyuk Lim
	DoHyun Lee(@l33d0hyun)



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Heap Overflow, Memory Corruption, Null Pointer Dereference, or Stack Buffer Overflow vulnerability and crash when converting certain PDF files to Office files. This occurs as the application reads data outside the bounds, accesses the memory that is modified invalidly, uses the null pointer, or reads or writes the data beyond the stack buffer. (CVE -2021-40729, CVE-2021-44709, ZS-VR-21-106, ZS-VR-21-107, ZS-VR-21-108, ZS-VR-21-109, CVE-2021-44740, CVE-2021-44741, CVE-2021-44708, ZS-VR-21-116)
	
	Kai Lu of Zscaler's ThreatLabz



	Addressed a potential issue where the application could be exposed to Memory Leak or Out-of-Bounds Read/Write vulnerability and crash. This occurs as the V8 JavaScript Engine does not take into account that the value of a variable type can be changed to “NaN” through addition or subtraction of Infinities, and fails to properly check and handle the abnormal data while handling the JavaScript. 
	
	Dongjun shin(@__sindo) 



	Addressed potential issues where the application could be exposed to Null Pointer Dereference or Array Out-of-Bounds vulnerability and crash when parsing certain PDF files. This occurs due to the use of null pointer or invalid object without proper validation. (CVE-2022-25108) 
	
	DoHyun Lee(@l33d0hyun) and SeungJu Oh(@real_as3617)



	Addressed a potential issue where the application could be exposed to Uncontrolled Search Path Element Privilege Escalation vulnerability, which could be exploited by attackers to execute malicious DLL files. This occurs as the application does not specify an absolute path when searching the DLL library. (CVE-2022-24955)
	
	DoHyun Lee(@l33d0hyun)



	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when processing the format specifiers. This occurs as the util.printf function fails to handle the %llx format string properly.
	
	Trifescu Stefan-Octavian



	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read Remote Code Execution vulnerability and crash when deleting pages in certain PDF files using the JavaScript API. This occurs due to the use of freed object or read of data beyond the boundaries as the application incorrectly deletes the page view even though the PDF engine has not successfully deleted the page. (CVE-2022-24359, CVE-2022-24358)
	
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when handling certain Annotation objects, Doc objects or Acroforms. This occurs due to the use of wild pointers or freed objects without proper validation. (CVE-2022-24357, CVE-2022-24360, CVE-2022-24363, CVE-2022-24362, CVE-2021-40420, CVE-2022-24364, CVE-2022-24365, CVE-2022-24366, CVE-2022-24367, CVE-2022-24368) 
	
	Anonymous working with Trend Micro Zero Day Initiative
	Aleksandar Nikolic of Cisco Talos
	Ashfaq Ansari and Krishnakant Patil - HackSys Inc working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write Remote Code Execution vulnerability and crash when parsing certain JPEG2000 or JP2 files with relatively large values in their attributes. This is caused by the memory access violation due to the incorrectly-calculated value as an overflow occurs when calculating the memory size or buffer size to be allocated. (CVE-2022-24361, CVE-2022-24971, CVE-2022-24369, CVE-2022-24907, CVE-2022-24908) 
	
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain U3D files. This occurs due to the use of invalid pointer without proper validation. 
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain PDF files. This occurs as the application gets the null dictionary object since the EFF information getting from the PDF file does not match the actual dictionary name, and uses the null dictionary object without proper validation.
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability and crash when handling certain methods in JavaScript. This is caused by the array out-of-bounds error due to the lack of proper validation for the parameter in the method. (CVE-2022-22150)
	
	Aleksandar Nikolic of Cisco Talos



	Addressed an issue where the application could be exposed to various attacks if the XML configuration file of the iManage 10 plugin's logging function was modified. (CVE-2018-1285)
	







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 11.2.1 and Foxit PDF Editor 11.2.1



Release date: January 28, 2022

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 11.2.1 and Foxit PDF Editor 11.2.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	11.1.0.52543 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	11.2.0.53415 and all previous 11.x versions, 10.1.6.37749 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to to download the updated version of Foxit PDF Editor from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Stack-Based Buffer Overflow vulnerability and crash. This occurs due to the use of abnormal data without proper validation when handling an XFA file that contains improper attribute values in the node of a widget. (CVE-2022-24954) 
	
	DoHyun Lee(@l33d0hyun) and JaeHyuk Lim
	DoHyun Lee(@l33d0hyun)



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Heap Overflow, Memory Corruption, Null Pointer Dereference, or Stack Buffer Overflow vulnerability and crash when converting certain PDF files to Office files. This occurs as the application reads data outside the bounds, accesses the memory that is modified invalidly, uses the null pointer, or reads or writes the data beyond the stack buffer. (CVE -2021-40729, CVE-2021-44709, ZS-VR-21-106, ZS-VR-21-107, ZS-VR-21-108, ZS-VR-21-109, CVE-2021-44740, CVE-2021-44741, CVE-2021-44708, ZS-VR-21-116)
	
	Kai Lu of Zscaler's ThreatLabz



	Addressed a potential issue where the application could be exposed to Memory Leak or Out-of-Bounds Read/Write vulnerability and crash. This occurs as the V8 JavaScript Engine does not take into account that the value of a variable type can be changed to “NaN” through addition or subtraction of Infinities, and fails to properly check and handle the abnormal data while handling the JavaScript. 
	
	Dongjun shin(@__sindo) 



	Addressed potential issues where the application could be exposed to Null Pointer Dereference or Array Out-of-Bounds vulnerability and crash when parsing certain PDF files. This occurs due to the use of null pointer or invalid object without proper validation. (CVE-2022-25108) 
	
	DoHyun Lee(@l33d0hyun) and SeungJu Oh(@real_as3617)



	Addressed a potential issue where the application could be exposed to Uncontrolled Search Path Element Privilege Escalation vulnerability, which could be exploited by attackers to execute malicious DLL files. This occurs as the application does not specify an absolute path when searching the DLL library. (CVE-2022-24955)
	
	DoHyun Lee(@l33d0hyun)



	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when processing the format specifiers. This occurs as the util.printf function fails to handle the %llx format string properly.
	
	Trifescu Stefan-Octavian



	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Read Remote Code Execution vulnerability and crash when deleting pages in certain PDF files using the JavaScript API. This occurs due to the use of freed object or read of data beyond the boundaries as the application incorrectly deletes the page view even though the PDF engine has not successfully deleted the page. (CVE-2022-24359, CVE-2022-24358)
	
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when handling certain Annotation objects, Doc objects or Acroforms. This occurs due to the use of wild pointers or freed objects without proper validation. (CVE-2022-24357, CVE-2022-24360, CVE-2022-24363, CVE-2022-24362, CVE-2021-40420, CVE-2022-24364, CVE-2022-24365, CVE-2022-24366, CVE-2022-24367, CVE-2022-24368) 
	
	Anonymous working with Trend Micro Zero Day Initiative
	Aleksandar Nikolic of Cisco Talos
	Ashfaq Ansari and Krishnakant Patil - HackSys Inc working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write Remote Code Execution vulnerability and crash when parsing certain JPEG2000 or JP2 files with relatively large values in their attributes. This is caused by the memory access violation due to the incorrectly-calculated value as an overflow occurs when calculating the memory size or buffer size to be allocated. (CVE-2022-24361, CVE-2022-24971, CVE-2022-24369, CVE-2022-24907, CVE-2022-24908) 
	
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain U3D files. This occurs due to the use of invalid pointer without proper validation. 
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Read Access Violation vulnerability and crash when parsing certain PDF files. This occurs as the application gets the null dictionary object since the EFF information getting from the PDF file does not match the actual dictionary name, and uses the null dictionary object without proper validation.
	
	Milan Kyselica



	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability and crash when handling certain methods in JavaScript. This is caused by the array out-of-bounds error due to the lack of proper validation for the parameter in the method. (CVE-2022-22150)
	
	Aleksandar Nikolic of Cisco Talos



	Addressed an issue where the application could be exposed to various attacks if the XML configuration file of the iManage 10 plugin's logging function was modified. (CVE-2018-1285)
	







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 11.1.1 and Foxit PDF Reader for Mac 11.1.1 



Release date: January 28, 2022

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.1.1 and Foxit PDF Reader for Mac 11.1.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.1.0.0925 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	11.1.0.0925 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PDF Editor for Mac or Foxit PDF Reader for Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs due to the data access violation caused by the array out-of-bounds error as the application fails to validate the object properly while handling the width attribute of certain XFA widget (CVE-2022-24370). 
	
	DoHyun Lee(@l33d0hyun) working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability and crash. This occurs as the application fails to delete the page object timely after a page has been deleted (CVE-2022-24356). 
	
	DoHyun Lee(@l33d0hyun) working with Trend Micro Zero Day Initiative







For more information, please contact the Foxit Security Response Team at [email protected].











2021

 





Security updates available in Foxit PhantomPDF 10.1.6



Release date: November 29, 2021

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.6, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.5.37672 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Null Pointer Dereference or Read Access Violation vulnerability and crash. This occurs when handling certain malformed PDF files due to the use of null pointer, wild pointer, void pointer, or uninitialized pointer without proper validation. (CNVD-C-2021-205496, CNVD-C-2021-205515, CNVD-C-2021-205541) 
	
	JaeHyuk Lim and DoHyun Lee(@l33d0hyun)
	Milan Kyselica of IstroSec
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed potential issues where the application could be exposed to Pointer Dereference Remote Code Execution or Out-of-Bounds Read/Write vulnerability and crash when converting certain PDF files to Office files. This occurs as the application uses or accesses the freed pointer or uninitialized variable or reads/writes values outside the bounds.
	
	Ariele Caltabiano (kimiya)
	Haboob Lab



	Addressed potential issues where the application could be exposed to NTLM v2 Authentication Leak or Use-after-Free vulnerability and crash. This occurs as the browser add-on converts the URL path by mistake when processing the URL that is not truly accessible, or fails to use the com API properly during the download process. 
	
	j00sean



	Addressed potential issues where the application could be exposed to Use-after-Free, Out-of-Bounds Read, Read Access Violation, Null Pointer Dereference, or Uninitialized Memory Access vulnerability and crash, which could be exploited by attackers to execute remote code, disclose information, or cause denial of service. This occurs due to the use or access of memory, pointer, or object that has been freed without proper validation when handling certain JavaScripts or annotation objects. (CVE-2021-34948/CNVD-C-2021-247425, CVE-2021-34950, CVE-2021-34953, CVE-2021-34952/CNVD-C-2021-247417, CNVD-C-2021-205550, CVE-2021-34968, CVE-2021-34969/CNVD-C-2021-247399, CVE-2021-34972, CNVD-C-2021-247393, CNVD-C-2021-247404, CNVD-C-2021-247448, CNVD-C-2021-247458, CNVD-C-2021-247464, CVE-2021-41780, CVE-2021-41785, CVE-2021-41783, CVE-2021-41782, CVE-2021-41784, CVE-2021-41781, CVE-2021-34974, CVE-2021-34975)
	
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group
	Milan Kyselica of IstroSec
	China National Vulnerability Database
	cor3sm4sh3r working with Volon Cyber Security Pvt Ltd working with Trend Micro Zero Day Initiative
	Steven Seeley of Qihoo 360 Vulcan Team
	Rich working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Use-after-Free, or Type Confusion vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs when handling certain objects since the application transforms objects by force without judging the data type and uses the void pointer or memory without proper validation. (CVE-2021-34949, CVE-2021-34951/CNVD-C-2021-247436, CVE-2021-34954, CVE-2021-34955, CVE-2021-34956, CVE-2021-34957, CVE-2021-34958, CVE-2021-34959, CVE-2021-34965, CVE-2021-34960, CVE-2021-34961, CVE-2021-34962, CVE-2021-34963, CVE-2021-34964, CVE-2021-34966, CVE-2021-34967)
	
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	cor3sm4sh3r working with Volon Cyber Security Pvt Ltd working with Trend Micro Zero Day Initiative
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Arbitrary File Write vulnerability when verifying digital signatures in certain PDF files, which could be exploited by attackers to display the controlled contents. This occurs due to the lack of proper validation for the hidden and incremental data in the digitally signed PDF files. (CVE-2021-40326)
	
	Vladislav Mladenov, Simon Rohlmann, Christian Mainka, and Jörg Schwenk of the Ruhr-Universität Bochum, Chair for Network and Data Security



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash. This occurs when handling JavaScript in certain PDF files due to the access of arrays outside the bounds without proper validation. 
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute



	Addressed potential issues where the application could be exposed to Stack Overflow or Denial of Service vulnerability and crash. This is caused by the infinite loop, infinite mutual recursion or improper buffer management mechanism while handling certain JavaScripts.
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute



	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash when handling certain PDF files that contain illegal dictionary entries or incorrect Outlines (CNVD-C-2021-247433). 
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash. This occurs when getting the embedded fonts in certain PDF files as the bytes read exceed the stream length. (CVE-2021-34976, CVE-2021-34973)
	
	Milan Kyselica of IstroSec working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) and Jeonghoon Shin(@singi21a) of KITRI "BEST OF THE BEST" working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when processing the format specifiers. This occurs as the util.printf function fails to handle the format extension properly. (CVE-2021-34970) 
	
	sindo working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Heap-based Buffer Overflow Remote Code Execution vulnerability and crash. This occurs as the application writes the data based on the wrong region calculated when parsing certain JPEG2000 files. (CVE-2021-34971)
	
	Milan Kyselica of IstroSec working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when handling attachments or submitting forms. This occurs due to the lack of proper validation of the file suffix and file path.
	
	Pontus Keski-Pukkila of Hoxhunt 







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 11.1 and Foxit PDF Editor 11.1



Release date: October 12, 2021

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 11.1 and Foxit PDF Editor 11.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	11.0.1.49938 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	11.0.1.49938, 11.0.0.49893, 10.1.5.37672 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Null Pointer Dereference or Read Access Violation vulnerability and crash. This occurs when handling certain malformed PDF files due to the use of null pointer, wild pointer, void pointer, or uninitialized pointer without proper validation. (CNVD-C-2021-205496, CNVD-C-2021-205515, CNVD-C-2021-205541) 
	
	rwxcode of nsfocus security team
	JaeHyuk Lim and DoHyun Lee(@l33d0hyun)
	Milan Kyselica of IstroSec
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed potential issues where the application could be exposed to Pointer Dereference Remote Code Execution or Out-of-Bounds Read/Write vulnerability and crash when converting certain PDF files to Office files. This occurs as the application uses or accesses the freed pointer or uninitialized variable or reads/writes values outside the bounds.
	
	Ariele Caltabiano (kimiya)
	Haboob Lab



	Addressed potential issues where the application could be exposed to NTLM v2 Authentication Leak or Use-after-Free vulnerability and crash. This occurs as the browser add-on converts the URL path by mistake when processing the URL that is not truly accessible, or fails to use the com API properly during the download process. 
	
	j00sean



	Addressed potential issues where the application could be exposed to Use-after-Free, Out-of-Bounds Read, Read Access Violation, Null Pointer Dereference, or Uninitialized Memory Access vulnerability and crash, which could be exploited by attackers to execute remote code, disclose information, or cause denial of service. This occurs due to the use or access of memory, pointer, or object that has been freed without proper validation when handling certain JavaScripts or annotation objects. (CVE-2021-34948/CNVD-C-2021-247425, CVE-2021-34950, CVE-2021-34953, CVE-2021-34952/CNVD-C-2021-247417, CNVD-C-2021-205550, CVE-2021-34968, CVE-2021-34969/CNVD-C-2021-247399, CVE-2021-34972, CNVD-C-2021-247393, CNVD-C-2021-247404, CNVD-C-2021-247448, CNVD-C-2021-247458, CNVD-C-2021-247464, CVE-2021-41780, CVE-2021-41785, CVE-2021-41783, CVE-2021-41782, CVE-2021-41784, CVE-2021-41781, CVE-2021-34974, CVE-2021-34975)
	
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group
	Milan Kyselica of IstroSec
	China National Vulnerability Database
	cor3sm4sh3r working with Volon Cyber Security Pvt Ltd working with Trend Micro Zero Day Initiative
	Steven Seeley of Qihoo 360 Vulcan Team
	Rich working with Trend Micro Zero Day Initiative



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Use-after-Free, or Type Confusion vulnerability and crash, which could be exploited by attackers to disclose information or execute remote code. This occurs when handling certain objects since the application transforms objects by force without judging the data type and uses the void pointer or memory without proper validation. (CVE-2021-34949, CVE-2021-34951/CNVD-C-2021-247436, CVE-2021-34954, CVE-2021-34955, CVE-2021-34956, CVE-2021-34957, CVE-2021-34958, CVE-2021-34959, CVE-2021-34965, CVE-2021-34960, CVE-2021-34961, CVE-2021-34962, CVE-2021-34963, CVE-2021-34964, CVE-2021-34966, CVE-2021-34967)
	
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	cor3sm4sh3r working with Volon Cyber Security Pvt Ltd working with Trend Micro Zero Day Initiative
	Anonymous working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Arbitrary File Write vulnerability when verifying digital signatures in certain PDF files, which could be exploited by attackers to display the controlled contents. This occurs due to the lack of proper validation for the hidden and incremental data in the digitally signed PDF files. (CVE-2021-40326)
	
	Vladislav Mladenov, Simon Rohlmann, Christian Mainka, and Jörg Schwenk of the Ruhr-Universität Bochum, Chair for Network and Data Security



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash. This occurs when handling JavaScript in certain PDF files due to the access of arrays outside the bounds without proper validation. 
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute



	Addressed potential issues where the application could be exposed to Stack Overflow or Denial of Service vulnerability and crash. This is caused by the infinite loop, infinite mutual recursion or improper buffer management mechanism while handling certain JavaScripts.
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute



	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash when handling certain PDF files that contain illegal dictionary entries or incorrect Outlines (CNVD-C-2021-247433). 
	
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute
	China National Vulnerability Database



	Addressed potential issues where the application could be exposed to Out-of-Bounds Read vulnerability and crash. This occurs when getting the embedded fonts in certain PDF files as the bytes read exceed the stream length. (CVE-2021-34976, CVE-2021-34973)
	
	Milan Kyselica of IstroSec working with Trend Micro Zero Day Initiative
	DoHyun Lee(@l33d0hyun) and Jeonghoon Shin(@singi21a) of KITRI "BEST OF THE BEST" working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when processing the format specifiers. This occurs as the util.printf function fails to handle the format extension properly. (CVE-2021-34970) 
	
	sindo working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Heap-based Buffer Overflow Remote Code Execution vulnerability and crash. This occurs as the application writes the data based on the wrong region calculated when parsing certain JPEG2000 files. (CVE-2021-34971)
	
	Milan Kyselica of IstroSec working with Trend Micro Zero Day Initiative



	Addressed a potential issue where the application could be exposed to Arbitrary File Execution vulnerability when handling attachments or submitting forms. This occurs due to the lack of proper validation of the file suffix and file path.
	
	Pontus Keski-Pukkila of Hoxhunt 







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 11.1 and Foxit PDF Reader for Mac 11.1 



Release date: October 12, 2021

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.1 and Foxit PDF Reader for Mac 11.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.0.1.0719 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	11.0.1.0719 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PDF Editor for Mac or Foxit PDF Reader for Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability. This occurs as the application allows the local programs to be opened by executing certain JavaScripts without proper validation (CVE-2021-45978, CVE-2021-45979, CVE-2021-45980).
	
	DoHyun Lee(@l33d0hyun)



	Addressed a potential issue where the application could be exposed to Null Pointer Dereference vulnerability and crash. This occurs when handling certain malformed PDF files due to the use of null pointer without proper validation. 
	
	JaeHyuk Lim and DoHyun Lee(@l33d0hyun)







For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 10.1.5



Release date: August 26, 2021

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 10.1.5, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	10.1.4.37651 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website..






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write or Null Pointer Dereference vulnerability and crash when parsing certain PDF files. This occurs due to the access violation in the array subscript when storing the offset value for the indirect object because the array size created based on the /Size entry whose value is smaller than the actual maximum indirect object number is not enough to accommodate the data.
	xina1i

DoHyun Lee(l33d0hyun)

Milan Kyselica

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash when processing certain arguments. This occurs due to the access of illegal memory as the application fails to restrict the access to an array outside its bounds when calling the util.scand function. (CVE-2021-38564)
	Xinyu Wan, Yiwei Zhang and Wei You from Renmin University of China

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling certain Javascripts or annotation objects. This occurs due to the use or access of memory, pointer, or object that has been freed without proper validation (CVE-2021-21831, CVE-2021-21870, CVE-2021-34831, CVE-2021-34832, CVE-2021-34847).
	Aleksandar Nikolic of Cisco Talos

Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Arbitrary File Write vulnerability when executing the submitForm function. Attackers could exploit this vulnerability to create arbitrary files in the local system and inject the uncontrolled contents.
	Hou JingYi (@hjy79425575)

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling the annotation objects in certain PDF files if the same Annotation dictionary is referenced in the page structures for different pages. This occurs as multiple annotation objects are associated to the same Annotation dictionary (CVE-2021-34852, CVE-2021-34834, CVE-2021-34835, CVE-2021-34851, CVE-2021-34836, CVE-2021-34837, CVE-2021-34838, CVE-2021-34839, CVE-2021-34840, CVE-2021-34841, CVE-2021-34833, CVE-2021-34842, CVE-2021-34843, CVE-2021-34844, CVE-2021-34845, CVE-2021-34853).
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash when handling certain events of form elements. This occurs due to the use of Field object that has been cleaned up after executing events using the event.target property (CVE-2021-21893).
	Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Stack Overflow vulnerability and crash when parsing XML data with too many embedded nodes. This occurs as the recursion level exceeds the maximum recursion depth when parsing XML nodes using recursion.
	Milan Kyselica

	Addressed a potential issue where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when traversing bookmark nodes in certain PDF files. This occurs due to stack overflow caused by the infinite loop as the application fails to handle the loop condition correctly (CVE-2021-34846).
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Reader 11.0.1 and Foxit PDF Editor 11.0.1



Release date: July 27, 2021

Platform: Windows

Summary

Foxit has released Foxit PDF Reader 11.0.1 and Foxit PDF Editor 11.0.1, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Reader (previously named Foxit Reader)
	11.0.0.49893 and earlier
	Windows

	Foxit PDF Editor (previously named Foxit PhantomPDF)
	11.0.0.49893, 10.1.4.37651 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	In Foxit PDF Reader or Foxit PDF Editor, click on “Help” > “About Foxit PDF Reader” or “About Foxit PDF Editor” > “Check for Update” (for Version 10 and earlier, click on “Help” > “Check for Updates”) to update to the latest version. 
	Click here to download the updated version of Foxit PDF Reader from our website.
	Click here to download the updated version of Foxit PDF Editor from our website. 






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write or Null Pointer Dereference vulnerability and crash when parsing certain PDF files. This occurs due to the access violation in the array subscript when storing the offset value for the indirect object because the array size created based on the /Size entry whose value is smaller than the actual maximum indirect object number is not enough to accommodate the data. 
	xina1i

DoHyun Lee(l33d0hyun)

Milan Kyselica

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash when processing certain arguments. This occurs due to the access of illegal memory as the application fails to restrict the access to an array outside its bounds when calling the util.scand function. (CVE-2021-38564) 
	Xinyu Wan, Yiwei Zhang and Wei You from Renmin University of China

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling certain Javascripts or annotation objects. This occurs due to the use or access of memory, pointer, or object that has been freed without proper validation ( CVE-2021-21831, CVE-2021-21870, CVE-2021-34831, CVE-2021-34832, CVE-2021-34847, CVE-2021-34850, CVE-2021-34849, CVE-2021-34848). 
	Aleksandar Nikolic of Cisco Talos

Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Arbitrary File Write vulnerability when executing the submitForm function. Attackers could exploit this vulnerability to create arbitrary files in the local system and inject the uncontrolled contents. 
	Hou JingYi (@hjy79425575)

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling the annotation objects in certain PDF files if the same Annotation dictionary is referenced in the page structures for different pages. This occurs as multiple annotation objects are associated to the same Annotation dictionary (CVE-2021-34852, CVE-2021-34834, CVE-2021-34835, CVE-2021-34851, CVE-2021-34836, CVE-2021-34837, CVE-2021-34838, CVE-2021-34839, CVE-2021-34840, CVE-2021-34841, CVE-2021-34833, CVE-2021-34842, CVE-2021-34843, CVE-2021-34844, CVE-2021-34845, CVE-2021-34853). 
	Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash when handling certain events of form elements. This occurs due to the use of Field object that has been cleaned up after executing events using the event.target property (CVE-2021-21893). 
	Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Stack Overflow vulnerability and crash when parsing XML data with too many embedded nodes. This occurs as the recursion level exceeds the maximum recursion depth when parsing XML nodes using recursion. 
	Milan Kyselica

	Addressed a potential issue where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when traversing bookmark nodes in certain PDF files. This occurs due to stack overflow caused by the infinite loop as the application fails to handle the loop condition correctly (CVE-2021-34846). 
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PDF Editor for Mac 11.0.1 and Foxit PDF Reader for Mac 11.0.1 



Release date: July 27, 2021

Platform: macOS

Summary

Foxit has released Foxit PDF Editor for Mac 11.0.1 and Foxit PDF Reader for Mac 11.0.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Editor for Mac (previously named Foxit PhantomPDF Mac)
	11.0.0.0510 and earlier
	macOS

	Foxit PDF Reader for Mac (previously named Foxit Reader Mac)
	11.0.0.0510 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PDF Editor for Mac or Foxit PDF Reader for Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PDF Reader for Mac from our website.
	Click here to download the updated version of Foxit PDF Editor for Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Null Pointer Reference Denial of Service vulnerability and crash. This is caused by memory corruption due to the lack of proper validation when handling certain PDF files whose dictionary entries are missing (CNVD-C-2021-95204). 
	China National Vulnerability Database

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling certain Javascripts. This occurs due to the use or access of memory or object that has been freed without proper validation (CVE-2021-21831, CVE-2021-34832). 
	Aleksandar Nikolic of Cisco Talos

Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-after-Free vulnerability and crash when handling certain events of form elements. This occurs due to the use of Field object that has been cleaned up after executing events using the event.target property (CVE-2021-21893). 
	Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read/Write vulnerability and crash when parsing certain PDF files. This occurs due to the access violation in the array subscript when storing the offset value for the indirect object because the array size created based on the /Size entry whose value is smaller than the actual maximum indirect object number is not enough to accommodate the data. 
	Milan Kyselica

	Addressed a potential issue where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when traversing bookmark nodes in certain PDF files. This occurs due to stack overflow caused by the infinite loop as the application fails to handle the loop condition correctly (CVE-2021-34846). 
	ZhangJiaxing(@r0fm1a) from Codesafe Team of Legendsec at Qi'anxin Group working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 10.1.4 and Foxit PhantomPDF 10.1.4



Release date: May 6, 2021

Platform: Windows

Summary

Foxit has released Foxit Reader 10.1.4 and Foxit PhantomPDF 10.1.4, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader
	10.1.3.37598 and earlier
	Windows

	Foxit PhantomPDF
	10.1.3.37598 and all previous 10.x versions, 9.7.5.29616 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Memory Corruption vulnerability and crash when exporting certain PDF files to other formats. This occurs due to the access violation, which could be exploited by attackers to execute remote code. 
	Ariele Caltabiano (kimiya)

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash when handling certain XFA forms or link objects. This is caused by stack overflow as there are too many levels or dead loops during the recursive call of functions (CNVD-C-2020-186243/CNVD-C-2020-186246/CNVD-C-2020-186244/CNVD-C-2020-186248/CNVD-C-2020-186237).
	China National Vulnerability Database

Xuwei Liu

	Addressed potential issues where the application could be exposed to Denial of Service, Null Pointer Reference, Out-of-Bounds Read, Context Level Bypass, Type Confusion, or Buffer Overflow vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs during the implementation of certain functions in JavaScript due to the use of incorrect parameters or objects without proper validation (CNVD-C-2020-305224/CNVD-C-2020-305182/CNVD-C-2020-305095/EIP-2018-0045/CNVD-C-2020-305100/CVE-2021-31461/CVE-2021-31476). 
	Xinyu Wan, Yiwei Zhang, and Wei You from Renmin University of China

China National Vulnerability Database

mnhFly of Aurora Infinity WeiZhen Security Team

Exodus Intelligence

cor3sm4sh3r working with Volon Cyber Security Pvt Ltd working with

Trend Micro Zero Day Initiative

Yongil Lee(@intellee) and Wonyoung Jung(@nonetype) of Diffense

cece working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Arbitrary File Deletion vulnerability due to improper access control. Local attackers could exploit this vulnerability to create a symbolic link and cause arbitrary files to be deleted once the application is uninstalled by an admin user. 
	Dhiraj Mishra (@RandomDhiraj)

	Addressed a potential issue where the application could deliver incorrect signature information for certain PDF files that contained invisible digital signatures. This occurs as the application gets the certificate name in an incorrect order and displays the document owner as the signature author by mistake. 
	Thore Hendrikson

	Addressed potential issues where the application could be exposed to DLL Hijacking vulnerability when it was launched, which could be exploited by attackers to execute remote code by placing a malicious DLL in the specified path directory. This occurs due to the improper behavior while loading libraries, including loading the libraries in the installation directory as precedence when loading system libraries, loading the libraries that are disguised as system libraries in the installation folder without proper validation, and failing to use the fully qualified paths when loading external libraries (CNVD-C-2021-68000/CNVD-C-2021-68502). 
	mnhFly of Aurora Infinity WeiZhen Security Team

China National Vulnerability Database

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write/Read Remote Code Execution or Information Disclosure vulnerability and crash when handling certain JavaScripts or XFA forms. This occurs due to the use of abnormal data that exceeds the maximum size allocated in parameters without proper validation (CVE-2021-31452/CVE-2021-31473). 
	mnhFly of Aurora Infinity WeiZhen Security Team

Yongil Lee(@intellee) and Wonyoung Jung(@nonetype) of Diffense

Yongil Lee(@intellee) and Wonyoung Jung(@nonetype) of Diffense working with Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability when parsing certain PDF files that contain nonstandard /Size key value in the Trailer dictionary. This occurs due to the access of an array whose size is not enough to accommodate the data. 
	xina1i

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash when converting certain PDF files to Microsoft Office files. This occurs as the PDF object data defined in the Cross-Reference Table is corrupted. 
	Haboob Lab

	Addressed potential issues where the application could be exposed to Use-after-Free Remote Code Execution vulnerability and crash when handling certain XFA forms or annotation objects. This occurs due to the use or access of the objects that have been released or deleted (CVE-2021-31441/CVE-2021-31450/CVE-2021-31453/CVE-2021-31451/CVE-2021-31455/CVE-2021-31456/CVE-2021-31457/CVE-2021-31458/CVE-2021-31459/CVE-2021-31460/CVE-2021-21822).


	Yongil Lee and Wonyoung Jung of Diffense

Xu Peng from UCAS and Wang Yanhao from QiAnXin Technology Research Institute working with Trend Micro Zero Day Initiative

Yongil Lee(@intellee) and Wonyoung Jung(@nonetype) of Diffense working with Trend Micro Zero Day Initiative

Aleksandar Nikolic of Cisco Talos


	Addressed potential issues where the application could be exposed to Arbitrary File Write Remote Code Execution vulnerability when executing certain JavaScripts. This occurs as the application fails to restrict the file type and validate the file path in extractPages and CombineFiles functions (EIP-2018-0046/EIP-2019-0006/EIP-2019-0007).
	Exodus Intelligence

	Addressed potential issues where the application could be exposed to SQL Injection Remote Code Execution vulnerability. Attackers could exploit this vulnerability to insert or delete databases by inserting codes at the end of the strings (EIP-2018-0057/EIP-2018-0080/EIP-2018-0081). 
	Exodus Intelligence

	Addressed a potential issue where the application could be exposed to Uninitialized Variable Information Disclosure vulnerability and crash. This occurs due to the array access violation resulting from the discrepant information in the form control when users press the Tab key to get focus on a field and input new text in certain XFA forms. 
	Yongil Lee and Wonyoung Jung of Diffense

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read or Heap-based Buffer Overflow vulnerability and crash, which could be exploited by attackers to execute remote code or disclose sensitive information. This occurs due to the logic error or improper handling of elements when working with certain PDF files that define excessively large value in the file attribute or contain negative leadDigits value in the file attribute (CVE-2021-31454). 
	Yongil Lee and Wonyoung Jung of Diffense

Yongil Lee(@intellee) and Wonyoung Jung(@nonetype) of Diffense working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 10.1.4.37623



Release date: May 6, 2021

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 10.1.4.37623 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	10.1.3.37598 and all previous 10.x versions, 9.7.4.29600 and earlier
	Windows





Solution

Update your Foxit Reader or PhantomPDF to version 10.1 or higher, and then install the latest version of the 3D Plugin Beta by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write, Use-After-Free, or Double Free vulnerability and crash if users were using 3D Plugin Beta, which could be exploited by attackers to execute remote code or disclose sensitive information. This occurs due to the lack of proper validation of illogical data range when handling certain U3D objects embedded in PDF files. (CVE-2021-31469/CVE-2021-31470/CVE-2021-31471/CVE-2021-31472/CVE-2021-31442/CVE-2021-31443/CVE-2021-31444/CVE-2021-31445/CVE-2021-31446/CVE-2021-31447/CVE-2021-31448/CVE-2021-31449/CVE-2021-31467/CVE-2021-31468/CVE-2021-31466/CVE-2021-31465/CVE-2021-31464/CVE-2021-31463/CVE-2021-31462).
	Mat Powell of Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].



Security update available in Foxit Studio Photo 3.6.6.934



Release date: Apr 20, 2021

Platform: Web

Summary

Foxit has a new version of Foxit Studio Photo 3.6.6.934, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Studio Photo
	3.6.6.933 and earlier
	Windows





Solution

Update Foxit Studio Photo to the latest versions by following the instructions below.

	Click here to download the updated version of Foxit Studio Photo.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where remote attackers to execute arbitrary code on the application. This is caused by an uninitialized variable(CVE-2021-31435).
	Francis Provencher {PRL} working with Trend Micro Zero Day Initiative

	Addressed potential issues where remote attackers to execute arbitrary code on the application. There is a potential problem with overwriting buffers in the ARW, JPM, JP2 file's parser. (CVE-2021-31433/ CVE-2021-31434/ CVE-2021-31437).
	Wenguang Jiao working with Trend Micro Zero Day Initiative

Francis Provencher {PRL} working with Trend Micro Zero Day Initiative

	Addressed potential issues where remote attackers to execute arbitrary code on the application. There is a potential problem with overwriting buffers in the parser of the SGI file. (CVE-2021-31436).
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed potential issues where remote attackers to execute arbitrary code on the application. There is a potential problem with overwriting buffers in the parser of the PSP file. (CVE-2021-31438)
	Francis Provencher {PRL} working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PDF SDK for Web 7.6.0



Release date: March 31, 2021

Platform: Web

Summary

Foxit has released Foxit PDF SDK for Web 7.6.0, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF SDK for Web
	7.5.0 and earlier
	Web





Solution

	Update the Foxit PDF SDK for Web to the latest versions by clicking here to download the latest package from our website.






Vulnerability details

	Brief
	Acknowledgement

	Fixed a cross-site scripting security where the JavaScript app.alert() message was taken as HTML code, injected into HTML DOM and execute.
	Luigi Gubello





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 10.1.3 and Foxit PhantomPDF 10.1.3



Release date: March 22, 2021

Platform: Windows

Summary

Foxit has released Foxit Reader 10.1.3 and Foxit PhantomPDF 10.1.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader
	10.1.1.37576 and earlier
	Windows

	Foxit PhantomPDF
	10.1.1.37576 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read vulnerability and crash, which could be exploited by attackers to execute remote code. This occurs due to the improper release of resources when parsing certain JPEG2000 files (CVE-2021-27270).
	cece working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 10.1.3.37598



Release date: March 22, 2021

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 10.1.3.37598 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	10.1.1.37576 and earlier
	Windows





Solution

Update your Foxit Reader or PhantomPDF to version 10.1 or higher, and then install the latest version of the 3D Plugin Beta by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read, Use-After-Free, or Memory Corruption vulnerability and crash if users were using 3D Plugin Beta, which could be exploited by attackers to execute remote code or disclose sensitive information. This occurs when working with certain PDF files that contain 3D objects due to a parse error as the data format recorded in the PDF file is not consistent with the actual one (CVE-2021-27261/CVE-2021-27262/CVE-2021-27263/CVE-2021-27264/CVE-2021-27265/CVE-2021-27266/CVE-2021-27267/CVE-2021-27268/CVE-2021-27271).
	Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash if users were using 3D Plugin Beta, which could be exploited by attackers to execute remote code. This occurs when parsing certain PDF files that contain 3D objects as the number of KeyFrames defined in MOTIONRESOURCE (0xffffff56) block does not match the actual one written (CVE-2021-27269).
	Mat Powell of Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF Mac 4.1.3 and Foxit Reader Mac 4.1.3



Release date: February 2, 2021

Platform: macOS

Summary

Foxit has released Foxit PhantomPDF Mac 4.1.3 and Foxit Reader Mac 4.1.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF Mac
	4.1.1.1123 and earlier
	macOS

	Foxit Reader Mac
	4.1.1.1123 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit PhantomPDF Mac or Foxit Reader Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader Mac from our website. 
	Click here to download the updated version of Foxit PhantomPDF Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Evil Annotation Attack and deliver incorrect validation results when validating certain certified PDF files whose visible content was significantly altered. This occurs as the application fails to identify the objects in the incremental update when the Subtype entry of the Annotation dictionary is set as null.
	Simon Rohlmann, Vladislav Mladenov, Christian Mainka, Jorg Schwenk





For more information, please contact the Foxit Security Response Team at [email protected].
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Security updates available in Foxit PhantomPDF 9.7.5



Release date: December 30, 2020

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 9.7.5 , which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	9.7.4.29600 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash while processing certain XFA templates. This occurs during the process of modifying control attributes and appending nodes as the application fails to validate and uses certain type of object that is explicitly converted from a wrong layout object created by the appended template node (CVE-2020-27860). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Evil Annotation Attack and deliver incorrect validation results when validating certain certified PDF files whose visible content was significantly altered. This occurs as the application fails to identify the objects in the incremental update when the Subtype entry of the Annotation dictionary is set as null.
	Simon Rohlmann, Vladislav Mladenov, Christian Mainka, Jorg Schwenk

	Addressed a potential issue where the application could be exposed to Type Confusion Memory Corruption or Remote Code Execution vulnerability and crash due to the lack of proper validation when an incorrect argument was passed to the app.media.openPlayer function defined in PDF JavaScript API (CVE-2020-13547). 
	Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when executing certain JavaScript in a PDF file. This occurs due to the access or use of pointer or object that has been removed after calling certain JavaScript functions (CVE-2020-13548/CVE-2020-13557/CVE-2020-13560/CVE-2020-13570).
	Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash when opening certain PDF files that contained illegal value in the /Size entry of the Trail dictionary. This occurs due to the array overflow as the illegal value in the /Size entry causes an error in initializing the array size for storing the compression object streams, and an object number which is larger than the initialization value is used as the array index while parsing the cross-reference streams (CVE-2020-28203). 
	Sanjeev Das (IBM Research)





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 10.1.1 and Foxit PhantomPDF 10.1.1



Release date: December 9, 2020

Platform: Windows

Summary

Foxit has released Foxit Reader 10.1.1 and Foxit PhantomPDF 10.1.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader
	10.1.0.37527 and earlier
	Windows

	Foxit PhantomPDF
	10.1.0.37527 and all previous 10.x versions, 9.7.4.29600 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash while processing certain XFA templates. This occurs during the process of modifying control attributes and appending nodes as the application fails to validate and uses certain type of object that is explicitly converted from a wrong layout object created by the appended template node (CVE-2020-27860). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Evil Annotation Attack and deliver incorrect validation results when validating certain certified PDF files whose visible content was significantly altered. This occurs as the application fails to identify the objects in the incremental update when the Subtype entry of the Annotation dictionary is set as null.
	Simon Rohlmann, Vladislav Mladenov, Christian Mainka, Jorg Schwenk

	Addressed a potential issue where the application could be exposed to Type Confusion Memory Corruption or Remote Code Execution vulnerability and crash due to the lack of proper validation when an incorrect argument was passed to the app.media.openPlayer function defined in PDF JavaScript API (CVE-2020-13547). 
	Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when executing certain JavaScript in a PDF file. This occurs due to the access or use of pointer or object that has been removed after calling certain JavaScript functions (CVE-2020-13548/CVE-2020-13557/CVE-2020-13560/CVE-2020-13570).
	Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash when opening certain PDF files that contained illegal value in the /Size entry of the Trail dictionary. This occurs due to the array overflow as the illegal value in the /Size entry causes an error in initializing the array size for storing the compression object streams, and an object number which is larger than the initialization value is used as the array index while parsing the cross-reference streams (CVE-2020-28203). 
	Sanjeev Das (IBM Research)





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 9.7.4



Release date: October 20, 2020

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 9.7.4, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	9.7.3.29555 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability and crash when executing JavaScript in certain AcroForm. This occurs due to the use of Opt object after it has been deleted by calling Field::ClearItems method while executing Field::DeleteOptions method. 
	Hung Tien Tran @hungtt28

	Addressed a potential issue where the application could be exposed to Write/Read Access Violation vulnerability and crash. This occurs due to the exception thrown by the V8 JavaScript engine, which is resulted from the failure to properly handle the situation where the Index returned during the allocation of thread local storage by TslAlloc function exceeds the limits acceptable by the V8 JavaScript engine. 
	John Stigerwalt

	Addressed potential issues where the application could be exposed to Null Pointer Access/Dereference vulnerability and crash when opening certain specially crafted PDF. This occurs due to the access or reference of the null pointer without proper validation (CNVD-C-2020-169904/CNVD-C-2020-186241/CNVD-C-2020-186245). 
	John Stigerwalt

Nafiez, Fakhrie and Yeh of TomatoDuck Fuzzing Group

China National Vulnerability Database


	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when parsing certain JPEG2000 images. This occurs because the application fails to release memory correctly based on the memory block information (CVE-2020-17410). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash. This occurs during the handling of Shading because the number of outputs calculated by function does not match the number of color components in the Shading directory’s color space.
	Nafiez, Fakhrie and Yeh of TomatoDuck Fuzzing Group

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability when parsing certain JPEG2000 images due to the incorrect read and write of memory at invalid address (CVE-2020-17416). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability during installation. This occurs as the application does not use the absolute path to find taskkill.exe but firstly finds and executes the one in the current working directory.
	Dhiraj Mishra (@RandomDhiraj)

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure or Remote Code Execution vulnerability and crash. This occurs due to the use of /V item which is deleted after being interpreted as the action executed during validation when it exists in both Additional Action and Field dictionaries but shares different interpretations (CNVD-C-2020-169907). 
	China National Vulnerability Database

	Addressed a potential issue where the application could be exposed to Universal Signature Forgery vulnerability and deliver incorrect validation results when validating digital signatures in certain PDF files. This occurs as the application fails to perform cryptographic validation of signatures correctly, which could be exploited by attackers to forge arbitrary signatures on arbitrary files and deceive the validator.
	Matthias Valvekens





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 9.7.4.29600



Release date: October 20, 2020

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.7.4.29600 for Foxit PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	9.7.3.29555 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write or Stack-based Buffer Overflow vulnerability if users were using 3D Plugin Beta, which could be exploited by attackers to execute remote code or disclose sensitive information. This occurs due to the lack of proper validation of data when parsing certain U3D object that contains incorrect data stream (CNVD-C-2020-73515/CNVD-C-2020-73509/CVE-2020-17411/CVE-2020-17412/CVE-2020-17413). 
	China National Vulnerability Database

Mat Powell of Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF Mac and Foxit Reader Mac 4.1 



Release date: October 9, 2020

Platform: macOS

Summary

Foxit has released Foxit PhantomPDF Mac and Foxit Reader Mac 4.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF Mac
	4.0.0.0430 and earlier
	macOS

	Foxit Reader Mac
	4.0.0.0430 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF Mac or Foxit Reader Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader Mac from our website. 
	Click here to download the updated version of Foxit PhantomPDF Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Code Injection or Information Disclosure vulnerability because it did not enable Hardened Runtime capability during code signing. 
	Hou JingYi (@hjy79425575)





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 10.1 and Foxit PhantomPDF 10.1



Release date: September 28, 2020

Platform: Windows

Summary

Foxit has released Foxit Reader 10.1 and Foxit PhantomPDF 10.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	10.0.1.35811 and earlier
	Windows

	Foxit PhantomPDF 
	10.0.1.35811, 10.0.0.35798, 9.7.3.29555 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability and crash when executing JavaScript in certain AcroForm. This occurs due to the use of Opt object after it has been deleted by calling Field::ClearItems method while executing Field::DeleteOptions method. 
	Hung Tien Tran @hungtt28

	Addressed a potential issue where the application could be exposed to Write/Read Access Violation vulnerability and crash. This occurs due to the exception thrown by the V8 JavaScript engine, which is resulted from the failure to properly handle the situation where the Index returned during the allocation of thread local storage by TslAlloc function exceeds the limits acceptable by the V8 JavaScript engine. 
	John Stigerwalt

	Addressed potential issues where the application could be exposed to Null Pointer Access/Dereference vulnerability and crash when opening certain specially crafted PDF. This occurs due to the access or reference of the null pointer without proper validation (CNVD-C-2020-169904/CNVD-C-2020-186241/CNVD-C-2020-186245). 
	John Stigerwalt

Nafiez, Fakhrie and Yeh of TomatoDuck Fuzzing Group

China National Vulnerability Database


	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when parsing certain JPEG2000 images. This occurs because the application fails to release memory correctly based on the memory block information (CVE-2020-17410). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Incorrect Permission Assignment Privilege Escalation vulnerability, which could be exploited by attackers to execute an arbitrary program. This occurs due to the incorrect permission set on a resource used by Foxit update service (CVE-2020-17414/CVE-2020-17415). 
	@Kharosx0 working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative


	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash. This occurs during the handling of Shading because the number of outputs calculated by function does not match the number of color components in the Shading directory’s color space.
	Nafiez, Fakhrie and Yeh of TomatoDuck Fuzzing Group

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability when parsing certain JPEG2000 images due to the incorrect read and write of memory at invalid address (CVE-2020-17416). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Remote Code Execution vulnerability during installation. This occurs as the application does not use the absolute path to find taskkill.exe but firstly finds and executes the one in the current working directory.
	Dhiraj Mishra (@RandomDhiraj)

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure or Remote Code Execution vulnerability and crash. This occurs due to the use of /V item which is deleted after being interpreted as the action executed during validation when it exists in both Additional Action and Field dictionaries but shares different interpretations (CNVD-C-2020-169907). 
	China National Vulnerability Database

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability and crash due to the lack of proper validation of the input data when triggering Doc.getNthFieldName method (CVE-2020-17417). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Universal Signature Forgery vulnerability and deliver incorrect validation results when validating digital signatures in certain PDF files. This occurs as the application fails to perform cryptographic validation of signatures correctly, which could be exploited by attackers to forge arbitrary signatures on arbitrary files and deceive the validator.
	Matthias Valvekens





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 10.1.0.37494



Release date: September 28, 2020

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 10.1.0.37494 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	10.0.1.35811, 10.0.0.35737, 9.7.3.29555 and earlier
	Windows





Solution

Update your Foxit Reader or PhantomPDF to version 10.1, and then install the latest version of the 3D Plugin Beta by following one of the methods below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write or Stack-based Buffer Overflow vulnerability if users were using 3D Plugin Beta, which could be exploited by attackers to execute remote code or disclose sensitive information. This occurs due to the lack of proper validation of data when parsing certain U3D object that contains incorrect data stream (CNVD-C-2020-73515/CNVD-C-2020-73509/CVE-2020-17411/CVE-2020-17412/CVE-2020-17413). 
	China National Vulnerability Database

Mat Powell of Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 9.7.3



Release date: August 31, 2020

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 9.7.3, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	9.7.2.29539 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Uninitialized Object Information Disclosure vulnerability and crash. This occurs as the application directly transforms the PDF Object as PDF Stream for further actions without proper validation when verifying the information in a crafted XObject (CVE-2020-11493). 
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs due to the application mistakenly uses the index of the original text string to recognize links after the original text string is divided into two pieces during text string layout (CVE-2020-12247).
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure vulnerability and crash due to the access of illegal memory when loading certain webpage (CVE-2020-15637). 
	Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Heap Buffer Overflow Remote Code Execution vulnerability and crash. This occurs due to the application fails to execute a fault-tolerance mechanism when processing the dirty data in the image resources (CVE-2020-12248). 
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash due to the access of array whose length is larger than its initial length (CVE-2020-15638). 
	Rene Freingruber (@ReneFreingruber) and Patrick Wollgast working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 10.0.1 and Foxit PhantomPDF 10.0.1



Release date: July 31, 2020

Platform: Windows

Summary

Foxit has released Foxit Reader 10.0.1 and Foxit PhantomPDF 10.0.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	10.0.0.35798 and earlier
	Windows

	Foxit PhantomPDF 
	10.0.0.35798, 9.7.2.29539 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Uninitialized Object Information Disclosure vulnerability and crash. This occurs as the application directly transforms the PDF Object as PDF Stream for further actions without proper validation when verifying the information in a crafted XObject (CVE-2020-11493). 
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs due to the application mistakenly uses the index of the original text string to recognize links after the original text string is divided into two pieces during text string layout (CVE-2020-12247).
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure vulnerability and crash due to the access of illegal memory when loading certain webpage (CVE-2020-15637). 
	Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Heap Buffer Overflow Remote Code Execution vulnerability and crash. This occurs due to the application fails to execute a fault-tolerance mechanism when processing the dirty data in the image resources (CVE-2020-12248). 
	Steven Seeley of Qihoo 360 Vulcan Team

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash due to the access of array whose length is larger than its initial length (CVE-2020-15638). 
	Rene Freingruber (@ReneFreingruber) and Patrick Wollgast working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PhantomPDF Mac and Foxit Reader Mac 4.0 



Release date: May 6, 2020

Platform: macOS

Summary

Foxit has released Foxit PhantomPDF Mac and Foxit Reader Mac 4.0, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF Mac
	3.4.0.1012 and earlier
	macOS

	Foxit Reader Mac
	3.4.0.1012 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF Mac or Foxit Reader Mac, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader Mac from our website. 
	Click here to download the updated version of Foxit PhantomPDF Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures (CVE-2020-9592/CVE-2020-9596).
	Christian Mainka, Vladislav Mladenov, Simon Rohlmann, Jorg Schwenk





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.7.2 and Foxit PhantomPDF 9.7.2



Release date: April 16, 2020

Platform: Windows

Summary

Foxit has released Foxit Reader 9.7.2 and Foxit PhantomPDF 9.7.2, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.7.1.29511 and earlier
	Windows

	Foxit PhantomPDF 
	9.7.1.29511 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Type Confusion or Arbitrary File Write Remote Code Execution vulnerability and crash. This occurs during the handling of app.opencPDFWebPage JavaScript due to the lack of proper validation of parameters in socket message (ZDI-CAN-9828/ZDI-CAN-9829/ZDI-CAN-9830/ZDI-CAN-9831/ZDI-CAN-9865/ZDI-CAN-9942/ZDI-CAN-9943/ZDI-CAN-9944/ZDI-CAN-9945/ZDI-CAN-9946)
	Anonymous working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability if users were using the DocuSign plugin. This occurs because the username and password are hardcoded in the DocuSign plugin during an HTTP request. 
	David Cook

	Addressed a potential issue where the application could be exposed to Brute-force Attack vulnerability as the CAS service did not limit the times of user login failures. 
	Hassan Personal

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when processing certain XFA template or AcroForm due to the use of objects which had been freed (ZDI-CAN-10132/ZDI-CAN-10142/ZDI-CAN-10614/ZDI-CAN-10650). 
	hungtt28 of Viettel Cyber Security working with Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

Peter Nguyen Vu Hoang of STAR Labs working with Trend Micro Zero Day Initiative

Hung Tien Tran @hungtt28

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when working with certain malicious PDF file. This occurs as the application continues to execute JavaScript to open a document without proper validation after the page is deleted or the document is closed.
	J. Müller, D. Noss, C. Mainka, V. Mladenov, J. Schwenk

	Addressed potential issues where the application could be exposed to Circular Reference vulnerability and got stuck in a dead loop when working with certain PDF file. This occurs due to the lack of a circular reference verification mechanism when processing actions that contain circular reference. 
	J. Müller, D. Noss, C. Mainka, V. Mladenov, J. Schwenk

	Addressed a potential issue where the application could be exposed to Infinite Loop or Out-of-Memory vulnerability and crash when parsing certain PDF file that contains irregular data in cross-reference stream or lengthy character strings in the content stream.
	J. Müller, D. Noss, C. Mainka, V. Mladenov, J. Schwenk

	Addressed a potential issue where the application could be exposed to Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures (CVE-2020-9592/CVE-2020-9596).
	Christian Mainka, Vladislav Mladenov, Simon Rohlmann, Jorg Schwenk





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 9.7.2.29539



Release date: April 16, 2020

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.7.2.29539 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	9.7.1.29511 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write or Heap-based Buffer Overflow vulnerability if users were using 3D Plugin Beta, which could be exploited by attackers to disclose information or execute remote codes. This occurs due to the lack of proper validation of data when parsing certain file with incorrect 3D annotation data (ZDI-CAN-10189/ZDI-CAN-10190/ZDI-CAN-10191/ZDI-CAN-10192/ZDI-CAN-10193/ZDI-CAN-10195/ZDI-CAN-10461/ZDI-CAN-10462/ZDI-CAN-10463/ZDI-CAN-10464/ZDI-CAN-10568).
	Mat Powell of Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.7.1 and Foxit PhantomPDF 9.7.1



Release date: January 16, 2020

Platform: Windows

Summary

Foxit has released Foxit Reader 9.7.1 and Foxit PhantomPDF 9.7.1, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.7.0.29478 and earlier
	Windows

	Foxit PhantomPDF 
	9.7.0.29455 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Integer Overflow or Out-of-Bounds Write/Read Remote Code Execution or Information Disclosure vulnerability and crash when parsing certain JPEG/JPG2000 images or JP2 streams inside PDF files. This is caused by memory allocation mistake or overflow which results in memory access violation (ZDI-CAN-9102/ZDI-CAN-9606/ZDI-CAN-9407/ZDI-CAN-9413/ZDI-CAN-9414/ZDI-CAN-9415/ZDI-CAN-9406/ZDI-CAN-9416). 
	Natnael Samson (@NattiSamson) working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

A3F2160DCA1BDE70DA1D99ED267D5DC1EC336192 working with Trend Micro Zero

Anonymous working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when handling watermarks, AcroForm objects, text field or JavaScript field objects in PDF files due to the use of objects after it had been freed without proper validation (ZDI-CAN-9358/ZDI-CAN-9640/ZDI-CAN-9400/CVE-2019-5126/CVE-2019-5131/CVE-2019-5130/CVE-2019-5145/ZDI-CAN-9862). 
	mrpowell of Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

hungtt28 working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write or Use-After-Free Remote Code Execution vulnerability and crash when converting HTML files to PDFs due to memory access violation during the loading and rendering of webpages (ZDI-CAN-9591/ZDI-CAN-9560). 
	rgod of 9sg working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-After-Free vulnerability due to the use of uninitialized pointer without proper validation when processing certain documents whose dictionary was missing. 
	rwxcode of nsfocus security team

	Addressed a potential issue where the application could be exposed to Stack Overflow vulnerability and crash due to looped indirect object reference. 
	Michael Heinzl





For more information, please contact the Foxit Security Response Team at [email protected].











2019

 





Security updates available in Foxit PhantomPDF 8.3.12



Release date: November 5, 2019

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.12, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.11.45106 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability and crash due to the unexpected error or out-of-memory in V8 Engine when executing certain JavaScript (CVE-2019-5031/CVE-2019-13123/CVE-2019-13124/ZDI-CAN-8692).
	Aleksandar Nikolic of Cisco Talos

Roderick Schaefer (kciredor)

RockStar working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when deleting Field with the nested scripts (ZDI-CAN-8864/ZDI-CAN-8888/ZDI-CAN-8913/ZDI-CAN-9044/ZDI-CAN-9081).
	Anonymous working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash when parsing TIFF files as the application failed to set decoding information for images properly (ZDI-CAN-8695/ZDI-CAN-8742).
	Zak Rogness working with Trend Micro Zero Day Initiative

Natnael Samson (@NattiSamson) working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability when converting JPG file to PDF due to array access violation (ZDI-CAN-8838). 
	Natnael Samson (@NattiSamson) working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash due to the dereference of null pointer. 
	ADLab of Venustech

	Addressed potential issues where the application could crash when parsing certain files. This occurs because the application creates data for each page in application level, which causes the memory of application reach to the maximum. 
	ADLab of Venustech

	Addressed a potential issue where the application could be exposed to Stack Exhaustion vulnerability and crash due to the nested calling of functions when parsing XML files. 
	ADLab of Venustech

	Addressed potential issues where the application could crash when parsing certain file data due to the access of null pointer without proper validation. 
	ADLab of Venustech

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash due to the access of objects which has been deleted or released (ZDI-CAN-9091/ZDI-CAN-9149).
	
RockStar working with Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Access Violation vulnerability and crash when it was launched on the condition that there was no enough memory in the current system (CVE-2019-17183). 
	K.K.Senthil Velan of Zacco Cybersecurity Research Labs





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.7 and Foxit PhantomPDF 9.7



Release date: October 16, 2019 (Foxit PhantomPDF 9.7) / September 29, 2019 (Foxit Reader 9.7)

Platform: Window s

Summary

Foxit has released Foxit Reader 9.7 and Foxit PhantomPDF 9.7, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.6.0.25114 and earlier
	Windows

	Foxit PhantomPDF 
	9.6.0.25114 and all previous 9.x versions, 8.3.11.45106 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Remote Code Execution vulnerability and crash due to the unexpected error or out-of-memory in V8 Engine when executing certain JavaScript (CVE-2019-5031/CVE-2019-13123/CVE-2019-13124/ZDI-CAN-8692).
	Aleksandar Nikolic of Cisco Talos

Roderick Schaefer (kciredor)

RockStar working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when deleting Field with the nested scripts (ZDI-CAN-8864/ZDI-CAN-8888/ZDI-CAN-8913/ZDI-CAN-9044/ZDI-CAN-9081).
	Anonymous working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash when parsing TIFF files as the application failed to set decoding information for images properly (ZDI-CAN-8695/ZDI-CAN-8742).
	Zak Rogness working with Trend Micro Zero Day Initiative

Natnael Samson (@NattiSamson) working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability when converting JPG file to PDF due to array access violation (ZDI-CAN-8838). 
	Natnael Samson (@NattiSamson) working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash due to the dereference of null pointer. 
	ADLab of Venustech

	Addressed potential issues where the application could crash when parsing certain files. This occurs because the application creates data for each page in application level, which causes the memory of application reach to the maximum. 
	ADLab of Venustech

	Addressed a potential issue where the application could be exposed to Stack Exhaustion vulnerability and crash due to the nested calling of functions when parsing XML files. 
	ADLab of Venustech

	Addressed potential issues where the application could crash when parsing certain file data due to the access of null pointer without proper validation. 
	ADLab of Venustech

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash due to the access of objects which has been deleted or released (ZDI-CAN-9091/ZDI-CAN-9149).
	
RockStar working with Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Access Violation vulnerability and crash when it was launched on the condition that there was no enough memory in the current system (CVE-2019-17183). 
	K.K.Senthil Velan of Zacco Cybersecurity Research Labs





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit PhantomPDF Mac 3.4



Release date: October 15, 2019

Platform: macOS

Summary

Foxit has released Foxit PhantomPDF Mac 3.4, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF Mac
	3.3.0.0709 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF Mac, click on “Check for Updates Now” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash due to the dereference of null pointer.
	Wenchao Li of VARAS@IIE





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 9.7.0.29430



Release date: September 29, 2019

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.7.0.29430 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	9.6.0.25108 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write and Null Pointer Dereference vulnerability if users were using 3D Plugin Beta. This occurs due to the lack of proper validation of incorrect image data when parsing certain files with incorrect image information. 
	ADLab of Venustech





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in the upgrade package for Foxit Reader (EXE package) 9.6



Release date: August 15, 2019 

Platform: Windows

Summary

Foxit has released the upgrade package for Foxit Reader (EXE package) 9.6, which addresses a potential security and stability issue. 

Affected versions


	Product
	Affected versions
	Platform

	Upgrade package for Foxit Reader (EXE package)
	9.6.0.25114
	Windows





Solution

Users who update Foxit Reader to the latest version after August 15, 2019 will not be affected. If you have enabled the Safe Reading Mode in the older version and updated Foxit Reader to Version 9.6.0.25114 before August 15, 2019, please go to File > Preferences > Trust Manager to check and enable the Safe Reading Mode. 





Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the Safe Reading Mode could be disabled when users updating Foxit Reader from within the application, which could be exploited by attackers to execute unauthorized action or data transmission. This occurs because the registry configuration is deleted and not applied during update.
	Haifei Li of McAfee





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 8.3.11



Release date: July 19, 2019

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.11, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.10.42705 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could crash when calling xfa.event.rest XFA JavaScript due to the access of wild pointer. 
	Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could crash when calling certain XFA JavaScript due to the use or access of null pointer without proper validation on the object. 
	Hui Gao of Palo Alto Networks

Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could crash due to array access violation during XFA layout. This occurs because the original node object contains one more contentArea object than that in XFA layout, which exceed the array size during traversal. 
	Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when processing AcroForms. This occurs because additional event is triggered to delete ListBox and ComboBox Field when trying to delete the items in ListBox and ComboBox Field by calling deleteItemAt method (ZDI-CAN-8295). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Stack Buffer Overrun vulnerability and crash. This occurs because the maximum length in For loop is not updated correspondingly when all the Field APs are updated after executing Field related JavaScript. 
	xen1thLabs

	Addressed a potential issue where the application could crash due to the repeated release of signature dictionary during CSG_SignatureF and CPDF_Document destruction. 
	Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could crash due to the lack of proper validation of the existence of an object prior to performing operations on the object when executing JavaScript. 
	Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability. This occurs because Field object is deleted during parameter calculation when setting certain attributes in Field object using JavaScript (ZDI-CAN-8491/ZDI-CAN-8801/ZDI-CAN-8656/ZDI-CAN-8757/ZDI-CAN-8759/ZDI-CAN-8814).
	banananapenguin working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could crash when calling clone function due to the endless loop resulted from the confused relationships between the child and parent object caused by append error. 
	Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Null Pointer Dereference vulnerability and crash when parsing certain Epub file. This occurs because a null string is written to FXSYS_wcslen which does not support null strings. 
	ADLab of Venustech

	Addressed potential issues where the application could be exposed the Use-After-Free Remote Code Execution vulnerability and crash due to the use of Field objects or control after they have been deleted or released (ZDI-CAN-8669). 
	Xinru Chi of Pangu Lab

huyna of Viettel Cyber Security working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when calling util.printf JavaScript as the actual memory address of any variable available to the JavaScript can be extracted (ZDI-CAN-8544). 
	banananapenguin working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed Out-of-Bounds Write vulnerability when users use the application in Internet Explorer because the input argument exceed the array length. 
	@j00sean





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF Mac 3.3 and Foxit Reader Mac 3.3



Release date: July 15, 2019

Platform: macOS

Summary

Foxit has released Foxit PhantomPDF Mac 3.3 and Foxit Reader Mac 3.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF Mac
	3.2.0.0404 and earlier
	macOS

	Foxit Reader Mac
	3.2.0.0404 and earlier
	macOS





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF Mac or Foxit Reader Mac, click on “Check for Updates Now” and update to the latest version.
	Click here to download the updated version of Foxit Reader Mac from our website. 
	Click here to download the updated version of Foxit PhantomPDF Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Null Pointer Dereference vulnerability and crash due to the use of null pointer without proper validation.
	Xinru Chi of Pangu Lab
Wenchao Li of VARAS@IIE

	Addressed a potential issue where the application could be exposed to Stack Overflow vulnerability due to the mutual reference between ICCBased color space and Alternate color space. 
	Xinru Chi of Pangu Lab





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.6 and Foxit PhantomPDF 9.6



Release date: July 4, 2019

Platform: Windows

Summary

Foxit has released Foxit Reader 9.6 and Foxit PhantomPDF 9.6, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.5.0.20723 and earlier
	Windows

	Foxit PhantomPDF 
	9.5.0.20723 and all previous 9.x versions, 8.3.10.42705 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could crash when calling xfa.event.rest XFA JavaScript due to the access of wild pointer. 
	Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could crash when calling certain XFA JavaScript due to the use or access of null pointer without proper validation on the object. 
	Hui Gao of Palo Alto Networks

Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could crash due to array access violation during XFA layout. This occurs because the original node object contains one more contentArea object than that in XFA layout, which exceed the array size during traversal. 
	Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when processing AcroForms. This occurs because additional event is triggered to delete ListBox and ComboBox Field when trying to delete the items in ListBox and ComboBox Field by calling deleteItemAt method (ZDI-CAN-8295). 
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Stack Buffer Overrun vulnerability and crash. This occurs because the maximum length in For loop is not updated correspondingly when all the Field APs are updated after executing Field related JavaScript. 
	xen1thLabs

	Addressed a potential issue where the application could crash due to the repeated release of signature dictionary during CSG_SignatureF and CPDF_Document destruction. 
	Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could crash due to the lack of proper validation of the existence of an object prior to performing operations on the object when executing JavaScript. 
	Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability. This occurs because Field object is deleted during parameter calculation when setting certain attributes in Field object using JavaScript (ZDI-CAN-8491/ZDI-CAN-8801/ZDI-CAN-8656/ZDI-CAN-8757/ZDI-CAN-8759/ZDI-CAN-8814).
	banananapenguin working with Trend Micro Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

Anonymous working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could crash when calling clone function due to the endless loop resulted from the confused relationships between the child and parent object caused by append error. 
	Qi Deng, Taojie Wang, Zhaoyan Xu, Vijay Prakash, Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Null Pointer Dereference vulnerability and crash when parsing certain Epub file. This occurs because a null string is written to FXSYS_wcslen which does not support null strings. 
	ADLab of Venustech

	Addressed potential issues where the application could be exposed the Use-After-Free Remote Code Execution vulnerability and crash due to the use of Field objects or control after they have been deleted or released (ZDI-CAN-8669). 
	Xinru Chi of Pangu Lab

huyna of Viettel Cyber Security working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Information Disclosure vulnerability when calling util.printf JavaScript as the actual memory address of any variable available to the JavaScript can be extracted (ZDI-CAN-8544). 
	banananapenguin working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed Out-of-Bounds Write vulnerability when users use the application in Internet Explorer because the input argument exceed the array length. 
	@j00sean





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 9.5.0.20733



Release date: May 28, 2019

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.5.0.20733 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta
	9.5.0.20723 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could crash if users were using 3D Plugin Beta. This occurs due to the lack of proper validation of void data when parsing and rendering certain files with lost or corrupted data (CNVD-C-2019-41438). 
	Wei Lei from STAR Labs

ADLab of Venustech

China National Vulnerability Database (CNVD)





For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit PhantomPDF 8.3.10



Release date: April 18, 2019

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.10, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.9.41099 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Race Condition vulnerability when calling the proxyCPDFAction, proxyCheckLicence, proxyDoAction, proxyGetAppEdition, or proxyPreviewAction function with a large integer or long string, which could trigger a stack buffer overflow or out-of-bounds read. Attackers could leverage the vulnerability to execute arbitrary code or disclose information (CVE-2018-20309/CVE-2018-20310/ CVE-2018-20311/CVE-2018-20312/CVE-2018-20313/ CVE-2018-20314/ CVE-2018-20315/ CVE-2018-20316).
	Steven Seeley (mr_me) of Source Incite 

	Addressed a potential issue where the application could be exposed to Directory Traversal vulnerability, which could lead to remote code execution. This occurs because the application mistakenly allows users to invoke certain JavaScript that is used for cPDF plugin only from the console to write local files (ZDI-CAN-7407). 
	Steven Seeley (mr_me) of Source Incite working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Integer Overflow vulnerability and crash due to the lack of proper validation of user-supplied data when handling XFA Stuff method. Attackers could exploit this vulnerability to disclose information (ZDI-CAN-7561).
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read or Use-After-Free vulnerability and crash when converting HTML files to PDFs, which could be leveraged by attackers to disclose information or execute remote code. This occurs due to the failure in loop termination, release of the memory which has been released before, or abnormal logic processing (ZDI-CAN-7620/ZDI-CAN-7844/ZDI-CAN-8170).
	T3rmin4t0r working with Trend Micro Zero Day Initiative

kdot working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash due to the data written in “bmp_ptr->out_row_buffer” or “_JP2_Wavelet_Synthesis_Horizontal_Long” exceeds the maximum allocated when converting PDFs. (ZDI-CAN-7613/ZDI-CAN-7614/ZDI-CAN-7701).
	Hao Li from ADLab of VenusTech working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Heap Corruption vulnerability due to the data desynchrony when adding AcroForm.
	Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure vulnerability and crash due to the multiple release of net::IOBufferWithSize pointer. (ZDI-CAN-7769).
	Mat Powell of Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write Remote Code Execution vulnerability and crash. This occurs due to the release of wild pointer because the Resolution memory is not allocated accordingly when the ucLevel value is changed (ZDI-CAN-7696/ZDI-CAN-7694). 
	Hao Li from ADLab of VenusTech working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability due to the use of invalid pointer copy resulting from destructed string object. 
	Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability because it did not set the document pointer as null after deleting it by invoking XFA API (ZDI-CAN-7777). 
	juggernaut working with Trend Micro Zero Day Initiative
Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to IDN Homograph Attach vulnerability when a user clicked a fake link to open illegal address. 
	Dr. Alfonso Muñoz (@mindcrypt) - Global Technical Cybersecurity Lead & Head of cybersecurity lab

	Addressed a potential issue where the application could be exposed to Cloud Drive Connection vulnerability which could allow users to freely gain access to documents on Google Drive from within the application even though it has been logged out. 
	JS

	Addressed a potential issue where the application could be exposed to ISA Exploit Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures.
	Vladislav Mladenov, Christian Mainka, Martin Grothe and Jörg Schwenk of the Ruhr-Universität Bochum and Karsten Meyer zu Selhausen of Hackmanit GmbH

	Addressed a potential issue where the application could be exposed to JavaScript Denial of Service vulnerability when deleting pages in a document that contains only one page by calling t.hidden = true function. 
	Paolo Arnolfo (@sw33tLie)
Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could be exposed to Null Pointer Reference vulnerability and crash when getting PDF object from document or parsing certain portfolio that contain null dictionary. 
	Xie Haikuo from Baidu Security Lab

ADLab of Venustech
Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when embedding PDFs with invalid URL by calling put_src interface from Foxit Browser plugin in Microsoft Word. This occurs due to the use of illegal IBindStatusCallback object which has been freed (ZDI-CAN-7874). 
	@j00sean working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash. This occurs due to the use of discrepant widget object which is transformed from invalid node appended (ZDI-CAN-7972). 
	hungtt28 of Viettel Cyber Security working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Information Disclosure vulnerability when deleting Field with the nested scripts (ZDI-CAN-8162/ZDI-CAN-8163/ZDI-CAN-8164/ZDI-CAN-8165/ZDI-CAN-8229/ZDI-CAN-8230/ZDI-CAN-8231/ZDI-CAN-8272). 
	hemidallt working with Trend Micro Zero Day Initiative
Anonymous working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.5 and Foxit PhantomPDF 9.5 



Release date: April 16, 2019

Platform: Windows

Summary

Foxit has released Foxit Reader 9.5 and Foxit PhantomPDF 9.5, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.4.1.16828 and earlier
	Windows

	Foxit PhantomPDF 
	9.4.1.16828 and all previous 9.x versions, 8.3.9.41099 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Race Condition vulnerability when calling the proxyCPDFAction, proxyCheckLicence, proxyDoAction, proxyGetAppEdition, or proxyPreviewAction function with a large integer or long string, which could trigger a stack buffer overflow or out-of-bounds read. Attackers could leverage the vulnerability to execute arbitrary code or disclose information (CVE-2018-20309/CVE-2018-20310/ CVE-2018-20311/CVE-2018-20312/CVE-2018-20313/ CVE-2018-20314/ CVE-2018-20315/ CVE-2018-20316).
	Steven Seeley (mr_me) of Source Incite 

	Addressed a potential issue where the application could be exposed to Directory Traversal vulnerability, which could lead to remote code execution. This occurs because the application mistakenly allows users to invoke certain JavaScript that is used for cPDF plugin only from the console to write local files (ZDI-CAN-7407). 
	Steven Seeley (mr_me) of Source Incite working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Integer Overflow vulnerability and crash due to the lack of proper validation of user-supplied data when handling XFA Stuff method. Attackers could exploit this vulnerability to disclose information (ZDI-CAN-7561).
	Anonymous working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read or Use-After-Free vulnerability and crash when converting HTML files to PDFs, which could be leveraged by attackers to disclose information or execute remote code. This occurs due to the failure in loop termination, release of the memory which has been released before, or abnormal logic processing (ZDI-CAN-7620/ZDI-CAN-7844/ZDI-CAN-8170).
	T3rmin4t0r working with Trend Micro Zero Day Initiative

kdot working with Trend Micro Zero Day Initiative

RockStar working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash due to the data written in “bmp_ptr->out_row_buffer” or “_JP2_Wavelet_Synthesis_Horizontal_Long” exceeds the maximum allocated when converting PDFs. (ZDI-CAN-7613/ZDI-CAN-7614/ZDI-CAN-7701).
	Hao Li from ADLab of VenusTech working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Heap Corruption vulnerability due to the data desynchrony when adding AcroForm.
	Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Information Disclosure vulnerability and crash due to the multiple release of net::IOBufferWithSize pointer. (ZDI-CAN-7769).
	Mat Powell of Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free or Out-of-Bounds Write Remote Code Execution vulnerability and crash. This occurs due to the release of wild pointer because the Resolution memory is not allocated accordingly when the ucLevel value is changed (ZDI-CAN-7696/ZDI-CAN-7694). 
	Hao Li from ADLab of VenusTech working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability due to the use of invalid pointer copy resulting from destructed string object. 
	Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability because it did not set the document pointer as null after deleting it by invoking XFA API (ZDI-CAN-7777). 
	juggernaut working with Trend Micro Zero Day Initiative
Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to IDN Homograph Attach vulnerability when a user clicked a fake link to open illegal address. 
	Dr. Alfonso Muñoz (@mindcrypt) - Global Technical Cybersecurity Lead & Head of cybersecurity lab

	Addressed a potential issue where the application could be exposed to Cloud Drive Connection vulnerability which could allow users to freely gain access to documents on Google Drive from within the application even though it has been logged out. 
	JS

	Addressed a potential issue where the application could be exposed to ISA Exploit Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures.
	Vladislav Mladenov, Christian Mainka, Martin Grothe and Jörg Schwenk of the Ruhr-Universität Bochum and Karsten Meyer zu Selhausen of Hackmanit GmbH

	Addressed a potential issue where the application could be exposed to JavaScript Denial of Service vulnerability when deleting pages in a document that contains only one page by calling t.hidden = true function. 
	Paolo Arnolfo (@sw33tLie)
Hui Gao of Palo Alto Networks

	Addressed potential issues where the application could be exposed to Null Pointer Reference vulnerability and crash when getting PDF object from document or parsing certain portfolio that contain null dictionary. 
	Xie Haikuo from Baidu Security Lab

ADLab of Venustech
Hui Gao of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when embedding PDFs with invalid URL by calling put_src interface from Foxit Browser plugin in Microsoft Word. This occurs due to the use of illegal IBindStatusCallback object which has been freed (ZDI-CAN-7874). 
	@j00sean working with Trend Micro Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write Remote Code Execution vulnerability and crash. This occurs due to the use of discrepant widget object which is transformed from invalid node appended (ZDI-CAN-7972). 
	hungtt28 of Viettel Cyber Security working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Information Disclosure vulnerability when deleting Field with the nested scripts (ZDI-CAN-8162/ZDI-CAN-8163/ZDI-CAN-8164/ZDI-CAN-8165/ZDI-CAN-8229/ZDI-CAN-8230/ZDI-CAN-8231/ZDI-CAN-8272). 
	hemidallt working with Trend Micro Zero Day Initiative
Anonymous working with Trend Micro Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security update in Foxit Reader Mac 3.2



Release date: April 10, 2019

Platform: macOS

Summary

Foxit has released Foxit Reader Mac 3.2, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader Mac
	3.1.0.0111
	macOS





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader Mac, click on “Check for Updates Now” and update to the latest version.
	Click here to download the updated version of Foxit Reader Mac from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Local Privilege Escalation vulnerability due to incorrect permission setting. Attackers could exploit this vulnerability to escalate his privileges by modifying the dynamic libraries in the PlugIns directory to execute arbitrary application. 
	Antonio Zekić of INFIGO IS d.o.o.





For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit PhantomPDF 8.3.9 



Release date: January 15, 2019

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.9, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.8.39677 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read/Write vulnerability and crash when handling certain XFA element attributes. This occurs due to the failure in calculating null-terminated character string as the string does not end up with null character correctly (CVE-2018-3956).
	Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures (CVE-2018-18688/CVE-2018-18689).
	Vladislav Mladenov, Christian Mainka, Karsten Meyer zu Selhausen, Martin Grothe, Jorg Schwenk of the Ruhr-Universität Bochum

John Heasman of DocuSign

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Information Disclosure vulnerability due to the use of page or pointer which has been closed or freed (ZDI-CAN-7347/ZDI-CAN-7452/ZDI-CAN-7601).
	Sebastian Apelt (@bitshifter123) working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative 

juggernaut working with Trend Micro Zero Day Initiative

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure or Remote Code Execution vulnerability and crash when parsing certain PDF files. This occurs due to array access violation in the color space and channel or lack of proper validation of illegal palette data in the color space of the image object (ZDI-CAN-7353/ZDI-CAN-7423).
	Sebastian Feldmann from GoSecure working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash when handling certain images. This occurs because the application writes a 2-byte data to the end of the allocated memory without judging whether it will cause corruption.
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash due to the access of null pointer when reading the TIFF data during TIFF parsing.
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could crash due to the lack of dereference of null pointer during PDF parsing.
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when executing certain JavaScript. This occurs due to the use of document and its auxiliary objects which have been closed after calling closeDoc function (ZDI-CAN-7368).
	Anonymous working with Trend Micro's Zero Day Initiative

Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability when converting HTML to PDF. This occurs due to the use of pointer which has been freed (ZDI-CAN-7369).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability caused by the abnormality in V8 engine resulting from the parsing of non-standard parameters (ZDI-CAN-7453).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability due to the inconsistent row numbers resulting from inconsistent character width during control text formatting (ZDI-CAN-7576).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs when executing certain XFA functions in crafted PDF files since the application could transform CXFA_Object to CXFA_Node without judging the data type and use the discrepant CXFA_Node directly (ZDI-CAN-7355).
	Anonymous working with Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].



Security update available in Foxit PDF ActiveX 5.5.1 



Release date: January 8, 2019

Platform: Windows

Summary

Foxit has released Foxit PDF ActiveX 5.5.1, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF ActiveX 
	5.5.0 and earlier
	Windows





Solution

Update the Foxit PDF ActiveX to the latest versions by clicking here to download the latest package from our website.





Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Command Injection Remote Code Execution Vulnerability. This occurs due to ActiveX not having a security permission control, which may allow JavaScript, LauchURL actions and Links to execute binary files/programs without prompting user for consent. (CVE-2018-19418/CVE-2018-19445/CVE-2018-19450/ CVE-2018-19451).
	Steven Seeley (mr_me) of Source Incite

	Addressed potential issues where the application could be exposed to Illegally Write Remote Code Execution Vulnerability. This occurs due to ActiveX not having a security permission control, which may allow JavaScript and exportAsFDF to write any type of files to any location without the user's consent (CVE-2018-19446/ CVE-2018-19449).
	Steven Seeley (mr_me) of Source Incite

	Addressed a potential issue where the application could be exposed to string1 URI Parsing Stack Based Buffer Overflow Remote Code Execution Vulnerability. This occurs due to lack of a maximum length limit for the URL where a long URL string will cause stack overflow when parsing (CVE-2018-19447).
	Steven Seeley (mr_me) of Source Incite

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution Vulnerability. This occurs when a javascript command is triggered by a mouse enter action or a focus lost which deletes the current annotation, and causes it to reference the released memory (CVE-2018-19452/ CVE-2018-19444).
	Steven Seeley (mr_me) of Source Incite

	Addressed a potential issue where the application could be exposed to Uninitialized Object Remote Code Execution Vulnerability. This occurs due to the fact that the timer does not end when the form loses focus, which causes subsequent code to reference uninitialized objects (CVE-2018-19448).
	Steven Seeley (mr_me) of Source Incite





For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit Reader 9.4 and Foxit PhantomPDF 9.4 



Release date: January 3, 2019

Platform: Windows

Summary

Foxit has released Foxit Reader 9.4 and Foxit PhantomPDF 9.4, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.3.0.10826 and earlier
	Windows

	Foxit PhantomPDF 
	9.3.0.10826 and all previous 9.x versions, 8.3.8.39677 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read/Write vulnerability and crash when handling certain XFA element attributes. This occurs due to the failure in calculating null-terminated character string as the string does not end up with null character correctly (CVE-2018-3956). 
	Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Signature Validation Bypass vulnerability and deliver incorrect validation result when validating certain PDF file that is modified maliciously or contains non-standard signatures (CVE-2018-18688/CVE-2018-18689). 
	Vladislav Mladenov, Christian Mainka, Karsten Meyer zu Selhausen, Martin Grothe, Jorg Schwenk of the Ruhr-Universität Bochum

John Heasman of DocuSign

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Information Disclosure vulnerability due to the use of page or pointer which has been closed or freed (ZDI-CAN-7347/ZDI-CAN-7452/ZDI-CAN-7601).
	Sebastian Apelt (@bitshifter123) working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative 

juggernaut working with Trend Micro Zero Day Initiative


	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure or Remote Code Execution vulnerability and crash when parsing certain PDF files. This occurs due to array access violation in the color space and channel or lack of proper validation of illegal palette data in the color space of the image object (ZDI-CAN-7353/ZDI-CAN-7423).
	Sebastian Feldmann from GoSecure working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Denial of Service vulnerability and crash when handling certain images. This occurs because the application writes a 2-byte data to the end of the allocated memory without judging whether it will cause corruption.
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash due to the access of null pointer when reading the TIFF data during TIFF parsing. 
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could crash due to the lack of dereference of null pointer during PDF parsing. 
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when executing certain JavaScript. This occurs due to the use of document and its auxiliary objects which have been closed after calling closeDoc function (ZDI-CAN-7368).
	Anonymous working with Trend Micro's Zero Day Initiative

Hui Gao and Zhaoyan Xu of Palo Alto Networks

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Remote Code Execution vulnerability when converting HTML to PDF. This occurs due to the use of pointer which has been freed (ZDI-CAN-7369).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability caused by the abnormality in V8 engine resulting from the parsing of non-standard parameters (ZDI-CAN-7453).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability due to the inconsistent row numbers resulting from inconsistent character width during control text formatting (ZDI-CAN-7576). 
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs when executing certain XFA functions in crafted PDF files since the application could transform CXFA_Object to CXFA_Node without judging the data type and use the discrepant CXFA_Node directly (ZDI-CAN-7355).
	Anonymous working with Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].



Security update in 3D Plugin Beta 9.4.0.16807



Release date: January 3, 2019

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.4.0.16807 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta 
	9.3.0.10826 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Write vulnerability and crash if users were using 3D Plugin Beta. This occurs when handling certain PDF file that embeds specifically crafted 3D content due to the improper handling of logic exception in IFXASSERT function (CVE-2019-6982). 
	Wei Lei from STAR Labs

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Indexing or Heap Overflow vulnerability and crash if users were using 3D Plugin Beta. This occurs when handling certain PDF file that embeds specifically crafted 3D content due to array access violation (CVE-2019-6983). 
	Wei Lei from STAR Labs

	Addressed a potential issue where the application could be exposed to Integer Overflow vulnerability and crash if users were using 3D Plugin Beta. This occurs when handling certain PDF file that embeds specifically crafted 3D content due to the free of valid memory (CVE-2019-6984). 
	Wei Lei from STAR Labs

	Address potential issues where the application could be exposed to Use-After-Free or Type Confusion vulnerability and crash if users were using 3D Plugin Beta. This occurs when handing certain PDF file that embeds specifically crafted 3D content due to the use of wild pointer (CVE-2019-6985). 
	Wei Lei from STAR Labs





For more information, please contact the Foxit Security Response Team at [email protected].
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Security update available in Quick PDF Library 16.12

Release date: December 17, 2018

Platform: Windows, macOS, Linux, Android, iOS

Summary

Foxit has released Quick PDF Library 16.12, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Quick PDF Library 
	16.11 and earlier
	Windows, macOS, Linux, Android, iOS





Solution

Visit our website or contact support to download the updated version of Quick PDF Library.





Vulnerability details

	Brief
	Acknowledgement

	Addressed an issue where loading a malformed or malicious PDF containing a recursive page tree structure using the LoadFromFile, LoadFromString or LoadFromStream functions results in a stack overflow. 
	Gal Elbaz, Alon Boxiner, Eran Vaknin and Noa Novogroder from Check Point Software Technologies

	Addressed an issue where loading a malformed or malicious PDF containing invalid xref table pointers or invalid xref table data using the LoadFromFile, LoadFromString, LoadFromStream, DAOpenFile or DAOpenFileReadOnly functions may result in an access violation caused by out of bounds memory access. 
	Gal Elbaz, Alon Boxiner, Eran Vaknin and Noa Novogroder from Check Point Software Technologies

	Addressed an issue where loading a malformed or malicious PDF containing invalid xref entries using the DAOpenFile or DAOpenFileReadOnly functions may result in an access violation caused by out of bounds memory access. 
	Gal Elbaz, Alon Boxiner, Eran Vaknin and Noa Novogroder from Check Point Software Technologies





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 8.3.8.1122

Release date: November 23, 2018

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 8.3.8.1122 for PhantomPDF, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta 
	8.3.8.39677 and earlier
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This occurs due to the use the null pointer or pointer access violation in U3D engine during U3D parsing (CVE-2018-18933/CVE-2018-19341/CVE-2018-19345/CVE-2018-19344).
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This occurs due to JPEG parsing error in IFXCore of the U3D engine during U3D parsing. (CVE-2018-19348/CVE-2018-19346/CVE-2018-19347). 
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This is caused by the array access violation in IFXCore of the U3D engine (CVE-2018-19342). 
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta due to the incorrect logic in IFXCore of the U3D engine (CVE-2018-19343).
	Asprose of Chengdu University of Information Technology





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in 3D Plugin Beta 9.3.0.10830

Release date: November 23, 2018

Platform: Windows

Summary

Foxit has released 3D Plugin Beta 9.3.0.10830 for Foxit Reader and PhantomPDF, which addresses potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	3D Plugin Beta 
	9.3.0.10809 and all previous 9.x versions
	Windows





Solution

Update the 3D Plugin Beta to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update 3D Plugin Beta to the latest version.
	Click here to download the updated version of 3D Plugin Beta for Foxit Reader or PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This occurs due to the use the null pointer or pointer access violation in U3D engine during U3D parsing (CVE-2018-18933/CVE-2018-19341/CVE-2018-19345/CVE-2018-19344). 
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This occurs due to JPEG parsing error in IFXCore of the U3D engine during U3D parsing. (CVE-2018-19348/CVE-2018-19346/CVE-2018-19347). 
	Asprose of Chengdu University of Information Technology

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta. This is caused by the array access violation in IFXCore of the U3D engine (CVE-2018-19342). 
	Asprose of Chengdu University of Information Technology

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash if users were using 3D Plugin Beta due to the incorrect logic in IFXCore of the U3D engine (CVE-2018-19343).
	Asprose of Chengdu University of Information Technology





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit PhantomPDF 8.3.8

Release date: November 2, 2018

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.8, which address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.7.38093 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Access/Write/Read or Use-After-Free vulnerability and crash when parsing non-integer strings during the conversion of HTML files to PDFs, which could be exploited by attackers to execute remote code (ZDI-CAN-6230/ZDI-CAN-7128/ZDI-CAN-7129/ZDI-CAN-7130/ZDI-CAN-7131/ZDI-CAN-7132).
	bit - MeePwn team working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs when executing certain JavaScript due to the use of document and its auxiliary objects which have been closed after calling closeDoc function (ZDI-CAN-6333/ZDI-CAN-6334/ZDI-CAN-6335/ZDI-CAN-6336/ZDI-CAN-6352/ZDI-CAN-6353/ZDI-CAN-6355/ZDI-CAN-6434/ZDI-CAN-6435/ZDI-CAN-6435/ZDI-CAN-6354/CVE-2018-3940/CVE-2018-3941/CVE-2018-3942/CVE-2018-3943/CVE-2018-3944/CVE-2018-3945/CVE-2018-3946/CVE-2018-3957/CVE-2018-3962/CVE-2018-3958/CVE-2018-3959/CVE-2018-3960/CVE-2018-3961/CVE-2018-3964/CVE-2018-3965/CVE-2018-3966/CVE-2018-3967/ZDI-CAN-6439/ZDI-CAN-6455/ZDI-CAN-6471/ZDI-CAN-6472/ZDI-CAN-6473/ZDI-CAN-6474/ZDI-CAN-6475/ZDI-CAN-6477/ZDI-CAN-6478/ZDI-CAN-6479/ZDI-CAN-6480/ZDI-CAN-6481/ZDI-CAN-6482/ZDI-CAN-6483/ZDI-CAN-6484/ZDI-CAN-6485/ZDI-CAN-6486/ZDI-CAN-6487/ZDI-CAN-6501/ZDI-CAN-6502/ZDI-CAN-6503/ZDI-CAN-6504/ZDI-CAN-6505/ZDI-CAN-6506/ZDI-CAN-6507/ZDI-CAN-6509/ZDI-CAN-6511/ ZDI-CAN-6512/ZDI-CAN-6513/ZDI-CAN-6514/ZDI-CAN-6517/ZDI-CAN-6518/ZDI-CAN-6519/ZDI-CAN-6520/ZDI-CAN-6521/ZDI-CAN-6522/ZDI-CAN-6523/ZDI-CAN-6524/ ZDI-CAN-6817/ZDI-CAN-6848/ZDI-CAN-6849/ZDI-CAN-6850/ZDI-CAN-6851/ZDI-CAN-6915/ZDI-CAN-7141/ZDI-CAN-7163/ZDI-CAN-6470/ZDI-CAN-7103/ZDI-CAN-7138/ZDI-CAN-7169/ZDI-CAN-7170/CVE-2018-3993/CVE-2018-3994/CVE-2018-3995/CVE-2018-3996/CVE-2018-3997/ZDI-CAN-7067/CVE-2018-16291/CVE-2018-16293/CVE-2018-16295/CVE-2018-16296/CVE-2018-16297/CVE-2018-16294/CVE-2018-16292/ZDI-CAN-7253/ZDI-CAN-7252/ZDI-CAN-7254/ZDI-CAN-7255).
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

Abago Forgans working with Trend Micro's Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

Kamlapati Choubey working with Trend Micro's Zero Day Initiative

ManchurianClassmate from 360 Yunying Labs

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when opening a malicious file. This occurs because a dialog box pops up repeatedly, which prevents the application to be closed (ZDI-CAN-6438/ZDI-CAN-6458).
	Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability due to the use of objects which have been deleted or closed (ZDI-CAN-6614/ZDI-CAN-6616).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash. This occurs due to the use of a control object after is has been deleted within static XFA layout, or the access of a wild pointer resulting from a deleted object after XFA re-layout (ZDI-CAN-6500/ZDI-CAN-6700).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when handing certain properties of Annotation objects due to the use of freed objects (ZDI-CAN-6498/ZDI-CAN-6499/ZDI-CAN-6820/ZDI-CAN-6845/ ZDI-CAN-7157).
	Kamlapati Choubey of Trend Micro Security Research working with Trend Micro's Zero Day Initiative

Sooraj K S (@soorajks)

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when processing malicious PDF documents or certain properties of a PDF form. This occurs because the application continues to set value for the field object after it has been removed (ZDI-CAN-6890/ZDI-CAN-7068/ZDI-CAN-7069/ZDI-CAN-7070/ZDI-CAN-7145).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Uninitialized Object Information Disclosure vulnerability since there exists an uninitialized object when creating ArrayBuffer and DataView objects (CVE-2018-17781).
	Steven Seeley (mr_me) of Source Incite working with iDefense Labs

	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability when getting pageIndex object without an initial value (CVE-2018-3992).
	Abago Forgans

Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability when processing the Lower () method of a XFA object due to the abnormal data access resulting from the different definition of object character length in WideString and ByteString (ZDI-CAN-6617).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability due to the use of a null pointer without validation (ZDI-CAN-6819).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read information Disclosure vulnerability and crash when parsing certain BMP images due to the access of invalid address (ZDI-CAN-6844).
	kdot working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability when processing a PDF file which contains non-standard signatures. This issue results from the lack of proper validation when getting null value within the obtaining of signature information using OpenSSL as the written signature information is incorrect (ZDI-CAN-7073).
	Sebastian Feldmann from GoSecure working with Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].




Security updates available in Foxit Reader 9.3 and Foxit PhantomPDF 9.3

Release date: September 28, 2018

Platform: Windows

Summary


Foxit has released Foxit Reader 9.3 and Foxit PhantomPDF 9.3, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.2.0.9297 and earlier
	Windows

	Foxit PhantomPDF 
	9.2.0.9297 and all previous 9.x versions, 8.3.7.38093 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Out-of-Bounds Access/Write/Read or Use-After-Free vulnerability and crash when parsing non-integer strings during the conversion of HTML files to PDFs, which could be exploited by attackers to execute remote code (ZDI-CAN-6230/ZDI-CAN-7128/ZDI-CAN-7129/ZDI-CAN-7130/ZDI-CAN-7131/ZDI-CAN-7132). 
	bit - MeePwn team working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution or Out-of-Bounds Read Information Disclosure vulnerability and crash. This occurs when executing certain JavaScript due to the use of document and its auxiliary objects which have been closed after calling closeDoc function (ZDI-CAN-6333/ZDI-CAN-6334/ZDI-CAN-6335/ZDI-CAN-6336/ZDI-CAN-6352/ZDI-CAN-6353/ZDI-CAN-6355/ZDI-CAN-6434/ZDI-CAN-6435/ZDI-CAN-6435/ZDI-CAN-6354/CVE-2018-3940/CVE-2018-3941/CVE-2018-3942/CVE-2018-3943/CVE-2018-3944/CVE-2018-3945/CVE-2018-3946/CVE-2018-3957/CVE-2018-3962/CVE-2018-3958/CVE-2018-3959/CVE-2018-3960/CVE-2018-3961/CVE-2018-3964/CVE-2018-3965/CVE-2018-3966/CVE-2018-3967/ZDI-CAN-6439/ZDI-CAN-6455/ZDI-CAN-6471/ZDI-CAN-6472/ZDI-CAN-6473/ZDI-CAN-6474/ZDI-CAN-6475/ZDI-CAN-6477/ZDI-CAN-6478/ZDI-CAN-6479/ZDI-CAN-6480/ZDI-CAN-6481/ZDI-CAN-6482/ZDI-CAN-6483/ZDI-CAN-6484/ZDI-CAN-6485/ZDI-CAN-6486/ZDI-CAN-6487/ZDI-CAN-6501/ZDI-CAN-6502/ZDI-CAN-6503/ZDI-CAN-6504/ZDI-CAN-6505/ZDI-CAN-6506/ZDI-CAN-6507/ZDI-CAN-6509/ZDI-CAN-6511/ ZDI-CAN-6512/ZDI-CAN-6513/ZDI-CAN-6514/ZDI-CAN-6517/ZDI-CAN-6518/ZDI-CAN-6519/ZDI-CAN-6520/ZDI-CAN-6521/ZDI-CAN-6522/ZDI-CAN-6523/ZDI-CAN-6524/ ZDI-CAN-6817/ZDI-CAN-6848/ZDI-CAN-6849/ZDI-CAN-6850/ZDI-CAN-6851/ZDI-CAN-6915/ZDI-CAN-7141/ZDI-CAN-7163/ZDI-CAN-6470/ZDI-CAN-7103/ZDI-CAN-7138/ZDI-CAN-7169/ZDI-CAN-7170/CVE-2018-3993/CVE-2018-3994/CVE-2018-3995/CVE-2018-3996/CVE-2018-3997/ZDI-CAN-7067/CVE-2018-16291/CVE-2018-16293/CVE-2018-16295/CVE-2018-16296/CVE-2018-16297/CVE-2018-16294/CVE-2018-16292/ZDI-CAN-7253/ZDI-CAN-7252/ZDI-CAN-7254/ZDI-CAN-7255).
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

Abago Forgans working with Trend Micro's Zero Day Initiative

Mat Powell of Trend Micro Zero Day Initiative

Kamlapati Choubey working with Trend Micro's Zero Day Initiative

ManchurianClassmate from 360 Yunying Labs

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when opening a malicious file. This occurs because a dialog box pops up repeatedly, which prevents the application to be closed (ZDI-CAN-6438/ZDI-CAN-6458).
	Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability due to the use of objects which have been deleted or closed (ZDI-CAN-6614/ZDI-CAN-6616).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash. This occurs due to the use of a control object after is has been deleted within static XFA layout, or the access of a wild pointer resulting from a deleted object after XFA re-layout (ZDI-CAN-6500/ZDI-CAN-6700).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability when handing certain properties of Annotation objects due to the use of freed objects (ZDI-CAN-6498/ZDI-CAN-6499/ZDI-CAN-6820/ZDI-CAN-6845/ ZDI-CAN-7157). 
	Kamlapati Choubey of Trend Micro Security Research working with Trend Micro's Zero Day Initiative

Sooraj K S (@soorajks)

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash when processing malicious PDF documents or certain properties of a PDF form. This occurs because the application continues to set value for the field object after it has been removed (ZDI-CAN-6890/ZDI-CAN-7068/ZDI-CAN-7069/ZDI-CAN-7070/ZDI-CAN-7145).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Uninitialized Object Information Disclosure vulnerability since there exists an uninitialized object when creating ArrayBuffer and DataView objects (CVE-2018-17781). 
	Steven Seeley (mr_me) of Source Incite working with iDefense Labs

	Addressed a potential issue where the application could be exposed to Memory Corruption vulnerability when getting pageIndex object without an initial value (CVE-2018-3992).
	Abago Forgans

Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability when processing the Lower () method of a XFA object due to the abnormal data access resulting from the different definition of object character length in WideString and ByteString (ZDI-CAN-6617). 
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability due to the use of a null pointer without validation (ZDI-CAN-6819). 
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read information Disclosure vulnerability and crash when parsing certain BMP images due to the access of invalid address (ZDI-CAN-6844).
	kdot working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability when processing a PDF file which contains non-standard signatures. This issue results from the lack of proper validation when getting null value within the obtaining of signature information using OpenSSL as the written signature information is incorrect (ZDI-CAN-7073). 
	Sebastian Feldmann from GoSecure working with Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response Team at [email protected].



Security update in Foxit E-mail advertising system





Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the Foxit E-mail adverting system that used Interspire Email Marketer service could be exposed to Interspire Email Marketer Remote Admin Authentication Bypass vulnerability, which could be exploited by attackers to disclose information. 
	Velayutham Selvaraj of TwinTech Solutions





For more information, please contact the Foxit Security Response Team at [email protected].




Security update available in Foxit Reader 2.4.4

Release date: September 18, 2018

Platform: Linux

Summary

Foxit has released Foxit Reader 2.4.4, which addresses a potential security and stability issue. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	2.4.1.0609 and earlier
	Linux





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader, click on “Check for Updates Now” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Denial of Service vulnerability and crash due to null pointer access.
	L5 of Qihoo 360 Vulcan Team





For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit PhantomPDF 8.3.7



Release date: August 16, 2018

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.7, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.6.35572 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash due to the use of object, pointer, or document which has been freed or closed (ZDI-CAN-5415/ZDI-CAN-5416/ZDI-CAN-5417/V-88f4smlocs/ZDI-CAN-5771/ZDI-CAN-6231/ZDI-CAN-6232/ZDI-CAN-6233/ ZDI-CAN-6211/ZDI-CAN-6212/ZDI-CAN-6213/ZDI-CAN-6327/ZDI-CAN-6328/ZDI-CAN-6214/ZDI-CAN-6215/ZDI-CAN-6216/ZDI-CAN-6217/ZDI-CAN-6218/ZDI-CAN-6219/ZDI-CAN-6220/ZDI-CAN-6265/ZDI-CAN-6266/ZDI-CAN-6267/ZDI-CAN-6326/ZDI-CAN-6329/ZDI-CAN-6330/ CVE-2018-3924/CVE-2018-3939).
	Anonymous working with Trend Micro's Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working with iDefense Labs

nsfocus security team working with Trend Micro's Zero Day Initiative

bit - MeePwn team working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write vulnerability when parsing or converting JPG files due to access violation on pointer, which could be exploited by attackers to disclose information or execute remote code (ZDI-CAN-5756/ZDI-CAN-5896/ZDI-CAN-5873).
	soiax working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability when calling addAdLayer function since the certain object in the function is replaced (ZDI-CAN-6003/ZDI-CAN-6004/ZDI-CAN-6005/ZDI-CAN-6006/ZDI-CAN-6007/ZDI-CAN-6008/ZDI-CAN-6009/ZDI-CAN-6010/ZDI-CAN-6011/ZDI-CAN-6012/ZDI-CAN-6013/ZDI-CAN-6014/ZDI-CAN-6015/ZDI-CAN-6016/ZDI-CAN-6017/ZDI-CAN-6018/ZDI-CAN-6019/ZDI-CAN-6020/ZDI-CAN-6021/ZDI-CAN-6022/ZDI-CAN-6023/ZDI-CAN-6024/ZDI-CAN-6025/ZDI-CAN-6026/ZDI-CAN-6027/ZDI-CAN-6028/ZDI-CAN-6029/ZDI-CAN-6030/ZDI-CAN-6031/ZDI-CAN-6032/ZDI-CAN-6033/ZDI-CAN-6034/ZDI-CAN-6035/ZDI-CAN-6036/ZDI-CAN-6037/ZDI-CAN-6038/ZDI-CAN-6039/ZDI-CAN-6058/ZDI-CAN-6059/ZDI-CAN-6060/ZDI-CAN-5770/ZDI-CAN-5773).
	nsfocus security team working with Trend Micro's Zero Day Initiative

TrendyTofu - Trend Micro Zero Day Initiative working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Arbitrary File Write vulnerability when executing exportAsFDF or exportData JavaScript since the application does not properly validate the file type to be exported, which could lead to remote code execution (ZDI-CAN-5619/ZDI-CAN-6332/ZDI-CAN-5757).
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash. This occurs when executing certain JavaScript functions since the application could transform non-XFA-node to XFA-node and use the discrepant XFA-node directly (ZDI-CAN-5641/ZDI-CAN-5642/ZDI-CAN-5774/ZDI-CAN-6331).
	nsfocus security team working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Uninitialized Pointer Remote Code Execution vulnerability. This occurs since the array object is transformed and used as dictionary object in the cases where inline image dictionary contains invalid dictionary end symbol and array start symbol which leads to inline image to be released and new array object to be added (ZDI-CAN-5763/ZDI-CAN-6221).
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to NTLM Credentials Theft vulnerability when executing GoToE & GoToR action, which could lead to information disclosure.
	Deepu

	Addressed a potential issue where the application could be exposed to Heap-based Buffer Overflow Remote Code Execution vulnerability and crash due to out of bound of array when parsing a malformed PDF file (ZDI-CAN-6222).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Integer Overflow Remote Code Execution vulnerability and crash since the value read from a crafted PDF file exceeds the maximum value the data type can represent (ZDI-CAN-6223).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability since the ICCBased color space is replaced with Pattern color space when the application parses “ColorSpace” within a PDF (ZDI-CAN-6362/ZDI-CAN-6683).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash due to improper handling of process when executing GetAssociatedPageIndex function (ZDI-CAN-6351).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could crash when executing var test = new ArrayBuffer(0xfffffffe) JavaScript due to large buffer application.
	Zhiyuan Wang of Chengdu Qihoo360 Tech Co. Ltd





For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit Reader 9.2 and Foxit PhantomPDF 9.2



Release date: July 19, 2018

Platform: Windows

Summary

Foxit has released Foxit Reader 9.2 and Foxit PhantomPDF 9.2, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.1.0.5096 and earlier
	Windows

	Foxit PhantomPDF 
	9.1.0.5096 and all previous 9.x versions, 8.3.6.35572 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where the application could be exposed to Use-After-Free Remote Code Execution vulnerability and crash due to the use of object, pointer, or document which has been freed or closed (ZDI-CAN-5415/ZDI-CAN-5416/ZDI-CAN-5417/V-88f4smlocs/ZDI-CAN-5771/ZDI-CAN-6231/ZDI-CAN-6232/ZDI-CAN-6233/ ZDI-CAN-6211/ZDI-CAN-6212/ZDI-CAN-6213/ZDI-CAN-6327/ZDI-CAN-6328/ZDI-CAN-6214/ZDI-CAN-6215/ZDI-CAN-6216/ZDI-CAN-6217/ZDI-CAN-6218/ZDI-CAN-6219/ZDI-CAN-6220/ZDI-CAN-6265/ZDI-CAN-6266/ZDI-CAN-6267/ZDI-CAN-6326/ZDI-CAN-6329/ZDI-CAN-6330/ CVE-2018-3924/CVE-2018-3939).
	Anonymous working with Trend Micro's Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working with iDefense Labs

nsfocus security team working with Trend Micro's Zero Day Initiative

bit - MeePwn team working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Esteban Ruiz (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write vulnerability when parsing or converting JPG files due to access violation on pointer, which could be exploited by attackers to disclose information or execute remote code (ZDI-CAN-5756/ZDI-CAN-5896/ZDI-CAN-5873). 
	soiax working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability when calling addAdLayer function since the certain object in the function is replaced (ZDI-CAN-6003/ZDI-CAN-6004/ZDI-CAN-6005/ZDI-CAN-6006/ZDI-CAN-6007/ZDI-CAN-6008/ZDI-CAN-6009/ZDI-CAN-6010/ZDI-CAN-6011/ZDI-CAN-6012/ZDI-CAN-6013/ZDI-CAN-6014/ZDI-CAN-6015/ZDI-CAN-6016/ZDI-CAN-6017/ZDI-CAN-6018/ZDI-CAN-6019/ZDI-CAN-6020/ZDI-CAN-6021/ZDI-CAN-6022/ZDI-CAN-6023/ZDI-CAN-6024/ZDI-CAN-6025/ZDI-CAN-6026/ZDI-CAN-6027/ZDI-CAN-6028/ZDI-CAN-6029/ZDI-CAN-6030/ZDI-CAN-6031/ZDI-CAN-6032/ZDI-CAN-6033/ZDI-CAN-6034/ZDI-CAN-6035/ZDI-CAN-6036/ZDI-CAN-6037/ZDI-CAN-6038/ZDI-CAN-6039/ZDI-CAN-6058/ZDI-CAN-6059/ZDI-CAN-6060/ZDI-CAN-5770/ZDI-CAN-5773).
	nsfocus security team working with Trend Micro's Zero Day Initiative

TrendyTofu - Trend Micro Zero Day Initiative working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Arbitrary File Write vulnerability when executing exportAsFDF or exportData JavaScript since the application does not properly validate the file type to be exported, which could lead to remote code execution (ZDI-CAN-5619/ZDI-CAN-6332/ZDI-CAN-5757). 
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerability and crash. This occurs when executing certain JavaScript functions since the application could transform non-XFA-node to XFA-node and use the discrepant XFA-node directly (ZDI-CAN-5641/ZDI-CAN-5642/ZDI-CAN-5774/ZDI-CAN-6331).
	nsfocus security team working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

	Addressed potential issues where the application could be exposed to Uninitialized Pointer Remote Code Execution vulnerability. This occurs since the array object is transformed and used as dictionary object in the cases where inline image dictionary contains invalid dictionary end symbol and array start symbol which leads to inline image to be released and new array object to be added (ZDI-CAN-5763/ZDI-CAN-6221). 
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to NTLM Credentials Theft vulnerability when executing GoToE & GoToR action, which could lead to information disclosure. 
	Deepu

	Addressed a potential issue where the application could be exposed to Heap-based Buffer Overflow Remote Code Execution vulnerability and crash due to out of bound of array when parsing a malformed PDF file (ZDI-CAN-6222).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Integer Overflow Remote Code Execution vulnerability and crash since the value read from a crafted PDF file exceeds the maximum value the data type can represent (ZDI-CAN-6223). 
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Type Confusion Remote Code Execution vulnerability since the ICCBased color space is replaced with Pattern color space when the application parses “ColorSpace” within a PDF (ZDI-CAN-6362/ZDI-CAN-6683).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could be exposed to Out-of-Bounds Read Information Disclosure vulnerability and crash due to improper handling of process when executing GetAssociatedPageIndex function (ZDI-CAN-6351).
	Anonymous working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where the application could crash when executing var test = new ArrayBuffer(0xfffffffe) JavaScript due to large buffer application. 
	Zhiyuan Wang of Chengdu Qihoo360 Tech Co. Ltd





For more information, please contact the Foxit Security Response Team at [email protected].



Security update available in Foxit PhantomPDF 8.3.6



Release date: May 7, 2018

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.6, which addresses potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	8.3.5.30351 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where the application could be exposed to Unsafe DLL Loading vulnerability since the application passes an insufficiently qualified path in loading an external library when a user launches the application, which could be exploited by attackers to execute remote code by placing a malicious DLL in the specified path directory. 
	Ye Yint Min Thu htut


	Addressed potential issues where the application could be exposed to Heap Buffer Overflow Remote Code Execution vulnerability and crash with abusing certain function calls. (CVE-2017-17557/ZDI-CAN-5472/ZDI-CAN-5895/ZDI-CAN-5473). 
	Steven Seeley (mr_me) of Source Incite

willJ of Tencent PC Manager working with Trend Micro's Zero Day Initiative

Add of MeePwn working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to Use-After-Free vulnerability due to the use of freed object when executing JavaScript or invoking certain functions to get object properties, which could be exploited by attackers to execute remote code (CVE-2017-14458/ZDI-CAN-5436/ZDI-CAN-5527/ZDI-CAN-5528/ZDI-CAN-5529/ZDI-CAN-5531/ZDI-CAN-5617/ZDI-CAN-5618/ZDI-CAN-5620/ZDI-CAN-5579/ZDI-CAN-5580/ZDI-CAN-5488/ZDI-CAN-5489/ZDI-CAN-5312/ZDI-CAN-5432/ ZDI-CAN-5433/ZDI-CAN-5434/ZDI-CAN-5435/ZDI-CAN-5568/ZDI-CAN-5491/ZDI-CAN-5379/ZDI-CAN-5382). 
	Aleksandar Nikolic of Cisco Talos

Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

bit from meepwn team working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to Uninitialized Memory/Pointer Information Disclosure or Remote Code Execution vulnerabilities due to the use of uninitialized new Uint32Array object or member variables in PrintParams or m_pCurContex objects (ZDI-CAN-5437/ZDI-CAN-5438/CVE-2018-3842/ ZDI-CAN-5380). 
	Steven Seeley of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

bit from meepwn team working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to Out-of-Bounds Read/Write Remote Code Execution or Information Disclosure vulnerability and crash due to incorrect memory allocation, memory commit, memory access, or array access (ZDI-CAN-5442/ZDI-CAN-5490/ZDI-CAN-5413/ZDI-CAN-5754/ZDI-CAN-5755/ZDI-CAN-5758). 
	Phil Blankenship of Cerberus Security working with Trend Micro's Zero Day Initiative

Steven Seeley of Source Incite working with Trend Micro's Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working with Trend Micro's Zero Day Initiative

soiax working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to Type Confusion Remote Code Execution vulnerabilities and crash. This occurs when executing certain XFA functions in crafted PDF files since the application could transform non-CXFA_Object to CXFA_Object without judging the data type and use the discrepant CXFA_Object to get layout object directly (ZDI-CAN-5370/ZDI-CAN-5371/ZDI-CAN-5372/ZDI-CAN-5373/ ZDI-CAN-5374/ZDI-CAN-5375/ZDI-CAN-5376/ZDI-CAN-5377).
	Anonymous working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to Use-After-Free Information Disclosure or Remote Code Execution vulnerability and crash since the application could continue to traverse pages after the document has been closed or free certain objects repeatedly (ZDI-CAN-5471/ZDI-CAN-5414/CVE-2018-3853). 
	willJ of Tencent PC Manager working with Trend Micro's Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos


	Addressed a potential issue where the application could be exposed to Remote Code Execution or Information Disclosure vulnerability by abusing GoToE & GoToR Actions to open or run arbitrary executable applications on a target system.
	Assaf Baharav of Threat Response Research Team


	Addressed a potential issues where when the application is not running in Safe-Reading-Mode, it could be exposed to Out-of-Bounds Read Information Disclosure vulnerability with abusing the _JP2_Codestream_Read_SOT function (ZDI-CAN-5549).
	soiax working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to User-After-Free Remote Code Execution vulnerability due to the use of object which has been closed or removed (ZDI-CAN-5569/ZDI-CAN-5570/ZDI-CAN-5571/ZDI-CAN-5572/CVE-2018-3850/ZDI-CAN-5762/CVE-2018-10303/CVE-2018-10302). 
	Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

Steven Seeley of Source Incite working with iDefense Labs


	Addressed a potential issue where the application could be exposed to Type Confusion vulnerability when parsing files with associated file annotations due to dereference of an object of invalid type, which could lead to sensitive memory disclosure or arbitrary code execution (CVE-2018-3843). 
	Aleksandar Nikolic of Cisco Talos


	Addressed a potential issue where the application could crash when opening a PDF in a browser from Microsoft Word since the application did not handle a COM object properly. 
	Anurudh


	Addressed a potential issue where the application could be exposed to arbitrary application execution vulnerability since users could embed executable files to PDF portfolio from within the application (FG-VD-18-029). 
	Chris Navarrete of Fortinet's FortiGuard Labs






For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit Reader 9.1 and Foxit PhantomPDF 9.1 



Release date: April 19, 2018

Platform: Windows

Summary

Foxit has released Foxit Reader 9.1 and Foxit PhantomPDF 9.1, which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	9.0.1.1049 and earlier
	Windows

	Foxit PhantomPDF 
	9.0.1.1049, 9.0.0.29935, 8.3.5.30351 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for Updates” and update to the latest version.
	Click here to download the updated version of Foxit Reader from our website.
	Click here to download the updated version of Foxit PhantomPDF from our website.






Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to Unsafe DLL Loading
vulnerability since the application passes an insufficiently
qualified path in loading an external library when a user
launches the application, which could be exploited by
attackers to execute remote code by placing a malicious DLL
in the specified path directory. 
	Ye Yint Min Thu htut


	Addressed potential issues where
the
application could be exposed to Heap Buffer Overflow Remote
Code Execution vulnerability and crash with abusing certain
function calls.
(CVE-2017-17557/ZDI-CAN-5472/ZDI-CAN-5895/ZDI-CAN-5473). 

	Steven Seeley (mr_me) of Source
Incite

willJ of Tencent PC Manager working with Trend Micro's Zero
Day Initiative

Add of MeePwn working with Trend Micro's Zero Day Initiative



	Addressed potential issues where
the application could be exposed to Use-After-Free
vulnerability due to the use of freed object when executing
JavaScript or invoking certain functions to get object
properties, which could be exploited by attackers to execute
remote code
(CVE-2017-14458/ZDI-CAN-5436/ZDI-CAN-5527/ZDI-CAN-5528/ZDI-CAN-5529/ZDI-CAN-5531/ZDI-CAN-5617/ZDI-CAN-5618/ZDI-CAN-5620/ZDI-CAN-5579/ZDI-CAN-5580/ZDI-CAN-5488/ZDI-CAN-5489/ZDI-CAN-5312/ZDI-CAN-5432/
ZDI-CAN-5433/ZDI-CAN-5434/ZDI-CAN-5435/ZDI-CAN-5568/ZDI-CAN-5491/ZDI-CAN-5379/ZDI-CAN-5382). 

	Aleksandar Nikolic of Cisco Talos

Steven Seeley (mr_me) of Source Incite working with Trend
Micro's Zero Day Initiative

bit from meepwn team working with Trend Micro's Zero Day
Initiative


	Addressed potential issues where
the application could be exposed to Uninitialized
Memory/Pointer Information Disclosure or Remote Code
Execution vulnerabilities due to the use of uninitialized
new Uint32Array object or member variables in PrintParams or
m_pCurContex objects
(ZDI-CAN-5437/ZDI-CAN-5438/CVE-2018-3842/
ZDI-CAN-5380). 
	Steven Seeley of Source Incite
working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

bit from meepwn team working with Trend Micro's Zero Day
Initiative


	Addressed potential issues where
the application could be exposed to Out-of-Bounds Read/Write
Remote Code Execution or Information Disclosure
vulnerability and crash due to incorrect memory allocation,
memory commit, memory access, or array access
(ZDI-CAN-5442/ZDI-CAN-5490/ZDI-CAN-5413/ZDI-CAN-5754/ZDI-CAN-5755/ZDI-CAN-5758). 

	Phil Blankenship of Cerberus
Security working with Trend Micro's Zero Day Initiative

Steven Seeley of Source Incite working with Trend Micro's
Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working
with Trend Micro's Zero Day Initiative

soiax working with Trend Micro's Zero Day Initiative


	Addressed potential issues where
the application could be exposed to Type Confusion Remote
Code Execution vulnerabilities and crash. This occurs when
executing certain XFA functions in crafted PDF files since
the application could transform non-CXFA_Object to
CXFA_Object without judging the data type and use the
discrepant CXFA_Object to get layout object directly
(ZDI-CAN-5370/ZDI-CAN-5371/ZDI-CAN-5372/ZDI-CAN-5373/
ZDI-CAN-5374/ZDI-CAN-5375/ZDI-CAN-5376/ZDI-CAN-5377).

	Anonymous working with Trend
Micro's Zero Day Initiative


	Addressed potential issues where
the application could be exposed to Use-After-Free
Information Disclosure or Remote Code Execution
vulnerability and crash since the application could continue
to traverse pages after the document has been closed or free
certain objects repeatedly
(ZDI-CAN-5471/ZDI-CAN-5414/CVE-2018-3853). 

	willJ of Tencent PC Manager working
with Trend Micro's Zero Day Initiative

Sudhakar Verma and Ashfaq Ansari - Project Srishti working
with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos


	Addressed a potential issue where
the application could be exposed to Remote Code Execution or
Information Disclosure vulnerability by abusing GoToE &
GoToR Actions to open or run arbitrary executable
applications on a target system.

	Assaf Baharav of Threat Response
Research Team


	Addressed a potential issues where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability with abusing the
_JP2_Codestream_Read_SOT function (ZDI-CAN-5549).

	soiax working with Trend Micro's
Zero Day Initiative


	Addressed potential issues where
the application could be exposed to User-After-Free Remote
Code Execution vulnerability due to the use of object which
has been closed or removed
(ZDI-CAN-5569/ZDI-CAN-5570/ZDI-CAN-5571/ZDI-CAN-5572/CVE-2018-3850/ZDI-CAN-5762/CVE-2018-10303/CVE-2018-10302). 

	Steven Seeley (mr_me) of Source Incite
working with Trend Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

Steven Seeley of Source Incite working with iDefense Labs



	Addressed a potential issue where
the application could be exposed to Type Confusion
vulnerability when parsing files with associated file
annotations due to dereference of an object of invalid type,
which could lead to sensitive memory disclosure or arbitrary
code execution (CVE-2018-3843). 

	Aleksandar Nikolic of Cisco
Talos


	Addressed a potential issue where
the application could crash when opening a PDF in a browser
from Microsoft Word since the application did not handle a
COM object properly. 

	Anurudh


	Addressed a potential issue where
the application could be exposed to arbitrary application
execution vulnerability since users could embed executable
files to PDF portfolio from within the application
(FG-VD-18-029). 

	Chris Navarrete of Fortinet's FortiGuard Labs


	Addressed potential issues where the application could be exposed to U3D Out-of-Bounds Read/Write/Access vulnerabilities, which could lead to information disclosure or remote code execution (ZDI-CAN-5425/ZDI-CAN-5428/ ZDI-CAN-5429/ZDI-CAN-5430/ZDI-CAN-5483/ZDI-CAN-5494/ZDI-CAN-5495/ZDI-CAN-5393/ZDI-CAN-5394/ZDI-CAN-5395/ZDI-CAN-5396/ZDI-CAN-5397/ZDI-CAN-5399/ ZDI-CAN-5401/ZDI-CAN-5408/ZDI-CAN-5409/ZDI-CAN-5410/ZDI-CAN-5412/ZDI-CAN-5418/ZDI-CAN-5419/ZDI-CAN-5421/ZDI-CAN-5422/ZDI-CAN-5423/ZDI-CAN-5424/ CVE-2018-5675/CVE-2018-5677/CVE-2018-5679/CVE-2018-5680/ZDI-CAN-5392/ZDI-CAN-5426). 

	kdot working with Trend Micro's Zero Day Initiative

Dmitri Kaslov working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed potential issues where the application could be exposed to U3D Use-After-Free vulnerabilities, which could lead to remote code execution (ZDI-CAN-5427). 

	kdot working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to U3D Uninitialized Pointer vulnerabilities, which could lead to remote code execution (ZDI-CAN-5431/ZDI-CAN-5411). 

	Dmitri Kaslov working with Trend Micro's Zero Day Initiative

kdot working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to U3D Heap Buffer Overflow or Stack-based Buffer Overflow vulnerabilities, which could lead to remote code execution (ZDI-CAN-5493/ZDI-CAN-5420/ CVE-2018-5674/CVE-2018-5676/CVE-2018-5678).

	Anonymous working with Trend Micro's Zero Day Initiative

kdot working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed potential issues where the application could be exposed to U3D Type Confusion vulnerabilities, which could lead to remote code execution (ZDI-CAN-5586/CVE-2018-7407). 

	Dmitri Kaslov working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed a potential issue where the application could be exposed to U3D Parsing Array Indexing vulnerability, which could lead to remote code execution (CVE-2018-7406). 

	Steven Seeley (mr_me) of Source Incite


	Addressed potential issues where the application could be exposed to U3D Out-of-Bounds Read/Write/Access vulnerabilities, which could lead to information disclosure or remote code execution (ZDI-CAN-5425/ZDI-CAN-5428/ ZDI-CAN-5429/ZDI-CAN-5430/ZDI-CAN-5483/ZDI-CAN-5494/ZDI-CAN-5495/ZDI-CAN-5393/ZDI-CAN-5394/ZDI-CAN-5395/ZDI-CAN-5396/ZDI-CAN-5397/ZDI-CAN-5399/ ZDI-CAN-5401/ZDI-CAN-5408/ZDI-CAN-5409/ZDI-CAN-5410/ZDI-CAN-5412/ZDI-CAN-5418/ZDI-CAN-5419/ZDI-CAN-5421/ZDI-CAN-5422/ZDI-CAN-5423/ZDI-CAN-5424/ CVE-2018-5675/CVE-2018-5677/CVE-2018-5679/CVE-2018-5680/ZDI-CAN-5392/ZDI-CAN-5426). 

	kdot working with Trend Micro's Zero Day Initiative

Dmitri Kaslov working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed potential issues where the application could be exposed to U3D Use-After-Free vulnerabilities, which could lead to remote code execution (ZDI-CAN-5427). 

	kdot working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to U3D Uninitialized Pointer vulnerabilities, which could lead to remote code execution (ZDI-CAN-5431/ZDI-CAN-5411). 

	Dmitri Kaslov working with Trend Micro's Zero Day Initiative

kdot working with Trend Micro's Zero Day Initiative


	Addressed potential issues where the application could be exposed to U3D Heap Buffer Overflow or Stack-based Buffer Overflow vulnerabilities, which could lead to remote code execution (ZDI-CAN-5493/ZDI-CAN-5420/ CVE-2018-5674/CVE-2018-5676/CVE-2018-5678).

	Anonymous working with Trend Micro's Zero Day Initiative

kdot working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed potential issues where the application could be exposed to U3D Type Confusion vulnerabilities, which could lead to remote code execution (ZDI-CAN-5586/CVE-2018-7407). 

	Dmitri Kaslov working with Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of Source Incite


	Addressed a potential issue where the application could be exposed to U3D Parsing Array Indexing vulnerability, which could lead to remote code execution (CVE-2018-7406). 

	Steven Seeley (mr_me) of Source Incite






For more information, please contact the Foxit Security Response Team at [email protected].



Security updates available in Foxit MobilePDF for Android 6.1 



Release date: January 8, 2018

Platform: Android

Summary

Foxit has released Foxit MobilePDF for Android 6.1, which addresses
a potential security and stability issue.

Affected versions


	Product
	Affected versions
	Platform

	Foxit MobilePDF for Android
	6.0.2 and earlier
	Android





Solution

Update your applications to the latest versions by following one of
the instructions below.

	Click here to download the updated version of Foxit
MobilePDF for Android.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to an arbitrary file read
and disclosure vulnerability with abusing URI + escape
character during Wi-Fi transfer. This occurs because the
paths are not properly escaped or validated when processed
within the URI, and the Wi-Fi service keeps running even if
users have closed the application. 
	Benjamin Watson of VerSprite






For more information, please contact the Foxit Security Response
Team at [email protected].
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Security updates available in Foxit PhantomPDF 8.3.5



Release date: November 17, 2017

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 8.3.5, which address potential
security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	8.3.2.25013 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability. This occurs when executing
certain XFA JavaScript functions in crafted PDF files since
the application could transform non-CXFA_Node to CXFA_Node
by force without judging the data type and use the
discrepant CXFA_Node directly (ZDI-CAN-5015/
ZDI-CAN-5016/ZDI-CAN-5017/ZDI-CAN-5018/ZDI-CAN-5019/
ZDI-CAN-5020/ZDI-CAN-5021/ZDI-CAN-5022/ZDI-CAN-5027/ZDI-CAN-5029/ZDI-CAN-5288).

	Steven Seeley (mr_me) of

Offensive Security working with

Trend Micro's Zero Day Initiative

Anonymous working with Trend

Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability. This occurs when executing
certain XFA FormCalc functions in crafted PDF files since
the application could transform non-CXFA_Object to
CXFA_Object by force without judging the data type and use
the discrepant CXFA_Object directly
(ZDI-CAN-5072/ZDI-CAN-5073).
	Steven Seeley (mr_me) of

Offensive Security working with

Trend Micro's Zero Day Initiative

	 Addressed potential issues where
the application could be exposed to Use-After-Free Remote
Code Execution vulnerability due to the use of Annot object
which has been freed
(ZDI-CAN-4979/ZDI-CAN-4980/ZDI-CAN-4981/ZDI-CAN-5023/ZDI-CAN-5024/ZDI-CAN-5025/ZDI-CAN-5026/ZDI-CAN-5028).

	Steven Seeley (mr_me) of

Offensive Security working with

Trend Micro's Zero Day Initiative

	Addressed potential issues where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability with abusing the
_JP2_Codestream_Read_SOT function
(ZDI-CAN-4982/ZDI-CAN-5013/ZDI-CAN-4976/ZDI-CAN-4977/ZDI-CAN-5012/
ZDI-CAN-5244).
	soiax working with Trend
Micro's

Zero Day Initiative

kdot working with Trend Micro's

Zero Day Initiative

Carlos Garcia Prado working with

Trend Micro's Zero Day Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability due to abnormal memory access with
abusing the lrt_jp2_decompress_write_stripe function call to
open arbitrary file (ZDI-CAN-5014).
	kdot working with Trend Micro's 

Zero Day Initiative

	Addressed potential issues where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability when rendering images
with abusing the render.image function call to open a local
PDF file (ZDI-CAN-5078/ZDI-CAN-5079).
	Ashraf Alharbi (Ha5ha5hin)

working with Trend Micro's Zero

Day Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability with abusing the
GetBitmapWithoutColorKey function call to open an abnormal
PDF file (ZDI-CAN-4978).
	kdot working with Trend Micro's 

Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability due to uninitialized
pointer with abusing the JP2_Format_Decom function call to
open an abnormal PDF file (ZDI-CAN-5011). 
	kdot working with Trend Micro's 

Zero Day Initiative

	Addressed potential issues where
the application could be exposed to User-After-Free Remote
Code Execution vulnerability due to the inconsistency of XFA
nodes and XML nodes after deletion during data binding
(ZDI-CAN-5091/ZDI-CAN-5092/ZDI-CAN-5289). 
	Anonymous working with
Trend 

Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to User-After-Free Remote
Code Execution vulnerability due to the use of document
after it has been freed by closeDoc JavaScript
(ZDI-CAN-5094/ZDI-CAN-5282/ZDI-CAN-5294/ZDI-CAN-5295/ZDI-CAN-5296). 

	Steven Seeley (mr_me) of

Offensive Security working with

Trend Micro's Zero Day Initiative

Steven Seeley of Source Incite

working with Trend Micro's Zero

Day Initiative

bit from meepwn team working 

with Trend Micro's Zero Day

Initiative

	Addressed a potential issue where
when the application is running in single instance mode, it
could be exposed to arbitrary code execution or denial of
service vulnerability and fail to initialize PenInputPanel
component by calling CoCreateInstance function when users
open a PDF file by double click after launching the
application (CVE-2017-14694). 
	Lin Wang, Beihang University,

China

	Addressed a potential issue where
the application could be exposed to Buffer Overflow
vulnerability when opening certain EPUB file due to the
invalid length of size_file_name in CDRecord in the ZIP
compression data. 
	Phil Blankenship of Cerberus
Security

	Addressed a potential issue where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability when opening certain XFA files
due to the use of discrepant data object during data binding
(ZDI-CAN-5216). 
	Anonymous working with
Trend 

Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability when the gflags app is
enabled due to the incorrect resource loading which could
lead to disordered file type filter (ZDI-CAN-5281). 

	Steven Seeley of Source Incite 

working with Trend Micro's Zero

Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability due to the calling of
incorrect util.printf parameter (ZDI-CAN-5290). 
	Anonymous working with Trend

Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit MobilePDF for iOS 6.1



Release date: November 12, 2017

Platform: iOS

Summary

Foxit has released Foxit MobilePDF for iOS 6.1, which addresses
potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit MobilePDF for iOS
	6.0.0 and earlier
	iOS





Solution

Update your applications to the latest versions by following one of
the instructions below.

	Click here
to download the updated version of Foxit MobilePDF for iOS







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to a denial-of-service
vulnerability. This occurs when users upload a file which
includes hexadecimal Unicode character in the “filename”
parameter via Wi-Fi since the application could fail to
parse such file name. 
	Antonio Zekić of INFIGO IS
d.o.o.

	Addressed a potential issue where
the application could be exposed to a Directory Traversal
vulnerability with abusing the URL + escape character during
Wi-Fi transfer, which could be exploited by attackers to
manipulate the local application files maliciously. 

	Antonio Zekić of INFIGO IS
d.o.o.





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 9.0 and Foxit PhantomPDF
9.0



Release date: November 1, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 9.0 and Foxit PhantomPDF 9.0, which
address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader
	8.3.2.25013 and earlier
	Windows

	Foxit PhantomPDF
	8.3.2.25013 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability. This occurs when executing
certain XFA JavaScript functions in crafted PDF files since
the application could transform non-CXFA_Node to CXFA_Node
by force without judging the data type and use the
discrepant CXFA_Node directly (ZDI-CAN-5015/
ZDI-CAN-5016/ZDI-CAN-5017/ZDI-CAN-5018/ZDI-CAN-5019/
ZDI-CAN-5020/ZDI-CAN-5021/ZDI-CAN-5022/ZDI-CAN-5027/ZDI-CAN-5029/ZDI-CAN-5288).

	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative

Anonymous working with Trend
 Micro's Zero Day Initiative


	Addressed potential issues where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability. This occurs when executing
certain XFA FormCalc functions in crafted PDF files since
the application could transform non-CXFA_Object to
CXFA_Object by force without judging the data type and use
the discrepant CXFA_Object directly
(ZDI-CAN-5072/ZDI-CAN-5073).
	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative

	Addressed potential issues where
the application could be exposed to Use-After-Free Remote
Code Execution vulnerability due to the use of Annot object
which has been freed
(ZDI-CAN-4979/ZDI-CAN-4980/ZDI-CAN-4981/ZDI-CAN-5023/ZDI-CAN-5024/ZDI-CAN-5025/ZDI-CAN-5026/ZDI-CAN-5028).

	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative

	Addressed potential issues where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability with abusing the
_JP2_Codestream_Read_SOT function
(ZDI-CAN-4982/ZDI-CAN-5013/ZDI-CAN-4976/ZDI-CAN-4977/ZDI-CAN-5012/
ZDI-CAN-5244).
	soiax working with Trend
Micro's
 Zero Day Initiative

kdot working with Trend Micro's
 Zero Day Initiative

Carlos Garcia Prado working with
 Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability due to abnormal memory access with
abusing the lrt_jp2_decompress_write_stripe function call to
open arbitrary file (ZDI-CAN-5014).
	kdot working with Trend Micro's

 Zero Day Initiative

	Addressed potential issues where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability when rendering images
with abusing the render.image function call to open a local
PDF file (ZDI-CAN-5078/ZDI-CAN-5079). 
	Ashraf Alharbi (Ha5ha5hin)
working
with Trend Micro's Zero
 Day Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to Out-of-Bounds Read Information
Disclosure vulnerability with abusing the
GetBitmapWithoutColorKey function call to open an abnormal
PDF file (ZDI-CAN-4978).
	kdot working with Trend Micro's

 Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability due to uninitialized
pointer with abusing the JP2_Format_Decom function call to
open an abnormal PDF file (ZDI-CAN-5011). 
	kdot working with Trend Micro's

 Zero Day Initiative

	Addressed potential issues where
the application could be exposed to User-After-Free Remote
Code Execution vulnerability due to the inconsistency of XFA
nodes and XML nodes after deletion during data binding
(ZDI-CAN-5091/ZDI-CAN-5092/ZDI-CAN-5289).
	Anonymous working with Trend 
Micro's
Zero Day Initiative

	Addressed potential issues where
the application could be exposed to User-After-Free Remote
Code Execution vulnerability due to the use of document
after it has been freed by closeDoc JavaScript
(ZDI-CAN-5094/ZDI-CAN-5282/ZDI-CAN-5294/ZDI-CAN-5295/ZDI-CAN-5296). 

	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative

Steven Seeley of Source Incite
 working with Trend
Micro's Zero
 Day Initiative

bit from meepwn team working 
with Trend Micro's Zero Day

Initiative

	Addressed a potential issue where
when the application is running in single instance mode, it
could be exposed to arbitrary code execution or denial of
service vulnerability and fail to initialize PenInputPanel
component by calling CoCreateInstance function when users
open a PDF file by double click after launching the
application (CVE-2017-14694).
	Lin Wang, Beihang University,

China

	Addressed a potential issue where
the application could be exposed to Buffer Overflow
vulnerability when opening certain EPUB file due to the
invalid length of size_file_name in CDRecord in the ZIP
compression data.
	Phil Blankenship of Cerberus
Security

	Addressed a potential issue where
the application could be exposed to Type Confusion Remote
Code Execution vulnerability when opening certain XFA files
due to the use of discrepant data object during data binding
(ZDI-CAN-5216). 
	Anonymous working with Trend 
Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability when the gflags app is
enabled due to the incorrect resource loading which could
lead to disordered file type filter (ZDI-CAN-5281). 

	Steven Seeley of Source Incite 
working
with Trend Micro's Zero
 Day Initiative

	Addressed a potential issue where
the application could be exposed to Out-of-Bounds Read
Information Disclosure vulnerability due to the calling of
incorrect util.printf parameter (ZDI-CAN-5290).
	Anonymous working with Trend

Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PhantomPDF 7.3.17



Release date: September 11, 2017

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 7.3.17, which address potential
security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	7.3.15.712 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
when the application is not running in Safe-Reading-mode, it
could be exposed to command injection vulnerability with
abusing the app.launchURL JavaScript call to execute a local
program.
	Ariele Caltabiano
(kimiya)
working
with Trend
 Micro's Zero
Day Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to an Arbitrary File Write vulnerability
with abusing the this.saveAs function call to drop a file to
the local file system.
	Steven Seeley (mr_me) 
of

Offensive Security
 working with
 Trend Micro's Zero
Day 
Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to an Arbitrary Write vulnerability with
abusing the createDataObject function call to create
arbitrary executable file in the local file system.
	Steven Seeley (mr_me)
Chris
Evans /
 scarybeasts

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to command injection vulnerability with
abusing the xfa.host.gotoURL function call to open arbitrary
executable file.
	Steven Seeley (mr_me) 
of

Offensive Security
 working with
 Trend Micro's Zero
Day 
Initiative
Alexander Inführ





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 8.3.2 and Foxit PhantomPDF
8.3.2



Release date: August 26, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 8.3.2 and Foxit PhantomPDF 8.3.2,
which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.3.1.21155 and earlier
	Windows

	Foxit PhantomPDF
	8.3.1.21155 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
when the application is not running in Safe-Reading-mode, it
could be exposed to command injection vulnerability with
abusing the app.launchURL JavaScript call to execute a local
program.
	Ariele Caltabiano (kimiya)

working with Trend Micro's Zero
 Day Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to an Arbitrary File Write vulnerability
with abusing the this.saveAs function call to drop a file to
the local file system.
	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to an Arbitrary Write vulnerability with
abusing the createDataObject function call to create
arbitrary executable file in the local file system. 

	Steven Seeley (mr_me)
Chris
Evans / scarybeasts

	Addressed a potential issue where
when the application is not running in Safe-Reading-Mode, it
could be exposed to command injection vulnerability with
abusing the xfa.host.gotoURL function call to open arbitrary
executable file. 
	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative
Alexander Inführ





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PDF Compressor 7.7.2.23




Release date: July 26, 2017

Platform: Windows

Summary

Foxit has released Foxit PDF Compressor 7.7.2.23, which addresses a
potential security and stability issue. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Compressor
	From 7.0.0.183 to 7.7.2.10
	Windows





Solution

No further action is required if you have installed the application
securely. To get the latest version of Foxit PDF Compressor, please click here. 





Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application's installer package could be exposed to a
DLL Pre-Loading vulnerability, which could be leveraged by
attackers to execute remote code during the installation
process.
	Kushal Arvind Shah of Fortinet's

FortiGuard Labs





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PhantomPDF 7.3.15



Release date: July 20, 2017

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 7.3.15, which address security
vulnerabilities that could potentially allow an attacker to execute remote
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	7.3.13.421 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a Null Pointer Read or
Null Pointer Deference vulnerability, which could lead to
unexpected crash.
	Dmitri Kaslov

	Addressed potential issues where
the application could still execute JavaScript functions
even when the JavaScript Actions in Trust Manager had been
disabled.
	Alexander Inführ

	Addressed potential issues where
the application could be exposed to Use-After-Free
vulnerabilities, which could be exploited by attackers to
execute remote code.
	Steven Seeley (mr_me) of

Offensive Security working with 
Trend Micro's Zero Day
Initiative

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read
vulnerability, which could lead to information
disclosure.
	Ashfaq Ansari - Project Srishti

working with Trend Micro's Zero 
Day Initiative

	Addressed a potential issue where
the application could be exposed to an Arbitrary Write
vulnerability, which could be leveraged by attackers to
execute remote code.
	Ashfaq Ansari - Project Srishti


	Addressed a potential issue where
the application could be exposed to a
Use-Before-Initialization vulnerability, which could lead to
unexpected crash.
	Jean-Marc Le Blanc





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 8.3.1 and Foxit PhantomPDF
8.3.1



Release date: July 04, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 8.3.1 and Foxit PhantomPDF 8.3.1,
which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.3.0.14878 and earlier
	Windows

	Foxit PhantomPDF 
	8.3.0.14878 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here
download the updated version of Foxit Reader from our website.

	Click here
download the updated version of Foxit PhantomPDF from our website. If you
already have a PhantomPDF 8 license, you can update to PhantomPDF 8.3.1 for
free.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a Null Pointer Read or
Null Pointer Deference vulnerability, which could lead to
unexpected crash.
	Dmitri Kaslov

	Addressed potential issues where
the application could still execute JavaScript functions
even when the JavaScript Actions in Trust Manager had been
disabled. 
	Alexander Inführ

	Addressed potential issues where
the application could be exposed to Use-After-Free
vulnerabilities, which could be exploited by attackers to
execute remote code. 
	Steven Seeley (mr_me) of

Offensive Security working with 
Trend Micro's Zero Day
Initiative

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read
vulnerability, which could lead to information
disclosure. 
	Ashfaq Ansari - Project Srishti

working with Trend Micro's Zero 
Day Initiative

	Addressed a potential issue where
the application could be exposed to an Arbitrary Write
vulnerability, which could be leveraged by attackers to
execute remote code. 
	Ashfaq Ansari - Project Srishti


	Addressed a potential issue where
the application could be exposed to a
Use-Before-Initialization vulnerability, which could lead to
unexpected crash. 
	Jean-Marc Le Blanc





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PhantomPDF 7.3.13

 

Release date: May 4, 2017

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 7.3.13, which address security
vulnerabilities that could potentially allow an attacker to execute remote
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF 
	7.3.11.1122 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, go to “Check for Update” and update
to the latest version.

	Click here
to download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be exploited by attackers to
execute remote code under the context of the current
process.
	NSFOCUS Security Team

SkyLined and Soiax working with

Trend Micro's Zero Day Initiative

Steven Seeley (mr_me) of

Offensive Security working with

Trend Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to a Type Confusion
vulnerability, which could be exploited by attackers to
execute remote code under the context of the current
process.
	NSFOCUS Security Team

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read
vulnerability, which could lead to information disclosure or
remote code execution.
	Ke Liu of Tencent's Xuanwu LAB

working with Trend Micro's Zero

Day Initiative

Ashfaq Ansari - Project Srishti

working with Trend Micro's Zero

Day Initiative

SkyLined and Soiax working with

Trend Micro's Zero Day Initiative

lightseeker working with Trend

Micro's Zero Day Initiative

Anonymous1 working with Trend

Micro's Zero Day Initiative

Toan Pham Van working with

Trend Micro's Zero Day Initiative

kdot working with Trend Micro's

Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Null Pointer
Dereference vulnerability when open a crafted PDF file,
which could cause the application to crash unexpectedly.

	riusksk of Tencent Security
Platform
Department

	Addressed a potential issue where
the application could be exposed to a memory corruption
vulnerability, which could be leveraged by attackers to
execute remote code.
	Toan Pham Van working with
Trend
Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Write/Read vulnerability, which could be
exploited by attackers to execute remote code or leak
information.
	kdot working with Trend Micro's

Zero Day Initiative

Gogil of STEALIEN working with

Trend Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be exploited by attackers to
execute remote code.
	Steven Seeley of Source Incite

working with Trend Micro's Zero

Day Initiative

kdot working with Trend Micro's 

Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Font Parsing
Out-of-Bounds Read vulnerability, which could lead to
information disclosure.
	kdot working with Trend Micro's

Zero Day Initiative

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read or
Memory Corruption vulnerability when converting JPEG or TIFF
files to PDFs, which could be exploited by attackers to
execute remote code or leak information.
	Ke Liu of Tencent's Xuanwu LAB

working with Trend Micro's Zero

Day Initiative

Juan Pablo Lopez Yacubian

working with Trend Micro's Zero

Day Initiative

	Addressed potential issues where
the application could be exposed to Use-After-Free
vulnerabilities, which could be exploited by attackers to
execute remote code.
	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative
Dmitri Kaslov

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Write vulnerability, which could lead to
remote code execution. 
	Toan Pham Van working with

Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a null pointer
vulnerability, which could lead to unexpected crash. 

	Dmitri Kaslov (PwC za-labs)






For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 8.3 and Foxit PhantomPDF
8.3

 

Release date: April 18, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 8.3 and Foxit PhantomPDF 8.3, which
address potential security and stability issues.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.2.1.6871 and earlier
	Windows

	Foxit PhantomPDF 
	8.2.1.6871 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website. If you
already have a PhantomPDF 8 license, you can update to PhantomPDF 8.3 for
free.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to Use-After-Free
vulnerabilities, which could be exploited by attackers to
execute remote code.
	Steven Seeley (mr_me) of

Offensive Security working with
 Trend Micro's Zero Day
Initiative
Dmitri Kaslov

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Write vulnerability, which could lead to
remote code execution. 
	Toan Pham Van working with

Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a null pointer
vulnerability, which could lead to unexpected crash. 

	Dmitri Kaslov (PwC za-labs)






For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PDF Toolkit 2.1

 

Release date: April 6, 2017

Platform: Windows

Summary

Foxit has released Foxit PDF Toolkit 2.1, which addresses a
potential security issue.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Toolkit 
	2.0
	Windows





Solution

Update Foxit PDF Toolkit to the latest version by clicking here
to download it from our website.





Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to a memory corruption
vulnerability, which could be exploited by attackers to
execute arbitrary code (CVE-2017-7584).
	Kushal Arvind Shah of Fortinet's
FortiGuard Labs







Security updates available in Foxit Reader 8.2.1 and Foxit PhantomPDF
8.2.1

 

Release date: March 1, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 8.2.1 and Foxit PhantomPDF 8.2.1,
which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.2.0.2051 and earlier
	Windows

	Foxit PhantomPDF 
	8.2.0.2192 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website. If you
already have a PhantomPDF 8 license, you can update to PhantomPDF 8.2.1 for
free.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be exploited by attackers to
execute remote code under the context of the current
process.
	NSFOCUS Security Team
SkyLined
and Soiax working with
Trend Micro's Zero Day
Initiative
Steven Seeley (mr_me) of
 Offensive
Security working with
 Trend Micro's Zero Day Initiative


	Addressed potential issues where
the application could be exposed to a Type Confusion
vulnerability, which could be exploited by attackers to
execute remote code under the context of the current
process.
	NSFOCUS Security Team

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read
vulnerability, which could lead to information disclosure or
remote code execution. 
	Ke Liu of Tencent's Xuanwu LAB

working with Trend Micro's Zero
 Day Initiative
Ashfaq
Ansari - Project Srishti
 working with Trend Micro's Zero

Day Initiative
SkyLined and Soiax working with
 Trend
Micro's Zero Day Initiative
lightseeker working with
Trend
 Micro's Zero Day Initiative
Anonymous1 working
with Trend
 Micro's Zero Day Initiative
Toan Pham Van
working with
 Trend Micro's Zero Day Initiative

kdot working with Trend Micro's
 Zero Day Initiative


	Addressed a potential issue where
the application could be exposed to a Null Pointer
Dereference vulnerability when open a crafted PDF file,
which could cause the application to crash
unexpectedly. 
	riusksk of Tencent Security
Platform
Department

	Addressed a potential issue where
the application could be exposed to a memory corruption
vulnerability, which could be leveraged by attackers to
execute remote code. 
	Toan Pham Van working with

Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 8.2 and Foxit PhantomPDF
8.2

 

Release date: January 10, 2017

Platform: Windows

Summary

Foxit has released Foxit Reader 8.2 and Foxit PhantomPDF 8.2, which
address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.1.4.1208 and earlier
	Windows

	Foxit PhantomPDF 
	8.1.1.1115 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website. If you
already have a PhantomPDF 8 license, you can update to PhantomPDF 8.2 for
free.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Write/Read vulnerability, which could be
exploited by attackers to execute remote code or leak
information.
	kdot working with Trend Micro's

Zero Day Initiative

Gogil of STEALIEN working with
 Trend Micro's Zero Day
Initiative

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be exploited by attackers to
execute remote code.
	Steven Seeley of Source Incite 
working
with Trend Micro's Zero
Day Initiative
kdot working
with Trend Micro's 
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Font Parsing
Out-of-Bounds Read vulnerability, which could lead to
information disclosure. 
	kdot working with Trend Micro's

Zero Day Initiative

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read or
Memory Corruption vulnerability when converting JPEG or TIFF
files to PDFs, which could be exploited by attackers to
execute remote code or leak information. 
	Ke Liu of Tencent's Xuanwu LAB 
working
with Trend Micro's Zero 
Day Initiative
Juan Pablo
Lopez Yacubian
 working with Trend Micro's Zero
 Day
Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader for Linux 2.3

 

Release date: January 10, 2017

Platform: Linux

Summary

Foxit has released Foxit Reader for Linux 2.3, which address
potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	2.2.1025 and earlier
	Linux





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader, click on “Check for Updates Now” and
update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to a stack overflow
vulnerability, which could be exploited by attackers to
execute a controlled crash.
	Dmitri Kaslov





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PDF Toolkit 2.0

 

Release date: January 10, 2017

Platform: Windows

Summary

Foxit has released Foxit PDF Toolkit 2.0, which addresses a
potential security issue.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF Toolkit
	1.3
	Windows





Solution

Update Foxit PDF Toolkit to the latest version by clicking here
to download it from our website.





Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to a memory corruption
vulnerability when parsing PDF files, which could cause
remote code execution (CVE-2017-5364).
	Kushal Arvind Shah of Fortinet's
FortiGuard Labs















2016

 



Security updates available in Foxit Reader 8.1.1 and Foxit PhantomPDF
8.1.1

 

Release date: November 17, 2016

Platform: Windows

Summary

Foxit has released Foxit Reader 8.1.1 and Foxit PhantomPDF 8.1.1,
which address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.1.0.1013 and earlier
	Windows

	Foxit PhantomPDF 
	8.1.0.1013 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Read vulnerability, which could lead to
information disclosure. 
	Gogil of STEALIEN working with 
Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG2000 Parsing
Use-After-Free vulnerability, which could be leveraged by
attackers to execute remote code. 
	Gogil of STEALIEN working with 
Trend
Micro's Zero Day Initiative 

	Addressed a potential issue where
the application could be exposed to a JPEG2000 Parsing
Heap-Based Buffer Overflow vulnerability, which could be
exploited by attackers to execute remote code. 
	Gogil of STEALIEN working with

Trend Micro's Zero Day Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 8.1 and Foxit PhantomPDF
8.1

 

Release date: October 18, 2016

Platform: Windows

Summary

Foxit has released Foxit Reader 8.1 and Foxit PhantomPDF 8.1, which
address potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.0.5 and earlier
	Windows

	Foxit PhantomPDF 
	8.0.5 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates (Now)” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a Heap Corruption
vulnerability, which could be exploited by attackers to
execute arbitrary code.
	Dmitri Kaslov
Ke Liu of
Tencent’s Xuanwu LAB

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be leveraged by attackers to
execute arbitrary code. 
	Dmitri Kaslov
Steven Seeley of
Source Incite
Rocco Calvi

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read or
Out-of-Bounds Write vulnerability, which could lead to
remote code execution or information disclosure. 
	Ke Liu of Tencent’s Xuanwu LAB
Rocco
Calvi
kdot working with Trend Micro's Zero Day Initiative
Soiax
working with Trend Micro's Zero Day Initiative
Dmitri
Kaslov
Steven Seeley of Source Incite working with Trend
Micro's Zero Day
SkyLined and Soiax working with Trend
Micro's Zero Day Initiative

Aleksandar Nikolic of Cisco Talos

	Addressed a potential issue where
the application could be exposed to a Null Pointer
Dereference vulnerability, which could cause the application
to crash unexpectedly. 
	Dmitri Kaslov 

	Addressed potential issues where
the application could be exposed to Heap Buffer Overflow
vulnerability, which could lead to remote code
execution. 
	kdot working with Trend Micro's
Zero Day Initiative
Ke Liu of Tencent’s Xuanwu LAB
SkyLined
and Soiax working with Trend Micro's Zero Day Initiative


	Addressed a potential issue where
the application could be exposed to an Integer Overflow
vulnerability, which could lead to remote code
execution.
	kdot working with Trend Micro's
Zero Day Initiative





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader for Mac and Linux
2.2

 

Release date: October 18, 2016

Platform:  Mac OS X/Linux

Summary

Foxit has released Foxit Reader for Mac and Linux 2.2, which address
potential security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	2.1.0.0805 and earlier
	Linux

	Foxit Reader 
	2.1.0.0804 and earlier
	Mac OS X





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader, click on “Check for Updates Now” and
update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a local privilege
escalation vulnerability due to the weak file permissions,
which could be exploited by attackers to execute arbitrary
code(CVE-2016-8856).
	c0dist (Garage4Hackers)





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader for Windows 8.0.2, Foxit
Reader for Mac/Linux 2.1, and Foxit PhantomPDF 8.0.2

 

Release date: August 8, 2016

Platform: Windows, Mac OS X, Linux

Summary

Foxit has released Foxit Reader for Windows 8.0.2, Foxit Reader for
Mac/Linux 2.1, and Foxit PhantomPDF 8.0.2, which address security and stability
issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	8.0.0.624 and earlier
	Windows

	Foxit Reader 
	2.0.0.0625 and earlier
	Mac OS X

	Foxit Reader 
	1.1.1.0602 and earlier
	Linux

	Foxit PhantomPDF 
	8.0.1.628 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Updates (Now)” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website..







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a TIFF Parsing
Out-of-Bounds Read/Write vulnerability, which could be
leveraged by attackers to execute remote code or leak
information. 
	Ke Liu of Tencent’s Xuanwu LAB 
Steven
Seeley of Source Incite 
5206560A306A2E085A437FD258EB57CE
working with Trend Micro's Zero Day Initiative
Steven
Seeley of Source Incite working with Trend Micro's Zero Day
Initiative


	Addressed a potential issue where
the application could be exposed to a Use-After-Free
vulnerability when attempting to parse malformed FlateDecode
Streams, which could be leveraged by attackers to leak
sensitive information or execute remote code. 
	 Rocco Calvi and Steven Seeley of
Source Incite

	Addressed potential issues where
the application could be exposed to an Out-Of-Bounds
Read/Write vulnerability when parsing JPEG2000 files, which
could be leveraged by attackers to leak information or
execute remote code.
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to memory corruption
vulnerability when parsing JPEG2000 files, which could cause
remote code execution.
	Ke Liu of Tencent’s Xuanwu LAB


	Addressed a potential issue where
the application could be exposed to a DLL hijacking
vulnerability that could allow an unauthenticated remote
attacker to execute arbitrary code on the targeted
system.
	Himanshu Mehta

	Addressed potential issues where
the application could be exposed to a JPXDecode
Out-of-Bounds Read/Write vulnerability when processing
specially crafted PDF files with malformed JPXDecode
streams, which could cause information leak or remote code
execution (CVE-2016-6867).
	Steven Seeley of Source Incite 
Kai
Lu of Fortinet's FortiGuard Labs

	Addressed a potential issue where
the application could be exposed to an Out-of-Bounds Read
vulnerability when processing specially crafted BMP files,
which could cause information leak.
	Steven Seeley of Source Incite
5206560A306A2E085A437FD258EB57CE working with Trend Micro's
Zero Day Initiative

	Addressed a potential memory
corruption vulnerabilities which could cause the application
to crash unexpectedly (CVE-2016-6868).
	Marco Grassi (@marcograss) of
KeenLab (@keen_lab), Tencent
Kai Lu of Fortinet's
FortiGuard Labs





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader and Foxit PhantomPDF
8.0

 

Release date: June 27, 2016

Platform: Windows

Summary

Foxit has released Foxit Reader and Foxit PhantomPDF 8.0, which
address security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.3.4.311 and earlier
	Windows

	Foxit PhantomPDF 
	7.3.4.311 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, click on “Check for
Update” and update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.

	Click here
to download the updated version of Foxit PhantomPDF from our website.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to a Use-After-Free Remote
Code Execution vulnerability when opening a XFA file whose
layout direction is set as “lr-tb”.
	Rocco Calvi

	Addressed a potential issue where
the application could be exposed to a FlatDecode
Use-After-Free Remote Code Execution vulnerability when
parsing the inline image in certain PDF file
(CVE-2016-6168).
	Steven Seeley of Source Incite,
working with Trend Micro's Zero Day Initiative 
Kushal
Arvind Shah of Fortinet's FortiGuard Labs

	Addressed a potential issue where
the application could be exposed to a Safe Mode Bypass
Information Disclosure vulnerability when handling SWF
content that is embedded in a PDF file, which could be
leveraged by attackers to access user’s local files or
remote resources.
	Björn Ruytenberg working with Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to an exportData
Restrictions Bypass Remote Code Execution vulnerability,
which could be leveraged by attackers to execute a malicious
file.
	insertscript working with Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF TIFF
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability when converting certain TIFF file to PDF
file.
	Steven Seeley of Source Incite
working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG Parsing
Out-of-Bounds Read Information Disclosure vulnerability when
converting a JPEG file that contains incorrect EXIF data to
PDF file.
	AbdulAziz Hariri - Trend Micro Zero
Day Initiative working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG Parsing
Out-of-Bounds Read Information Disclosure vulnerability when
parsing a JPEG image with corrupted color component in a PDF
file. 
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF GIF
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability when converting certain GIF file to PDF
file.
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF BMP
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability or a ConvertToPDF BMP Parsing Out-of-Bounds
Read Information Disclosure vulnerability when converting a
BMP file to PDF file.
	kdot and anonymous working with
Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to an Out-of-Bounds Read
vulnerability which could be leveraged by attackers to
execute remote code under the context of the current
process.
	Ke Liu of Tencent’s Xuanwu LAB


	Addressed a potential issue where
the application could be exposed to a Heap Buffer Overflow
Remote Code Execution vulnerability when processing
specially crafted TIFF files with large SamplesPerPixel
values.
	Steven Seeley of Source Incite


	Addressed a potential issue where
the application could be exposed to a Stack Buffer Overflow
Remote Code Execution vulnerability when parsing an
unusually long GoToR string. 
	Abdul-Aziz Hariri of Trend Micro
Zero Day Initiative, working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could crash unexpectedly when parsing a PDF
file that contains messy code in its image description.

	Rocco Calvi and Steven Seeley of
Source Incite, working with Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Pattern Uninitialized
Pointer Remote Code Execution vulnerability when processing
a stretched image in certain PDF files. 
	Steven Seeley of Source Incite,
working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Heap Overflow
vulnerability when parsing the content of a PDF file
containing incorrect Bezier data (CVE-2016-6169).
	Kai Lu of Fortinet's FortiGuard
Labs





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader for Linux 1.1.1

 

Release date: June 12, 2016

Platform: Linux

Summary

Foxit has released Foxit Reader for Linux 1.1.1, which addresses
security and stability issues. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	1.1.0.0225 and earlier
	Linux





Solution

Update your application to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, click on “Check for Updates Now” and
update to the latest version.

	Click here to
download the updated version of Foxit Reader from our website.







Vulnerability details

	Brief
	Acknowledgement

	
Addressed potential issues where the application
could crash unexpectedly due to memory corruption or invalid
read when opening a specially crafted PDF file, which could
be leveraged by attackers to execute a controlled crash.

	Mateusz Jurczyk of Google Project
Zero





For more information, please contact the Foxit Security Response
Team at [email protected].




Security updates available in Foxit PhantomPDF 7.3.11

 

Release date: November 30, 2016

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 7.3.11, which address security
vulnerabilities that could potentially allow an attacker to execute remote
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	7.3.9.816 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, go to “Check for Update” and update
to the latest version.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a JPEG2000 Parsing
Out-of-Bounds Read vulnerability, which could lead to
information disclosure.
	Gogil of STEALIEN working with 
Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG2000 Parsing
Use-After-Free vulnerability, which could be leveraged by
attackers to execute remote code.
	Gogil of STEALIEN working with 
Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG2000 Parsing
Heap-Based Buffer Overflow vulnerability, which could be
exploited by attackers to execute remote code.
	Gogil of STEALIEN working with 
Trend
Micro's Zero Day Initiative

	Addressed potential issues where
the application could be exposed to a Heap Corruption
vulnerability, which could be exploited by attackers to
execute arbitrary code.
	Dmitri Kaslov
Ke Liu of
Tencent’s Xuanwu LAB

	Addressed potential issues where
the application could be exposed to a Use-After-Free
vulnerability, which could be leveraged by attackers to
execute arbitrary code.
	Dmitri Kaslov
Steven Seeley of
Source Incite
Rocco Calvi

	Addressed potential issues where
the application could be exposed to an Out-of-Bounds Read or
Out-of-Bounds Write vulnerability, which could lead to
remote code execution or information disclosure.
	Ke Liu of Tencent’s Xuanwu LAB

Rocco Calvi

kdot working with Trend Micro's Zero 
Day Initiative

Soiax working with Trend Micro's Zero 
Day Initiative

Dmitri Kaslov

Steven Seeley of Source Incite working 
with Trend
Micro's Zero Day

SkyLined and Soiax working with Trend
 Micro's Zero Day
Initiative

Aleksandar Nikolic of Cisco Talos



	Addressed a potential issue where
the application could be exposed to a Null Pointer
Dereference vulnerability, which could cause the application
to crash unexpectedly.
	Dmitri Kaslov

	Addressed potential issues where
the application could be exposed to Heap Buffer Overflow
vulnerability, which could lead to remote code
execution.
	kdot working with Trend Micro's
Zero 
Day Initiative

Ke Liu of Tencent’s Xuanwu LAB

SkyLined and Soiax working with Trend
 Micro's Zero Day
Initiative



	Addressed a potential issue where
the application could be exposed to an Integer Overflow
vulnerability, which could lead to remote code
execution.
	kdot working with Trend Micro's
Zero 
Day Initiative





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit PhantomPDF 7.3.9

 

Release date: August 22, 2016

Platform: Windows

Summary

Foxit has released Foxit PhantomPDF 7.3.9, which address security
vulnerabilities that could potentially allow an attacker to execute remote
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PhantomPDF
	7.3.4.311 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit PhantomPDF, go to “Check for Update” and update
to the latest version.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed potential issues where
the application could be exposed to a TIFF Parsing
Out-of-Bounds Read/Write vulnerability, which could be
leveraged by attackers to execute remote code or leak
information.
	Ke Liu of Tencent’s Xuanwu
LAB
Steven Seeley of Source Incite 
5206560A306A2E085A437FD258EB57CE
working with Trend Micro's Zero Day Initiative
Steven
Seeley of Source Incite working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could be exposed to a Use-After-Free
vulnerability when attempting to parse malformed FlateDecode
Streams, which could be leveraged by attackers to leak
sensitive information or execute remote code.
	Rocco Calvi and Steven Seeley of
Source Incite

	Addressed potential issues where
the application could be exposed to an Out-Of-Bounds
Read/Write vulnerability when parsing JPEG2000 files, which
could be leveraged by attackers to leak information or
execute remote code.
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to memory corruption
vulnerability when parsing JPEG2000 files, which could cause
remote code execution.
	Ke Liu of Tencent’s Xuanwu
LAB

	Addressed a potential issue where
the application could be exposed to a DLL hijacking
vulnerability that could allow an unauthenticated remote
attacker to execute arbitrary code on the targeted
system.
	Himanshu Mehta

	Addressed potential issues where
the application could be exposed to a JPXDecode
Out-of-Bounds Read/Write vulnerability when processing
specially crafted PDF files with malformed JPXDecode
streams, which could cause information leak or remote code
execution (CVE-2016-6867).
	Steven Seeley of Source Incite

Kai Lu of Fortinet's FortiGuard Labs

	Addressed a potential issue where
the application could be exposed to an Out-of-Bounds Read
vulnerability when processing specially crafted BMP files,
which could cause information leak.
	Steven Seeley of Source
Incite
 5206560A306A2E085A437FD258EB57CE working with
Trend Micro's Zero Day Initiative

	Addressed a potential memory
corruption vulnerabilities which could cause the application
to crash unexpectedly (CVE-2016-6868).
	Marco Grassi (@marcograss) of
KeenLab (@keen_lab), Tencent
Kai Lu of Fortinet's
FortiGuard Labs 

	Addressed a potential issue where
the application could be exposed to a Use-After-Free Remote
Code Execution vulnerability when opening a XFA file whose
layout direction is set as “lr-tb”.
	Rocco Calvi

	Addressed a potential issue where
the application could be exposed to a FlatDecode
Use-After-Free Remote Code Execution vulnerability when
parsing the inline image in certain PDF file
(CVE-2016-6168).
	Steven Seeley of Source Incite,
working with Trend Micro's Zero Day Initiative
Kushal
Arvind Shah of Fortinet's FortiGuard Labs

	Addressed a potential issue where
the application could be exposed to a Safe Mode Bypass
Information Disclosure vulnerability when handling SWF
content that is embedded in a PDF file, which could be
leveraged by attackers to access user’s local files or
remote resources.
	Björn Ruytenberg working with Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to an exportData
Restrictions Bypass Remote Code Execution vulnerability,
which could be leveraged by attackers to execute a malicious
file.
	insertscript working with Trend
Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF TIFF
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability when converting certain TIFF file to PDF
file.
	Steven Seeley of Source Incite
working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG Parsing
Out-of-Bounds Read Information Disclosure vulnerability when
converting a JPEG file that contains incorrect EXIF data to
PDF file.
	AbdulAziz Hariri - Trend Micro Zero
Day Initiative working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could be exposed to a JPEG Parsing
Out-of-Bounds Read Information Disclosure vulnerability when
parsing a JPEG image with corrupted color component in a PDF
file.
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF GIF
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability when converting certain GIF file to PDF
file.
	kdot working with Trend Micro's
Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a ConvertToPDF BMP
Parsing Out-of-Bounds Write Remote Code Execution
vulnerability or a ConvertToPDF BMP Parsing Out-of-Bounds
Read Information Disclosure vulnerability when converting a
BMP file to PDF file.
	kdot and anonymous working with
Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to an Out-of-Bounds Read
vulnerability which could be leveraged by attackers to
execute remote code under the context of the current
process.
	Ke Liu of Tencent’s Xuanwu
LAB

	Addressed a potential issue where
the application could be exposed to a Heap Buffer Overflow
Remote Code Execution vulnerability when processing
specially crafted TIFF files with large SamplesPerPixel
values.
	Steven Seeley of Source Incite


	Addressed a potential issue where
the application could be exposed to a Stack Buffer Overflow
Remote Code Execution vulnerability when parsing an
unusually long GoToR string.
	Abdul-Aziz Hariri of Trend Micro
Zero Day Initiative, working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could crash unexpectedly when parsing a PDF
file that contains messy code in its image description.

	Rocco Calvi and Steven Seeley of
Source Incite, working with Trend Micro's Zero Day
Initiative

	Addressed a potential issue where
the application could be exposed to a Pattern Uninitialized
Pointer Remote Code Execution vulnerability when processing
a stretched image in certain PDF files.
	Steven Seeley of Source Incite,
working with Trend Micro's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to a Heap Overflow
vulnerability when parsing the content of a PDF file
containing incorrect Bezier data (CVE-2016-6169).
	Kai Lu of Fortinet's FortiGuard
Labs 





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader and Foxit PhantomPDF
7.3.4

 

Release date: March 16, 2016

Platform: Windows

Summary

Foxit has released Foxit Reader and Foxit PhantomPDF 7.3.4, which
address security vulnerabilities that could potentially allow an attacker to
execute remote code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.3.0.118 and earlier
	Windows

	Foxit PhantomPDF
	7.3.0.118 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, go
to “Check for Update” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could still use the pointer after the object
it pointed had been removed, which could cause an
application crash.
	Mateusz Jurczyk, Google Project
Zero

	Addressed a potential issue where
the application could crash caused by the error in parsing
malformed content stream.
	Ke Liu of Tencent’s Xuanwu LAB


	Addressed a potential issue where
the application recursively called the format error of some
PDFs and led to no response when opening the PDF.
	Ke Liu of Tencent’s Xuanwu LAB


	Addressed a potential issue where
the application could not parse the image content in the
document normally.
	Jaanus Kp, Clarified Security,
working with Trend Micro's Zero Day Initiative (ZDI)


	Addressed a potential issue where
the destructor of the object whose generation number is -1
in the PDF file could release the file handle which had been
imported by the application layer.
	Mario Gomes(@NetFuzzer), working
with Trend Micro's Zero Day Initiative (ZDI) 

	Addressed a potential issue where
the application could crash caused by the error in decoding
corrupted images during PDF conversion with the gflags app
enabled.
	AbdulAziz Hariri, working with
Trend Micro's Zero Day Initiative (ZDI)

	Addressed a potential issue where
XFA’s underlying data failed to synchronize with that of
PhantomPDF/Reader caused by the re-layout underlying
XFA.
	kdot, working with
Trend Micro's Zero Day Initiative (ZDI)

	Addressed a potential issue where
the application could call JavaScripts to do Save As or
Print when closing the document.
	AbdulAziz Hariri, working with
Trend Micro's Zero Day Initiative (ZDI)

	Addressed a potential issue where
the TimeOut function responded incorrectly and could cause
the application crash.
	AbdulAziz Hariri, working with
Trend Micro's Zero Day Initiative (ZDI)





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader and Foxit PhantomPDF
7.3

 

Release date: Jan. 20, 2016

Platform: Windows

Summary

Foxit has released Foxit Reader and Foxit PhantomPDF 7.3, which
address security vulnerabilities that could potentially allow an attacker to
execute remote code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.2.8.1124 and earlier
	Windows

	Foxit PhantomPDF
	7.2.2.929 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, go
to “Check for Update” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement

	Addressed a potential issue where
the application could be exposed to the Font Parsing
Use-After-Free Remote Code Execution Vulnerability.
	Mario Gomes(@NetFuzzer), working
with HP's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to the Global setPersistent
Use-After-Free Remote Code Execution Vulnerability.
	AbdulAziz Hariri, HPE Zero Day
Initiative, working with HP's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to the WillClose Action
Use-After-Free Remote Code Execution Vulnerability.
	AbdulAziz Hariri, HPE Zero Day
Initiative, working with HP's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to remote code execution
vulnerability when opening certain PDF file with images.

	Rocco Calvi, working with HP's Zero
Day Initiative

	Addressed a potential issue where
the application could be exposed to XFA FormCalc Replace
Integer Overflow Vulnerability.
	HPE Zero Day Initiative, working
with HP's Zero Day Initiative 

	Addressed a potential issue where
the application could be exposed to Remote Code Execution
Vulnerability due to JBIG2 Out-of-Bounds Read.
	kdot, working with HP's Zero Day
Initiative 

	Addressed a potential issue where
the application could crash unexpectedly when parsing
certain PDF files that contain malformed images.
	Francis Provencher,
COSIG 

	Addressed a potential issue where
the application could crash unexpectedly when converting
certain image with incorrect image data.
	kdot, working with HP's Zero Day
Initiative 

	Addressed a potential Microsoft
Windows Gdiplus GpRuntime::GpLock::GpLock Use-After-Free
Remote Code Execution Vulnerability.
	Jaanus Kp, Clarified Security,
working with HP's Zero Day Initiative

	Addressed a potential issue where
the application could be exposed to DLL hijacking
vulnerability when trying to load xpsp2res.dll or
phoneinfo.dll.
	Ke Liu of Tencent’s Xuanwu LAB






For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit Reader and Foxit PhantomPDF
7.2.2

 

Release date: October 8, 2015

Platform: Windows

Summary

Foxit has released Foxit Reader and Foxit PhantomPDF 7.2.2,
which fixed some security issues where the application could be exposed to
some vulnerabilities or crash unexpectedly. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.2.0.722 and earlier
	Windows

	Foxit PhantomPDF
	7.2.0.722 and earlier
	Windows





Solution

Update your applications to the latest versions by following one
of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, go
to “Check for Update” and update to the latest version.

	Click
here to download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential issue
where attacker could exploit a Foxit Cloud Plugin
vulnerability to execute arbitrary
code.
	Zhipeng Huo of Tencent's Xuanwu
Lab

	Addressed a
potential issue where the application could crash
unexpectedly when opening certain secured PDF files.

	kdot, working with
HP's Zero Day Initiative

	Addressed a
potential issue where the application could crash
unexpectedly when opening a PDF file that contains
incorrect gif data while being debugged by
GFlags.exe.
	Jaanus Kp of
Clarified Security, working with HP's Zero Day
Initiative

	Addressed a
potential issue where the application could crash
unexpectedly when opening a PDF file that contains
incorrect inline image while being debugged by
GFlags.exe.
	Jaanus Kp of
Clarified Security, working with HP's Zero Day
Initiative

	Addressed a
potential issue where the application could be exposed
to an Out-of-Bounds Read Vulnerability when opening
certain XFA forms.
	Jaanus Kp of
Clarified Security, working with HP's Zero Day
Initiative

	Addressed a
potential issue where the application could crash
unexpectedly when printing certain PDF files.
	AbdulAziz Hariri,
working with HP's Zero Day Initiative

	Addressed a
potential issue where the application could crash
unexpectedly when saving certain PDF files.
	AbdulAziz Hariri,
working with HP's Zero Day Initiative

	Addressed a
potential issue where the application could be exposed
to Foxit Cloud Update Service Local Privilege Escalation
Vulnerability.
	AbdulAziz Hariri
and Jasiel Spelman, working with HP's Zero Day
Initiative

	Addressed a
potential issue where the application could be exposed
to Use-After-Free Vulnerability when executing print()
or referencing App after closing the document.
	AbdulAziz Hariri,
working with HP's Zero Day Initiative

	Addressed a
potential issue where the application could crash
unexpectedly due to recursive reference.
	Guillaume Endignoux
of ANSSI





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader and Foxit PhantomPDF
7.2

 

Release date: July 29, 2015

Platform: Windows

Summary

Foxit has released Foxit Reader and Foxit PhantomPDF 7.2, which
address security vulnerabilities that could potentially allow an attacker to
execute remote code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.1.5.425 and earlier
	Windows

	Foxit Enterprise Reader 
	7.1.5.425 and earlier
	Windows

	Foxit PhantomPDF
	7.1.5.425 and earlier
	Windows





Solution

Update your applications to the latest versions by following one
of the instructions below.

	From the “Help” tab of Foxit Reader or Foxit PhantomPDF, go
to “Check for Update” and update to the latest version.

	Click
here to download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a
potential issue where attackers could exploit a PDF
creator plugin vulnerability to execute arbitrary
code.
	Sascha Schirra

	Addressed a
potential issue where the applications could be exposed
to a remote code execution when converting a TIFF file
to PDF file.
	Steven Seeley of
Source Incite, working with HP's Zero Day Initiative


	Addressed a
potential issue where the applications could be exposed
to a remote code execution vulnerability when converting
a GIF file to PDF file.
	Steven Seeley of
Source Incite, working with HP's Zero Day Initiative


	Addressed a
potential issue where memory corruption may occur when
opening certain XFA forms.
	Kai Lu of
Fortinet's FortiGuard Labs





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit MobilePDF for Android
3.3.2

 

Release date: May 18, 2015

Platform: Android

Summary

Foxit has released Foxit MobilePDF for Android 3.3.2, which
addresses a security vulnerability that could potentially allow an attacker
to intercept the username and password of user’s cloud service. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit MobilePDF for Android
	3.3.1 and earlier
	Android

	Foxit MobilePDF Business for Android
	3.3.1 and earlier
	Android





Solution

Update your applications to the latest versions by following one
of the instructions below.

	Click
here to download the updated version of Foxit MobilePDF for
Android.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential issue
where credentials of cloud services may be exposed to
MITM attackers when users log in the cloud services from
within Foxit MobilePDF.
	Sam Bowne





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader, Foxit Enterprise Reader,
and Foxit PhantomPDF 7.1.5

 

Release date: April 24, 2015

Platform: Windows

Summary

Foxit has released Foxit Reader, Foxit Enterprise Reader, and
Foxit PhantomPDF 7.1.5, which address security vulnerabilities that could
potentially allow an attacker to execute controlled crash. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.1.0.306 and 7.1.3.320
	Windows

	Foxit Enterprise Reader 
	7.1.0.306 and 7.1.3.320
	Windows

	Foxit PhantomPDF
	7.1.0.306, 7.1.2.311, 7.1.3.320
	Windows





Solution

Update your applications to the latest versions by following one
of the instructions below.

	From the “Help” tab of Foxit Reader, Foxit Enterprise
Reader, or Foxit PhantomPDF, go to “Check for Update” and
update to the latest version.

	Click
here to download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit Enterprise Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential issue
where memory corruption may occur when parsing a PDF
file that contains an invalid stream.

	Francis Provencher of Protek
Research Lab's

	Addressed a
potential issue where memory corruption may occur during
digital signature verification.
	Kai Lu of
Fortinet's FortiGuard Labs





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader, Foxit Enterprise Reader,
and Foxit PhantomPDF 7.1

 

Release date: March 9, 2015

Platform: Windows

Summary

Foxit has released Foxit Reader, Foxit Enterprise Reader, and
Foxit PhantomPDF 7.1, which address security vulnerabilities that could
potentially allow an attacker to execute malicious file or controlled
crash. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	7.0.6.1126 and earlier
	Windows

	Foxit Enterprise Reader 
	7.0.6.1126 and earlier
	Windows

	Foxit PhantomPDF
	7.0.6.1126 and earlier
	Windows





Solution

Update your applications to the latest versions by following one
of the instructions below.

	From the “Help” tab of Foxit Reader, Foxit Enterprise
Reader, or Foxit PhantomPDF, go to “Check for Update” and
update to the latest version.

	Click
here to download the updated version of Foxit Reader.

	Click
here to download the updated version of Foxit Enterprise
Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a
potential issue where attackers could exploit a Foxit
Cloud plugin vulnerability to execute malicious
files.
	Aljaz Ceru of InSec

	Addressed a
potential issue where memory corruption may occur when
converting a GIF file with an invalid value in
LZWMinimumCodeSize, which could lead to a controlled
crash execution.
	Francis Provencher
of Protek Research Lab's

	Addressed a
potential issue where memory corruption may occur when
converting a GIF file with an invalid value in Ubyte
Size in its DataSubBlock Structure, which could lead to
a controlled crash execution.
	Francis Provencher
of Protek Research Lab's





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit PDF SDK ActiveX 5.0.2.924


 

Release date: September 29, 2014

Platform: Windows

Summary

Foxit has released Foxit PDF SDK ActiveX 5.0.2.924, which addresses
a security vulnerability where applications built on Foxit PDF SDK ActiveX could
be exposed to Buffer Overflow. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF SDK ActiveX 
	2.3 to 5.0.1.820
	Windows





Solution

Please contact our support team via
1-866-693-6948 (24/7) to upgrade to Foxit PDF SDK ActiveX 5.0.2.924.





Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where applications built on Foxit PDF SDK ActiveX may
be exposed to Buffer Overflow when invoking “SetLogFile
()” method.
	Andrea Micalizzi (rgod), working
with Hewlett-Packard's Zero Day Initiative (ZDI)





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader, Foxit Enterprise Reader, and
Foxit PhantomPDF 6.2.1

 

Release date: July 1, 2014

Platform: Windows

Summary

Foxit has released Foxit Reader, Foxit Enterprise Reader, and Foxit
PhantomPDF 6.2.1 which address a security vulnerability that could potentially
allow an attacker to execute malicious file.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	6.2.0.429 and earlier
	Windows

	Foxit Enterprise Reader 
	6.2.0.429 and earlier
	Windows

	Foxit PhantomPDF
	6.2.0.429 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader, Foxit Enterprise Reader, or
Foxit PhantomPDF, go to “Check for Update” and update to the
latest version.

	Click here to
download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit Enterprise Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue caused by the Stored XSS vulnerability when reading
and displaying filenames and their paths on the “Recent
Documents” section from the Start Page.
	Bernardo Rodrigues





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit PDF SDK DLL 3.1.1.5005

 

Release date: March 9, 2015

Platform: Windows

Summary

Foxit has released Foxit PDF SDK DLL 3.1.1.5005, which addresses a
security vulnerability that could potentially allow an attacker to execute
remote code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit PDF SDK DLL 
	3.1.1.2927 and earlier
	Windows





Solution

Please contact our support team via
1-866-693-6948 (24/7) to upgrade to Foxit PDF SDK DLL 3.1.1.5005.





Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where applications built on Foxit PDF SDK DLL may be
exposed to Buffer Overflow Remote Code Execution
Vulnerability when invoking “FPDFBookmark_GetTitle()”
method.
	Hewlett-Packard’s Zero Day
Initiative (ZDI)





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 6.1.4

 

Release date: February 19, 2014

Platform: Windows

Summary

Foxit has released Foxit Reader 6.1.4, which addresses a security
vulnerability that could potentially allow an attacker to execute malicious
file.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	6.1.2.1224
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” tab of Foxit Reader, go to “Check for
Update” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where Foxit Reader tried to load imgseg.dll, which
could be exploited.
	Hossam Hosam





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit Reader 5.4.5 and Foxit PhantomPDF
5.4.3

 

Release date: February 7, 2013

Platform: Windows

Summary

Foxit has released Foxit Reader 5.4.5 and Foxit PhantomPDF 5.4.3,
which address a security vulnerability that could potentially allow an attacker
to execute arbitrary code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.4.4 and earlier
	Windows

	Foxit PhantomPDF
	5.4.2 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader or Foxit PhantomPDF, go
to “Check for Updates Now” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.

	Click here to
download the updated version of Foxit PhantomPDF.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where attackers can exploit a web browser plugin
vulnerability to execute arbitrary code.
	Secunia





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Advanced PDF Editor 3.0.4.0


 

Release date: January 14, 2013

Platform: Windows

Summary

Foxit has released Foxit Advanced PDF Editor 3.0.4.0, which
addresses a security vulnerability that could potentially allow an attacker to
execute arbitrary code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Advanced PDF Editor 
	3.0.0.0
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where hackers can run arbitrary code by repairing a
STATUS_STACK_BUFFER_OVERRUN exception.
	CERT Coordination Center





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit Reader 5.4.3

 

Release date: September 26, 2012

Platform: Windows

Summary

Foxit has released Foxit Reader 5.4.3, which addresses a security
vulnerability that could potentially allow an attacker to execute arbitrary
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.4.2.0901 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where the insecure application loading libraries could
be exploited to attack the application.
	Parvez Anwar of Secunia SVCRP






For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 5.4

 

Release date: September 6, 2012

Platform: Windows

Summary

Foxit has released Foxit Reader 5.4, which addresses a security
vulnerability that could potentially allow an attacker to execute malicious
file. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.3.1.0606 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue where Foxit Reader may call and run malicious code in
the Dynamic Link Library (DLL) file.
	Remy Brands





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 5.3

 

Release date: May 3, 2012

Platform: Windows

Summary

Foxit has released Foxit Reader 5.3, which addresses a security
vulnerability that could potentially allow an attacker to execute remote
code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.1.4.0104 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed an issue
where users cannot open the attachments of PDF files in XP
and Windows7.
	John Leitch of Microsoft
Vulnerability Research





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit Reader 5.1.3

 

Release date: December 7, 2011

Platform: Windows

Summary

Foxit has released Foxit Reader 5.1.3, which addresses a security
vulnerability that could potentially allow an attacker to execute controlled
crash.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.1.0.1021 and earlier 
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue caused by the cross-border assignment of an array
which may result in memory corruption vulnerabilities when
opening certain PDF files.
	Alex Garbutt of iSEC Partners,
Inc.





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 5.0.2

 

Release date: July 21, 2011

Platform: Windows

Summary

Foxit has released Foxit Reader 5.0.2, which addresses security
vulnerabilities that could potentially allow an attacker to execute arbitrary
code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	5.0 and earlier 
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue of arbitrary code execution when opening certain PDF
files.
	Rob Kraus of Security Consulting
Services (SCS) 

	Addressed an issue of
Foxit Reader when opening certain PDF files in a web
browser.
	Dmitriy Pletnev of
Secunia Research





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 5.0

 

Release date: May 26, 2011

Platform: Windows

Summary

Foxit has released Foxit Reader 5.0, which addresses a security
vulnerability that could potentially allow an attacker to execute malicious
code. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	4.3.1.0218 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed an issue of
Foxit Reader when opening some affected PDF files.
	Brett Gervasoni of Sense of
Security Pty Ltd





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 4.3.1.0218

 

Release date: February 24, 2011

Platform: Windows

Summary

Foxit has released Foxit Reader 4.3.1.0218, which addresses a
security vulnerability that could potentially allow an attacker to execute
remote code.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	4.3 and earlier 
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed an issue of
the Foxit Reader software that is caused by illegal
accessing memory.
	Secunia Research





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Foxit Reader 4.2

 

Release date: September 29, 2010

Platform: Windows

Summary

Foxit has released Foxit Reader 4.2, which addresses a security
vulnerability that could potentially allow an attacker to compromise the digital
signature. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	4.1 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
identity theft issue caused by the security flaw of the
digital signature.
	Foxit





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 4.1.1.0805

 

Release date: August 6, 2010

Platform: Windows

Summary

Foxit has released Foxit Reader 4.1.1.0805, which addresses a
security vulnerability that could potentially allow an attacker to execute
controlled crash.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	4.0 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
crash issue caused by the new iPhone/iPad jailbreak program
efficiently and prevents the malicious attacks to your
computer.
	Foxit





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 4.0.0.0619

 

Release date: June 29, 2010

Platform: Windows

Summary

Foxit has released Foxit Reader 4.0.0.0619, which addresses a
security vulnerability that could potentially allow an attacker to execute
controlled crash.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	4.0 and earlier
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue caused by numerical overflow in the freetype engine
when opening some PDF files.
	David Seidman of Microsoft and
Microsoft Vulnerability Research (MSVR)





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 3.2.1.0401

 

Release date: April 1, 2010

Platform: Windows

Summary

Foxit has released Foxit Reader 3.2.1.0401, which addresses a
security vulnerability that could potentially allow an attacker to execute the
embedded program inside a PDF.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	3.2.0.0303
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click here to
download the updated version.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue that Foxit Reader runs an executable embedded program
inside a PDF automatically without asking for user's
permission.
	Didier Stevens





For more information, please contact Foxit Security Response
Team at [email protected].
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Security updates available in Firefox Plugin 1.1.2009.1117 for Foxit
Reader

 

Release date: November 17, 2009

Platform: Windows

Summary

Foxit has released Firefox Plugin 1.1.2009.1117 for Foxit Reader,
which addresses memory corruption vulnerability. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	3.1.2.1013 and 3.1.2.1030
	Windows





Solution

	Click here to
download the updated version of Firefox Plugin for Foxit Reader.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue caused by an error in the Foxit Reader plugin for
Firefox (npFoxitReaderPlugin.dll), which could be exploited
to trigger a memory corruption.
	Foxit and Secunia





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 3.0 and JPEG2000/JBIG2
Decoder 

 

Release date: June 19, 2009

Platform: Windows

Summary

Foxit has released Foxit Reader 3.0 Build 1817 and JPEG2000/JBIG2
Decoder add-on version 2.0 Build 2009.616, which address security
vulnerabilities that could potentially result in invalid address access.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	3.0
	Windows

	JPEG2000/JBIG2 Decoder Add-on
	2.0.2009.303
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click
here to download the updated version of Foxit Reader.

	Click here
to download the updated version of JPEG2000/JBIG2 Decoder Add-on.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a potential
issue related to negative stream offset (in malicious
JPEG2000 stream) which caused reading data from an
out-of-bound address.
	CERT

	Addressed a potential
issue related to error handling when decoding JPEG2000
header, an uncaught fatal error resulted a subsequent
invalid address access.
	CERT





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 3.0 Build 1506

 

Release date: March 9 2009

Platform: Windows

Summary

Foxit has released Foxit Reader 3.0 Build 1506, which addresses
stack-based buffer overflow and security authorization bypass
vulnerabilities.

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	3.0
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a stack-based
buffer overflow vulnerability.
	Foxit Security Response Team


	Addressed a security
authorization bypass vulnerability.
	Foxit Security Response
Team





For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in Foxit Reader 2.3 Build 3902

 

Release date: March 9 2009

Platform: Windows

Summary

Foxit has released Foxit Reader 2.3 Build 3902, which addresses
security authorization bypass vulnerability. 

Affected versions


	Product
	Affected versions
	Platform

	Foxit Reader 
	2.3
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click here to
download the updated version of Foxit Reader.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a security
authorization bypass vulnerability.
	Foxit Security Response Team






For more information, please contact Foxit Security Response
Team at [email protected].




Security updates available in JPEG2000/JBIG Decoder Add-on
2.0.2009.303

 

Release date: March 9, 2009

Platform: Windows

Summary

Foxit has released JPEG2000/JBIG Decoder Add-on 2.0.2009.303, which
addresses JBIG2 symbol dictionary processing vulnerability. 

Affected versions


	Product
	Affected versions
	Platform

	JPEG2000/JBIG Decoder Add-on
	2.0.2008.715 in Foxit Reader 3.0 and Foxit Reader 2.3
	Windows





Solution

Update your applications to the latest versions by following one of
the instructions below.

	From the “Help” menu of Foxit Reader, go to “Check for
Updates Now” and update to the latest version.

	Click here to
download the updated version of JPEG2000/JBIG Decoder Add-on.







Vulnerability details

	Brief
	Acknowledgement


	Addressed a JBIG2
symbol dictionary processing vulnerability. 
	Secunia





For more information, please contact Foxit Security Response
Team at [email protected].




Ask Toolbar ToolbarSettings ActiveX Control Buffer Overflow


 

The ask.com toolbar Foxit is bundling, is not the same version as reported on
secunia.com, and doesn't have the reported vulnerability.

Click here to check the
related report on secunia.com

















Get Support

	North America
	1-866-693-6948
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